Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

fiber uplinking NX5020 to NX7000

I intend to uplink NX5020 2 fiber ports to a NX7000 2 fiber ports running port-channel.

I have created on both sides:

interface port-channel10

  switchport mode trunk

  description NX7000 (SFP) <--> NX5000 (SFP)

I have configure fiber interfaces like this

interface Ethernet1/1

switchport mode trunk

description description NX7000 (SFP) <--> NX5000 (SFP)

channel-group 10

no shutdown

interface Ethernet1/2

switchport mode trunk

description description NX7000 (SFP) <--> NX5000 (SFP)

channel-group 10

no shutdown

Is there any specific fiber port on NX5020 to uplink to NX7000?

Thanks

Rosa

Everyone's tags (4)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Cisco Employee

fiber uplinking NX5020 to NX7000

Hello Rosa,

There is no specific fiber port in N5K or N7K for configuring as uplink port.

as per the conf pasted , its looks like we have to enable feature lacp  and configure the port channel as

channel-group 10 mode active

This schould be done in both the devices (N7K and N5K)

Regards

Partha

Cisco Employee

fiber uplinking NX5020 to NX7000

Rosa,

yes , you can use it.

In contrast to a static link aggregation, LACP provides the following advantages:[8]

  • Even if one physical links fails, it will detect if the point-to-point connection is using a media converter, so that the link status at the switching port remains up. Because LACPDUs do not form a component of this connection, the link will be removed from the link aggregate. This ensures that packets will not be lost due to the failed link.
  • Both of the devices can mutually confirm the LAG configuration. With static link aggregation, errors in the configuration or wiring will often not be detected as quickly.

Regards

Partha

7 REPLIES
Cisco Employee

fiber uplinking NX5020 to NX7000

Hello Rosa,

There is no specific fiber port in N5K or N7K for configuring as uplink port.

as per the conf pasted , its looks like we have to enable feature lacp  and configure the port channel as

channel-group 10 mode active

This schould be done in both the devices (N7K and N5K)

Regards

Partha

New Member

fiber uplinking NX5020 to NX7000

Ooopss!

NX7000 is running version5.2(7).

By now it has fiber trunk connection with 4 Cisco6509 boxes running fine, feature lacp is disables.

NX5020 is running version 4.0(1a)N2(1).

It is being deployed.

Version 4 does not have any feature.

So what do you suggest - try and see ?

Regards

Rosa

Cisco Employee

fiber uplinking NX5020 to NX7000

Rosa,

You can verify the what are the feature available in  4.0(1a)N2(1). using show feature. I believe it will have feature lacp if it supports vpc

If feature lacp not available in N5K, you can give try specifying channel group 10 mode on ( I believe u might have already done it)

Regards

Partha

New Member

fiber uplinking NX5020 to NX7000

Partha as NX7000 has feature lacp disabled can I use "channel group 10 mode on " on both sides ?

Qhat are the benefis of using lacp ?

Regards

Rosa

Cisco Employee

fiber uplinking NX5020 to NX7000

Rosa,

yes , you can use it.

In contrast to a static link aggregation, LACP provides the following advantages:[8]

  • Even if one physical links fails, it will detect if the point-to-point connection is using a media converter, so that the link status at the switching port remains up. Because LACPDUs do not form a component of this connection, the link will be removed from the link aggregate. This ensures that packets will not be lost due to the failed link.
  • Both of the devices can mutually confirm the LAG configuration. With static link aggregation, errors in the configuration or wiring will often not be detected as quickly.

Regards

Partha

New Member

fiber uplinking NX5020 to NX7000

Partha lacp is realy great!

What a pity, but must upgrade nx-os.

Regards

Rosa

New Member

fiber uplinking NX5020 to NX7000

It works fine !

199
Views
0
Helpful
7
Replies
CreatePlease login to create content