Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

files copy crossing office LAN is super slow

Two computers (XP and Win7) connected on office LAN, cisco 2960, not same switches, but all in the same rack, and link togeter, same IP subnet, tried to copy some kind of 26G files from one to another, using Windows share folders, and it showed need 23 hours to finish the copying.

It's not the first time, actually we always experienced very slow speed when copying files on Windows share folders.  Did not see any particualler message on the switch.  ports are all full/100m. 

Any clues or advises where I should start with to address this very annoying issue.

Thanks a lot.

9 REPLIES

files copy crossing office LAN is super slow

What sort of throughput do you get when using FTP to copy the file across?

Please remember to rate useful posts, by clicking on the stars below.

Cisco Employee

files copy crossing office LAN is super slow

Also good to start with small network diagram and configuration of switch ports connecting the switches and connected to PCs.

Nik

files copy crossing office LAN is super slow

Hi,

Please check the switch ports end to end  if have been configured as Full Duplex.

Also check the interfaces of the switch for late collisions, drops etc.

The problem described above is common for switch ports configured as hald duplex

Plz, update with the sh interface x.x output if this does not solve the problem

Hope that helps

Vasilis

New Member

files copy crossing office LAN is super slow

switch ports are set auto, but 'show inter status' showed all connected ports are full/100.  Didn't see errors, collisions or drops on 'show interface ...' .

And this issue happened many times, on many different PCs, connecting on many different ports.....:(

files copy crossing office LAN is super slow

OK. I assume that the show interface output also show full-duplex.

did you check the logs, the cpu load during the problem?

New Member

files copy crossing office LAN is super slow

No logs showed any outstanding issues on my switches. 

Actually, I experienced this issues for many years, on many different network environments(not all networks I worked before).  Ping tests with payload were all good, show interface out put was good, no valuable logs, most applications ran smoothly, but just copying files via shared folders was always very slow.

I am thinking this should be some common issues, but not a particular case on my current office LAN.  Really want to find out why and get it fixed.

Super Bronze

files copy crossing office LAN is super slow

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

What the physical topology of these switches?  Also, Minkdennis asked an important question, same issue if you do a copy with FTP?

Hall of Fame Super Gold

files copy crossing office LAN is super slow

switch ports are set auto, but 'show inter status' showed all connected ports are full/100.  Didn't see errors, collisions or drops on 'show interface ...' .

Please post the output to the following commands to both switchport ends:

1.  sh interface ; and

2.  sh contr e

Purple

Re: files copy crossing office LAN is super slow

  You say the ports are set as auto , just to verify when you do a "sh int status"  it shoudl look like this   .  If it doesn't have the little "a" in front of full  then it's not auto and is hardcoded . If it's hardcoded and the client nics are set as auto then you have a duplex mismatch which will cause all kinds of errors because the nic will then default to half duplex .  Verify the switchports and the nics are auto for speed and duplex. Although even if mismatched it shouldnt take 23 hours.

962
Views
0
Helpful
9
Replies
CreatePlease to create content