cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
735
Views
0
Helpful
2
Replies

Forwarding ports trough specific interface

alister9000
Level 1
Level 1

Hi everyone,

Im trying to configure some ports to be forwarded out to a serial interface, we have installed voip phones (not cisco) and i want them to use only the serial port.

this is the sh run output. needless to say i have erased some sentitive information:

!

!

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description  inside

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

no mop enabled

!

interface GigabitEthernet0/1

description Outside

ip address 1.1.1.1 255.255.255.0

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface Serial0/0/0

description T1

no ip address

encapsulation frame-relay IETF

!

interface Serial0/0/0.500 point-to-point

ip address 2.2.2.2 255.255.255.252

frame-relay interface-dlci 500

!

ip default-gateway 1.1.1.1

ip forward-protocol nd

!

!

ip nat inside source list 101 interface GigabitEthernet0/1 overload

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1

!

access-list 101 permit ip 192.168.1.0 0.0.0.255 any

access-list 101 permit ip 192.168.2.0 0.0.0.255 any

access-list 102 permit tcp any range 4444 4446 any

access-list 102 permit udp any range 30000 38000 any

access-list 102 permit udp any eq 5060 any eq 5060

access-list 102 permit udp any eq 6060 any eq 6060

!

!

i know that im missing the ip nat statements but i dont want to do it right now as it will interfere with everyones job if it doesnt work. i dont know if the access lists will work can anyone help me with it?

thanks

2 Replies 2

Reza Sharifi
Hall of Fame
Hall of Fame

Hi,

The way your router is currently configured, everything will go out using interface GigabitEthernet0/1

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1

If you want some traffic to go out using theGigabitEthernet0/1 interface and some traffic using GigabitEthernet0/1 than you need to configure PBR.

Have a look at this link for info and example:

http://www.cisco.com/en/US/docs/switches/datacenter/sw/5_x/nx-os/unicast/configuration/guide/l3_pbr.html

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009481d.shtml

HTH

i am using a cisco 1921 router and the command to enable pbr does not exists...i guess its not supported (?), is there any other way i can do this ?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card