Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Forwarding UDP Broadcast

I have two networks, with one router in between (192.168.100.0 & 211.0.0.0) in which I am trying to forward a udp broadcast packets. Network 211.0.0.0 is sending out a udp broadcast message to a number of node on this network and I am simply trying to forward that broadcast over to the 192.168.100.0 network. So far I haver been unsuccesful and I'm not sure what I am doing wrong.

I have used the IP help address command along with the IP directed-broadcost

interface fa 0/0

ip adresss 192.168.100.254

ip help address 211.0.0.255

interface fa 0/1

ip address 211.0.0.1

ip directed-broadcast

I was not able to receive any udp broadcast on 192.168.100.0

I have tried using the IP forward protocol  to enable forward of UDP packerts.... still no luck

Any help would be appreciated..

6 REPLIES

Re: Forwarding UDP Broadcast

Hi Jekood

Did you have a look at this URL ? It gives you all configurations needed for this UDP broadcasts to work.. what is the UDP port number that you are trying to broadcast ?

https://www.cisco.com/en/US/docs/internetworking/design/guide/nd2019.html

Hope this helps.. all the best

Raj

New Member

Re: Forwarding UDP Broadcast

Thanks....but I looked at this URL in great detail.

I'm almost positive I've missing something that very simple. I don't think its that difficult to forward a udp broadcast.  Maybe I get a copy of my running config to post on here. Again any help would be appreicated

Re: Forwarding UDP Broadcast

yes.. can you post your configs and the udp port details/application details for us to have a look at the issue ?

Thanks


Raj

New Member

Re: Forwarding UDP Broadcast

Ok here is my running config. The last thing I tried was the IP Helper command. I also tried using the ip forward protocol udp 7501 with access-list control (7501 being the port that the UDP broadcast is being sent out).

ip subnet-zero
no ip source-route
no ip gratuitous-arps
!
!
ip cef
!
!
no ip bootp server
no ip domain lookup
ip domain name yourdomain.com
ip multicast-routing
ip ips po max-events 100
no ftp-server write-enable
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
description SEAWATCH LAN Connection
ip address 192.168.100.254 255.255.255.0
ip broadcast-address 192.168.100.255
ip helper-address 211.0.0.255
duplex full
speed auto
no mop enabled
!
interface FastEthernet0/1
description SCCS LAN Connection
ip address 211.0.0.1 255.255.255.0
ip broadcast-address 211.0.0.255
ip directed-broadcast
duplex auto
speed auto
!
ip classless
no ip forward-protocol udp 7501
ip route profile
!
!
no ip http server
ip http access-class 23
no ip http secure-server
ip pim bidir-enable
ip pim autorp listener
ip pim accept-rp auto-rp
!
access-list 100 permit ip host 211.0.0.11 192.168.100.0 0.0.0.255
access-list 100 permit udp any any
access-list 115 permit udp any any eq 7501

!
!
control-plane
!
!
!
!
!
!
!
!
banner login ^CSEAWATCH Router ^C
banner motd ^C
-----------------------------------------------------------------

Access to this device or the attached network is prohibited.
Violators will be prosecuted to the fullest extent of both civil
and criminal law.

-----------------------------------------------------------------
^C
!
line con 0
exec-timeout 0 0
logging synchronous
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet ssh
line vty 5 15
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end

SEAWATCH#

New Member

Forwarding UDP Broadcast

Hi

the global configuration command "ip forward-protocol udp" is missing from your configuration. You need this command for forwarding to occur. Depending on the udp service you are trying to forward you may also have to explicitly declare the udp port number. I think the ones that are automatically forwarded are TIME, TFTP, DNS, NetBIOS and TACACS and a few others that I can't remember but if you use IOS help you should be able to figure out the port you need to allow.

HTH

Hall of Fame Super Silver

Forwarding UDP Broadcast

This is a pretty old post to bring up. But it presents a somewhat interesting question about why it did not work. You are correct that one of the problems is that if you want to forward a udp port that is not one of the standard ports then you need to use the ip forward-protocol command.

But there is also another serious issue in what the original poster was attempting to do. He has put the ip helper-address on the interface where he wants to receive the forwarded broadcast and has put the ip directed-broadcast on the interface where the original broadcast is received. This is backwards. The ip helper-address should be configured on the interface where the broadcast originates and the ip directed-broadcast should be in the interface that receives the forwarded broadcast.

The original poster says that he feels that he was missing something simple. And he was missing the concept of which interface gets which command.

HTH

Rick

7994
Views
0
Helpful
6
Replies