Cisco Support Community
Community Member

Get IOS on Flash Card

I have this 2801 in a critical environment.  We had a brief power blip, and even though the router is on UPS, something happened.  Anyway, after working with TAC, they determined the flash card had gone corrupt.  Lucky for me I had a spare 2801 in my office, I grabbed that flash card and plugged it in and we're back up and going.

TAC sent me a new flash card.  No matter what I do, I cannot get IOS to load on this thing!  I am stuck in rommon.  Here's what I've tried:

tftpdnld in rommon, times out. 

using another 2801 as a tftp-server.  doesn't complete.

using xmodem.  ugh.  never seems to get started.

booting the router with a known good flash card, so I can get to ena, and "copy tftp flash". 

have used tftpd32, Solar Winds TFTP server, What's Up Gold TFTP server, and open source tftp from sourceforge.  With the tftp32, it always gets to exactly 73% download and then times out (it says, I have a feeling it's noty really a timeout).  I have tried having the router and tftp server the only devices on a switch, i have tried the router plugged directly into the tftp server with a cross connect cable.  No happiness.  The open source tftp server reported (and I have to paraphrase, I am not near the router) "client does not support block number recount" or something like that.  The client being the 2801. 

The iOS file is about 45M.  Someone asked me if the flash card was formatted...would that matter? would the tftp even start if it wasn't?

OK, I've gone on long enough.  TAC is dispatching a new card AND 2801!  I think this is overkill!  I hate to let a flash card best me, lol!  Anyone have other ideas of what I could have tried?

Everyone's tags (3)
Hall of Fame Super Gold

Get IOS on Flash Card

Four things you can do:

1.  Pump the IOS from your TFTP server to the router's CF; or

2.  Get a multi-card reader and copy-and-paste.  Before you do this, make sure the new CF is properly formated using FAT16 or use the other router to format (using the command "format flash:"); or

3.  You can create a "spare" using a USB thumb drive; or

4.  Combine #3 and #4.

If you are going down the road of the USB thumb drive, a few things to consider:

1.  Not all USB thumb drives are supported.  So you'll have to do a number of trial-and-errors;

2.  USB support on an ISR G1 (like your 2800) size up to 2Gb (but some have sworn to get 4Gb but I haven't tried it); and

3.  Format the USB using the router or your client using FAT16

CreatePlease to create content