Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Ghosting image casting problem

Hi,

One of my sites has dual 6513s (sup720, 3b), multiple vlans, 3750 stacks on 5 floors trunked to the 6513s. The 6513s are trunked together. Each 3750 stack has 2 trunks, one to each 6513.

Staff at that site report they have problems with Ghost image casting.

Specifically:

If Ghost server and workstations are in the same VLAN, and on the same 3750 stack, ghosting proceeds normally.

If Ghost server and workstations are in the same VLAN, but server is on 3750 stack A and workstations are on 3750 stack B, ghosting fails.

In the failing scenario, Ghosting traffic should travel down stack A's trunk, through the 6513, then back up stack B's trunk.

I'm guessing there's some additional config needed at the 6513 to enable this traffic, but I haven't a clue as to what specific config would do the trick.

Anyone?

TIA...

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: Ghosting image casting problem

On the 6513 L3 interfaces:

ip pim sparse-mode

That may be enough to get it working.

On the 3750 trunks:

ip igmp snooping vlan 1 mrouter interface XX0/1

I've got the same situation on multiple 6500s- and I just enabled it on the L3 interfaces.

The L2 6500s doing multicast don't understand that ip igmp snooping VLAN configuration, but they show the mrouters as being the uplink.

The l2 3750 doing multicast to the same environment also has the mrouter as being the uplink.

I AM seeing a metric ton of discards on these vlans though, but I'm not sure if it's related. (theoretically, not much should be on these networks but multicast.

http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a008059a9df.shtml

That document looks to have been written for you.

2 REPLIES
Bronze

Re: Ghosting image casting problem

On the 6513 L3 interfaces:

ip pim sparse-mode

That may be enough to get it working.

On the 3750 trunks:

ip igmp snooping vlan 1 mrouter interface XX0/1

I've got the same situation on multiple 6500s- and I just enabled it on the L3 interfaces.

The L2 6500s doing multicast don't understand that ip igmp snooping VLAN configuration, but they show the mrouters as being the uplink.

The l2 3750 doing multicast to the same environment also has the mrouter as being the uplink.

I AM seeing a metric ton of discards on these vlans though, but I'm not sure if it's related. (theoretically, not much should be on these networks but multicast.

http://www.cisco.com/en/US/products/hw/switches/ps708/products_tech_note09186a008059a9df.shtml

That document looks to have been written for you.

New Member

Re: Ghosting image casting problem

Hey...

Well, that was quite helpful.

I put "ip pim sparse-dense-mode" on a single vlan, and the guys on site now report ghosting across switches works for that vlan.

Strangely, before adding the ip pim config, the sh ip igmp snooping mrouter command produced blank output. After putting it on vlan 131, the sh command listed a port for both vlan 11 and vlan 131. Don't know how vlan 11 got in the mix...

Anyway, thanks.

152
Views
0
Helpful
2
Replies
CreatePlease to create content