Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Giga Connexion KO

Hello,

As I mentioned in another thread, I am currently doing an apprenticeship program in a business with lots of Cisco switches and routers.

One of the employee, tried to connect 2 switches between each other using the Gigabit interfaces and using the module GLC-SX-MM for fiber. The result was no connection and the interfaces KO. As I am here to learn more about cisco... I set up 2 switches in lab to reproduce exactly the same situation.

1. 1x Switch 3750 and 1x Switch 2960.

2. I did the trunking using and ethernet cable and everything worked fine and could make the pings....

3. I then set up the modules GLC-SX-MM and inserted the fiber. At the point everything was KO. I tried again with the ethernet cable and it was OK.

4. The interfaces are up, the config is correct.... I tried with other modules and still KO.

5 What is interesting is that they have other 3750 and 2960 on their network and everything is OK.

Any ideas ?

thanks a lot.

Manu

6 REPLIES
Bronze

Re: Giga Connexion KO

Did you cross your TX and RX fibers on the other switch? I've been burned by that before. Also, if the SFP ports are dual purpose (either RJ-45 or SFP), try to define the media type under the interface config. I believe the command is media-type rj45|sfp

New Member

Re: Giga Connexion KO

Thanks a lot for your answer.

For the 2960 : the media type worked or I could say that I manage to run that command.

For the 3750 : this command doesn't exist. I did go into the config mode for the Interface Gigabit 1/0/1 but I can't run the media type ?

Thanks again.

Manu

Bronze

Re: Giga Connexion KO

Yeah, that command only works if the ports are dual-purpose.

Did you verify that the TX fiber from one switch was going to RX on the other and vice versa?

New Member

Re: Giga Connexion KO

Hello,

Yes I checked the fiber to make sure it was fine on both end. I even tried it the other way aroun lol to see if I was doing it wrong. Well this is the WE here in France, so I am going out to take a walk and get my mind working for me.

thanks again and hopefully I will find the answer soon !!! and thanks for your advices again.

manu

New Member

Re: Giga Connexion KO

Me, again !! well I checked the interface and it is in SFP for the 3750 but still KO between both switches. I tried with the ethernet cable and it is OK. ??

I have to study more things it looks like. If anyone has more idea, it would be appreciated.

Thanks again.

Manu

New Member

Re: Giga Connexion KO

Hello again,

So I manage to make it work with the module fiber. It was a problem with the configuration.

But now I have another question.

I want to order some GLC-SX-MM to use on the switches which will be enough for the distance... I have some spares here that I am using in lab for testing but they don't work ???? when I use the GLC-LH-SM, everything is fine. I thought that maybe the GLC-SX-MM was KO but I have 10 of them and I don't think that all of them are KO.

Is there a difference between them or something I should do on the switches ??? (except the differences in distance...). Weird as this is working with the LH-SM, so it should also work with the SX-MM ???

Thanks.

Manu

222
Views
0
Helpful
6
Replies