Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Gigabit interface can't go to 1000Mb/s

I have a 2960 with a following relevant config:

interface Port-channel1

switchport mode trunk

!

interface GigabitEthernet0/1

switchport mode trunk

channel-group 1 mode active

!

interface GigabitEthernet0/2

switchport mode trunk

bandwidth 1000000

channel-group 1 mode active

And stacked 3750's with relevant config:

interface Port-channel8

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/0/24

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 8 mode active

!        

interface GigabitEthernet2/0/24

switchport trunk encapsulation dot1q

switchport mode trunk

bandwidth 1000000

channel-group 8 mode active

!        

Port gi0/1 is connected to gi1/0/24, and gi0/2 is connected to gi2/0/24

When I check channel groups, I see:

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

8      Po8(SU)         LACP      Gi1/0/24(P) Gi2/0/24(s)

So port 2/0/24 is in suspended mode. It's the same on 2960

Details are:

3750#sh etherchannel 8 detail

Group state = L2

Ports: 2   Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol:   LACP

Minimum Links: 0

        Ports in the group:

        -------------------

Port: Gi1/0/24

------------

Port state    = Up Mstr Assoc In-Bndl

Channel group = 8           Mode = Active          Gcchange = -

Port-channel  = Po8         GC   =   -             Pseudo port-channel = Po8

Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.

        A - Device is in active mode.        P - Device is in passive mode.

Local information:

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Gi1/0/24  SA      bndl      32768         0x8       0x8     0x119       0x3D 

Partner's information:

                  LACP port                        Admin  Oper   Port    Port

Port      Flags   Priority  Dev ID          Age    key    Key    Number  State

Gi1/0/24  SA      32768     0021.56a4.3000   5s    0x0    0x1    0x19    0x3D 

Age of the port in the current state: 0d:19h:34m:40s

Port: Gi2/0/24

------------

Port state    = Up Cnt-bndl Suspend Not-in-Bndl

Channel group = 8           Mode = Active          Gcchange = -

Port-channel  = null        GC   =   -             Pseudo port-channel = Po8

Port index    = 0           Load = 0x00            Protocol =   LACP

Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.

        A - Device is in active mode.        P - Device is in passive mode.

Local information:

                            LACP port     Admin     Oper    Port        Port

Port      Flags   State     Priority      Key       Key     Number      State

Gi2/0/24  SA      susp      32768         0x8       0x0     0x219       0x45 

Age of the port in the current state: 0d:00h:20m:37s

Probable reason: speed of Gi2/0/24 is 100M, Gi1/0/24 is 1000M

        Port-channels in the group:

        ---------------------------

Port-channel: Po8    (Primary Aggregator)

------------

Age of the Port-channel   = 0d:19h:51m:12s

Logical slot/port   = 10/8          Number of ports = 1

HotStandBy port = null

Port state          = Port-channel Ag-Inuse

Protocol            =   LACP

Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits

------+------+------+------------------+-----------

  0     00     Gi1/0/24 Active             0

Time since last port bundled:    0d:19h:34m:43s    Gi1/0/24

3750#sh int gi2/0/24          

GigabitEthernet2/0/24 is up, line protocol is down (suspended)

  Hardware is Gigabit Ethernet, address is 0017.946f.0798 (bia 0017.946f.0798)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

2960#sh int gi0/2

GigabitEthernet0/2 is up, line protocol is down (suspended)

  Hardware is Gigabit Ethernet, address is 0021.56a4.301a (bia 0021.56a4.301a)

  MTU 1500 bytes, BW 1000000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive not set

  Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000BaseTX

If I do "speed 1000" on 3750, gi0/2 on 2960 goes down, although gi0/2 support 1000Mb/s.

How to solve this?

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Gigabit interface can't go to 1000Mb/s

Hello Boban,

1000 Mbps operation requires a cable with all four pairs

try to change the cable between C2960:gi0/2 and C3750, first of all remove port channel configuration do shut/no shut interfaces an check if you are able to see both links running at 1000 Mbps before applying port channel configuration again

Eventually swap the cabling and check if the problem follows the cable.

Edit:

to force the speed manually you have to do it on both sides, but it is not recommended with gigabit ethernet

Hope to help

Giuseppe

10 REPLIES
Hall of Fame Super Silver

Re: Gigabit interface can't go to 1000Mb/s

Hello Boban,

1000 Mbps operation requires a cable with all four pairs

try to change the cable between C2960:gi0/2 and C3750, first of all remove port channel configuration do shut/no shut interfaces an check if you are able to see both links running at 1000 Mbps before applying port channel configuration again

Eventually swap the cabling and check if the problem follows the cable.

Edit:

to force the speed manually you have to do it on both sides, but it is not recommended with gigabit ethernet

Hope to help

Giuseppe

Hall of Fame Super Gold

Re: Gigabit interface can't go to 1000Mb/s

Hello Boban,

1000 Mbps operation requires a cable with all four pairs

Nope.  All you need is three.  If you run the TDR, you need only A, B and D.  Pair C controlls PoE and Pair D controls GigabitEthernet.

Hall of Fame Super Silver

Gigabit interface can't go to 1000Mb/s

Hello Leo,

as far as I know 802.3ab uses 4 pairs, PoE is a different matter

see

http://en.wikipedia.org/wiki/Gigabit_Ethernet

Hope to help

Giuseppe

Hall of Fame Super Gold

Gigabit interface can't go to 1000Mb/s

as far as I know 802.3ab uses 4 pairs, PoE is a different matter

I ain't going to debate on you with this because I know you are right.  I was, however, talking about the TDR results taken from a Cisco switch. 

Hall of Fame Super Gold

Gigabit interface can't go to 1000Mb/s

If I do "speed 1000" on 3750, gi0/2 on 2960 goes down, although gi0/2 support 1000Mb/s. 

Run TDR on both switches.  Here are the commands:

1.  Command:  test cable tdr interface ;

2.  Wait for approximately 5 to 7 seconds;

3.  Command:  sh cable tdr interface ;  and

4.  Please post the output to the command.

New Member

Re: Gigabit interface can't go to 1000Mb/s

3750#show cable-diagnostics tdr interface gigabitEthernet 2/0/24

TDR test last run on: May 15 11:10:27

Interface Speed Local pair Pair length        Remote pair Pair status

--------- ----- ---------- ------------------ ----------- --------------------

Gi2/0/24  auto  Pair A     2    +/- 4  meters Pair B      Normal             

                Pair B     2    +/- 4  meters Pair A      Normal             

                Pair C     0    +/- 4  meters Pair C      Open               

                Pair D     0    +/- 4  meters Pair D      Open   

2960#sh cable-diagnostics tdr interface gi0/2

TDR test last run on: May 15 11:09:11

Interface Speed Local pair Pair length        Remote pair Pair status

--------- ----- ---------- ------------------ ----------- --------------------

Gi0/2     100M  Pair A     N/A                Pair A      Normal             

                Pair B     N/A                Pair B      Normal             

                Pair C     4    +/- 2  meters Pair C      Open               

                Pair D     4    +/- 2  meters Pair D      Open 

Hall of Fame Super Gold

Gigabit interface can't go to 1000Mb/s

Giuseppe is right.  The output from both switches is showing that Pair "D" is in Open Circuit.  Pair "D" controls GigabitEthernet.   This is why the interface will only negotiate to 100 Mbps.

Change the patch cable. 

New Member

Gigabit interface can't go to 1000Mb/s

You could also issue show connect status to find out how the auto negotiation had worked and at what speed they have settled down at ... that would give us a fair idea about on which speed the both ends are operating and negotiated.

Just my 2 cents.

-Vijay

New Member

Re: Gigabit interface can't go to 1000Mb/s

There is no "show connect status" command...

Purple

Gigabit interface can't go to 1000Mb/s

  He meant "show interface status"  . 

1394
Views
0
Helpful
10
Replies
CreatePlease to create content