Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

GLBP is not working,(not load balancing the LAN traffic)

Hi, all,

I have 2*3825 routers configured with GLBP, but traffic is moving only with one router it only fallback on other router when the 1st router is isolated.

diagram

LAN=======>ASA(Routed mode with active-standby)======>one cisco L2 switch========>2 *3825 Router

When traceroute from LAN PC show that traffic is only taking via single router.

LAN gatway is defined as ASA inside address and in ASA a default route pointed to GLBP address.

RTR1 config:

==========

int g0/0

ip address 1.1.1.2 255.255.255.0

glbp 1 ip 1.1.1.1

glbp 1 preemt

RTR2 config:

==========

int g0/0

ip address 1.1.1.3 255.255.255.0

glbp 1 ip 1.1.1.1

glbp 1 preemt

Is there any other config is required? Immediate help will be highly appriciated...

Regards

Madhu

4 REPLIES
Hall of Fame Super Silver

Re: GLBP is not working,(not load balancing the LAN traffic)

Hello Madhu,

what you see is normal because the ASA is the only client.

GLBP works by providing different answers (AVF mac addresses) to ARP requests for GLBP VIP address, once the ASA has performed the ARP request it gets one answer and it uses it for 4 hours (ARP entry standard timeout).

GLBP works well in a vlan where there are multiple clients.

Here of you use two static routes or you move to a dynamic routing protocol (EIGRP or OSPF are supported on the ASA  in recent SW versions).

You could use two HSRP groups instead making edge router1 active for group1 and edge router2 active for group2.

the ASA can use two default routes with different next-hops that are out the same interface.

Hope to help

Giuseppe

New Member

Re: GLBP is not working,(not load balancing the LAN traffic)

Hi Giuseppe

Even i cleared the arp on router and ASA, but still its taking the same path..when i remove the router 1 then it takes 2nd router path

both router is connected to internet with two diffrent ISP, One ISP is using class B address and other using class C with same mask-bit(30-bit)

regards

madhu

New Member

Re: GLBP is not working,(not load balancing the LAN traffic)

this is happening with me also. I have having asa firewall on the inside of wan routers. the firewall learns the first mac address only from the glbp pair and keeps forwarding the packet only to it until it goes down. the second avf doesnt come in picture until in becomes active. round-robin load balancing is not working for me. By the way i am using asa in routed mode and i am not doing any NAT over my asa. The routers are recieving request from different ip subnets from inside lan.

Re: GLBP is not working,(not load balancing the LAN traffic)

i guess you can try with the weighting and host dedpendant option to load balance between two routers...

Refer the cisco document which will clear you the scenario and thato an extentt helps you

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t15/feature/guide/ft_glbp.html#wp1040173

2088
Views
4
Helpful
4
Replies
CreatePlease to create content