Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

GLBP Not Load-Balancing Properly?

Hi

I having configured GLBP and using Host-dependent as a load-balancing algorithem. But all the traffice is passing through one rtr only.

For your reference i have attached my topology diagram.

There are two L3 Switches running HSRP for each vlan interface. For half of the vlans, L3-SW-1 is active and for rest L3-SW-2 is active. and pc's are assigned the respective vlan's vip. These L3's are connected to a 3500 L2 Switch which also connects the Core rtrs. which are running glbp.

RTR-A is configured as AVG. I am having a default route in Both L3's to point the traffic to GLBP VIP 10.9.0.1

But all the traffice is passing via RTR-A and both the are learning the VMAC of RTR-A only. I tried clearing the arp-cache but they learn the same VMAC.

I also tried changing the AVG to RTR-B but still no results. Configrations are as follows-

RTR-A# interface FastEthernet0/4

ip address 10.9.0.74 255.255.255.0

glbp 1 ip 10.9.0.1

glbp 1 priority 120

glbp 1 preempt

glbp 1 weighting 110

glbp 1 load-balancing host-dependent

glbp 1 forwarder preempt delay minimum 10

RTR-B# interface FastEthernet0/4

ip address 10.9.0.75 255.255.255.0

glbp 1 ip 10.9.0.1

glbp 1 preempt

glbp 1 weighting 110

glbp 1 load-balancing host-dependent

glbp 1 forwarder preempt delay minimum 10

L3-SW-1#int vlan1

ip add 10.9.0.2 255.255.255.0

standby 1 ip 10.9.0.3

standby 1 priority 150

standby 1 preempt

int vlan2

ip add 10.10.0.2 255.255.255.0

standby 2 ip 10.10.0.3

standby 2 preempt

L3-SW-2#

int vlan1

ip add 10.9.0.4 255.255.255.0

standby 1 ip 10.9.0.3

standby 1 preempt

int vlan2

ip add 10.10.0.4 255.255.255.0

standby 2 ip 10.10.0.3

standby 2 priority 120

standby 2 preempt

Any suggetions apprecited?

Thanks in Advance.

Regards

Pankaj

344
Views
0
Helpful
0
Replies
CreatePlease to create content