Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

glbp

Hi,

I have this configuration on two routers:

Router 1

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.1.120.254 255.255.255.0 secondary

ip address 10.1.6.163 255.255.248.0

ip helper-address 10.4.0.51

ip helper-address 10.4.0.52

ip accounting output-packets

ip accounting access-violations

service-policy input MARKING

no ip mroute-cache

no cdp enable

glbp 10 ip 10.1.6.162

glbp 10 ip 10.1.120.1 secondary

glbp 10 preempt

glbp 10 load-balancing weighted

Router 2

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.1.120.253 255.255.255.0 secondary

ip address 10.1.6.164 255.255.248.0

ip helper-address 10.4.0.51

ip helper-address 10.4.0.52

ip accounting output-packets

ip accounting access-violations

service-policy input MARKING

no ip mroute-cache

no cdp enable

glbp 10 ip 10.1.6.162

glbp 10 ip 10.1.120.1 secondary

glbp 10 priority 254

glbp 10 preempt

glbp 10 load-balancing weighted

end

but a show glbp int show that just one forwarder is active int group:

sh glbp f0/0.1

FastEthernet0/0.1 - Group 10

State is Active

7 state changes, last state change 1w3d

Virtual IP address is 10.1.6.162

Secondary virtual IP address 10.1.120.1

Hello time 3 sec, hold time 10 sec

Next hello sent in 0.520 secs

Redirect time 600 sec, forwarder time-out 14400 sec

Preemption enabled, min delay 0 sec

Active is local

Standby is 10.1.6.163, priority 100 (expires in 9.480 sec)

Priority 254 (configured)

Weighting 100 (default 100), thresholds: lower 1, upper 100

Load balancing: weighted

There are 2 forwarders (1 active)

Forwarder 1

State is Listen

2 state changes, last state change 1w4d

MAC address is 0007.b400.0a01 (learnt)

Owner ID is 0002.2c80.4100

Redirection enabled, 599.476 sec remaining (maximum 600 sec)

Time to live: 14399.476 sec (maximum 14400 sec)

Preemption enabled, min delay 30 sec

Active is 10.1.6.163 (primary), weighting 100 (expires in 9.476 sec)

Arp replies sent: 80876

Forwarder 2

State is Active

5 state changes, last state change 1w3d

MAC address is 0007.b400.0a02 (default)

Owner ID is 0002.2c79.e000

Redirection enabled

Preemption enabled, min delay 30 sec

Active is local, weighting 100

Arp replies sent: 80874

In this case I don't have load balancing.

Someone can give my an advice?

2 REPLIES
New Member

Re: glbp

Have you tried leaving the 'glbp 10 priority 254' statement off router 2 to see if it impacts glbp at all?

New Member

Re: glbp

glbp will just route traffic to both routers but dis will be done on the weight u specify.for example in your sample, if one packet goes to one router about 2.5 will go to the next router. it is simply routing over un-equal path here, kind of. If u want load-sharing u either use a 3rd-vendor like f5 or u use cisco oer.

142
Views
0
Helpful
2
Replies