Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

GRE Tunnel Doesnt Go Down

Hi Friends,

A peculiar problem it seems. I have a GRE tunnel between Router A & B.

If i do a manual shut down on tunnel on router A, the line protocol goes down on router B.. coz of the keepalives set...this is fine. However if the tunnel is manually shut on router B, the line protocol doesnt go down on router A ( which it should coz of the keepalives set)

Both ends have a /30 tunnel ip, source & dest ip * keepalives of 10 3.

Will really appreciate your comments on this

Regards,

Vicky

2 REPLIES
Hall of Fame Super Silver

Re: GRE Tunnel Doesnt Go Down

Vicky

This does sound a bit odd. I believe that there is some difference on the routers that is causing this (either some difference in how they are configured or some difference in what you are doing on the routers to shut down something).

One of the things about GRE keepalives is that the functionality of keepalive for the GRE tunnel is not dependent on the other end supporting GRE keepalive. I am not sure whether this is a factor in your situation or not.

Can you provide configuration details from both routers? And perhaps a bit more specific information about what is shut down on each router?

HTH

Rick

New Member

Re: GRE Tunnel Doesnt Go Down

Hi Rick,

Thanks for your reply. Have pasted the configs along with the IOS versions. Am just shutting the GRE tunnels turnwise at both the ends. Butt as mentioned below when i manually shut down the tunnel on router B, line protocol still stays up at router A ( even after the keepalive duration)

By using Tunnel mode ipip, the same results were observed.

Router A

interface Tunnel1

description *SECONDARY TUNNEL*

ip address 7.x.x.x.255.255.252

ip mtu 1500

keepalive 3 2

tunnel source 1.1.1.1

tunnel destination 2.2.2.2

end

IOS:c1841-spservicesk9-mz.124-1c.bin

Router B

interface Tunnel12

description Secondary Tunnel for Galaxy

ip address 7.x.x.x.255.255.252

ip directed-broadcast

ip mtu 1500

keepalive 3 2

tunnel source 2.2.2.2

tunnel destination 1.1.1.1

IOS:rsp-pv-mz.120-30.S1.bin

120
Views
0
Helpful
2
Replies