Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Bronze

gre tunnel with dynamic IP

Dear ,

I'm trying to create GRE tunnel between two Cisco 877 routers by using ddns

interface Tunnel1

ip address 10.10.10.1 255.255.255.252

tunnel source Dialer1

tunnel destination hat45.dnsalias.net

The domain name under hat45.dnsalias.net is resolving immediately to IP and when I do show run tunnel destination is showing me as IP address and this is making problem . Because remote end point for the tunnel is dynamic IP and it's changing everytime . I want to use tunnel destination as domain name and not as IP ? Is there is any way

Regards

4 REPLIES

Re: gre tunnel with dynamic IP

I would assume that the IP address is changing frequently because you are not keeping the tunnel up.

Perhaps you could keep the tunnel up using GRE Keepalives.

e.g.:

interface Tunnel0

keepalive 5 4

The only time you would likely see a change in IP, would be following a power outage.

Not the perfect solution you are seeking, but it could significantly improve your situation.

New Member

Re: gre tunnel with dynamic IP

Try:

interface tunnel1

ip ddns update hat45.dnsalias.net

ip address 10.10.10.1 255.255.255.252

tunnel source Dialer1

tunnel destination hat45.dnsalias.net

Also search Cisco docs for "ip ddns" show and debug commands, options.

Bronze

Re: gre tunnel with dynamic IP

The issue is that when i type

" tunnel destination hat45.dnsalias.net " its translating to IP .

As i know with IPsec it's working ,but i want to user GRE

http://www.cisco.com/en/US/tech/tk583/tk372/technologies_configuration_example09186a00801dddbb.shtml

Regards,

Haris

New Member

Re: gre tunnel with dynamic IP

Did you ever find a solution on that? i want to do exactly the same thing..

3114
Views
0
Helpful
4
Replies
CreatePlease to create content