Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Hard Code duplex and speed on 2960

I tried to hard code duplex and speed on 2960 switch gig ports. I have 3 switches in series. I go to the last one code speed 1000 and duplex full and it takes the commands. Then On the second I code the same to the connecting port afterword the last switch loses the connection. I can get the connection back by setting the second switch back to

Speed auto and duplex auto. Any suggestion

2 REPLIES
New Member

Re: Hard Code duplex and speed on 2960

You are using a switch with a dual purpose uplink so you have to specify "media-type rj-45" or "media-type sfp" in order to set the duplex; however, for gigabit you should always be running full duplex would you not ? I have had to set the speed and duplex when using 100FX type SFPs in these switches and this does fix that problem.

Randy

Purple

Re: Hard Code duplex and speed on 2960

Sounds like you are using the wrong type of cable and the switch is using mdix to correct the cable . Mdix will only work when the speed and duplex is set to auto ,once you hardcode it will kill that connection. If the device on the other end is a cisco device you can leave it as auto without a problem . Sounds like you are using a straight thru cable instead of a xover cable. Gig is full duplex anyway and I don't think you gain much by hardcoding a gig port .

870
Views
0
Helpful
2
Replies