Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

cco
New Member

Hard coding 100Mbps/Full-Duplex issue

When connecting a cisco WS-C2960G-24TC-L switch to a cisco WS-C3560G-24TS switch with 100Mbps Full Duplex hard coded on both ends, the connection fails (interface goes down on both ends) with the following error message on the 3560 switch: "10w1d: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on GigabitEthernet0/2

(not full duplex), with S100573 GigabitEthernet0/19 (full duplex)". We tried both cross and straight cables with no results. Setting the ports to Auto/Auto on both sides makes the link go up with 1000Mbps Full Duplex. hard coding the ports to 100Mbps Half Duplex works fine too. But we need the link to operate at 100Mbps Full. Thanks

4 REPLIES

Re: Hard coding 100Mbps/Full-Duplex issue

Hi,

- The cabling should be crossed (TypeA in one end and TypeB in the other end).

- Category 5e or 6

- Cable length?

Regards,

Dandy

cco
New Member

Re: Hard coding 100Mbps/Full-Duplex issue

As I said we tried both straight and cross. We use Cat5e 3 meters patch cords. Both straight and cross failed.

Purple

Re: Hard coding 100Mbps/Full-Duplex issue

Try turning off mdix on the ports on both sides and see what happens .

cco
New Member

Re: Hard coding 100Mbps/Full-Duplex issue

Tried that too but no luck. Am suspecting kind of bug in one of the switches.

231
Views
0
Helpful
4
Replies