Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Having trouble manufacturing a routing loop

Greetings!

I'm  practicing some routing techniques related to the Implementing Cisco IP  Routing class and exam.  I'm trying to manufacture a routing loop in  order to correct it with route maps and prefix lists, etc.  I can't seem  to get the routing loop to appear the way I thought it would, and I  would like a hand. 

Please consider the topology attached to this post.

The  lab is intended to feature mutual redistribution at two points,  creating a routing loop.  When I redistribute EIGRP into OSPF at R1, for  example, R2 gets the routes expected in it's routing table.  R2's next  hop is R1 to reach the 192.168.253/254.0 networks (this is expected for  now).  When I try to redistribute EIGRP into OSPF at R2 there seems to  be no effect.  R1 maintains its routing table - it's as if the  redistribution commands at R2 never happened.  If I redistribute in the  opposite order (R2 before R1) I have the opposite scenario.

Can  someone please tell me what I'm doing wrong?  I have the lab sitting in  front of me, so I'll be happy to provide any other details required. 

Thanks for your time.

Eric

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions

Having trouble manufacturing a routing loop

One of the redistribution rules is that only routes from the routing table are considered for redistribution, i.e. only the best routes. In this way R1 learns the routes to 192.168.253 & 254 from R2. Because they are redistributed routes, they are flagged as External type 2 which is the default value.

When R1 subsequently considers the routes to redistribute, for 192.168.253 & 254 it only has the OSPF routes because those are currently in the routing table.

Another default behavior for OSPF is to only redistribute Internal routes.

Because the routes to 192.168.253 & 254 are of the type E2, they are not considered for redistribution.

The EIGRP routes are overruled by OSPF because of their lower AD so they cannot be used. (not in table)

You will get different results when you change the redistribute as follows:

redistribute ospf 1 metric 1 1 255 1 300 match external 2

http://www.cisco.com/en/US/partner/docs/ios/12_2t/ip_route/command/reference/p2ftind2.html#wp1041381

regards,

Leo

4 REPLIES

Having trouble manufacturing a routing loop

This is a classic problem related to administrative distance.

After redistibuting on R1, R2 learns a route via OSPF.

R2 is however also having a route via EIGRP and this one is preferred because of its lower AD 90 vs 110.

We will need routing tables and configs in order to help you out but fiddling this one out for yourself is of course an excellent learning experience. Have fun!

regards,

Leo

New Member

Having trouble manufacturing a routing loop

Yes, but the .253/.254 are being redistributed into EIGRP.  Distributing EIGRP into OSPF should make the OSPF path look better, am I not correct?

Configs and routing tables are as follows.  Thanks again for your help.

R1:

Building configuration...

Current configuration : 943 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname ro1

!

!

ip subnet-zero

!

!

no ip domain-lookup

!

!

!

!

interface FastEthernet0/0

ip address 10.2.7.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

ip address 192.168.2.1 255.255.255.0

no fair-queue

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/1

ip address 10.3.7.1 255.255.255.0

!

router eigrp 5

redistribute ospf 1 metric 1 1 255 1 300

network 10.3.7.0 0.0.0.255

network 192.168.2.0

no auto-summary

eigrp log-neighbor-changes

!

router ospf 1

router-id 1.1.1.1

log-adjacency-changes

redistribute eigrp 5 subnets

network 10.2.7.0 0.0.0.255 area 0

!

ip classless

ip http server

ip pim bidir-enable

!

!

alias exec blank copy flash:blank-config.txt start

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

login

R1's routing table:

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets

C       10.3.7.0 is directly connected, Serial0/1

C       10.2.7.0 is directly connected, FastEthernet0/0

O E2 192.168.254.0/24 [110/20] via 10.2.7.2, 00:07:54, FastEthernet0/0

D    192.168.1.0/24 [90/2681856] via 192.168.2.2, 00:12:33, Serial0/0

O E2 192.168.253.0/24 [110/20] via 10.2.7.2, 00:07:54, FastEthernet0/0

C    192.168.2.0/24 is directly connected, Serial0/0

R2:

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname ro2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

no ip domain lookup

no ip dhcp use vrf connected

!

!

interface FastEthernet0/0

ip address 10.2.7.2 255.255.255.0

duplex auto

speed auto

!


!

interface FastEthernet2/0

no ip address

shutdown

duplex auto

speed auto

!

interface Serial2/0

ip address 10.3.7.2 255.255.255.0

!

interface Serial3/0

ip address 192.168.1.1 255.255.255.0

!

interface Serial3/1

no ip address

shutdown

no dce-terminal-timing-enable

!

interface Serial3/2

no ip address

shutdown

no dce-terminal-timing-enable

!

interface Serial3/3

no ip address

shutdown

no dce-terminal-timing-enable

!

interface Vlan1

no ip address

!

router eigrp 5

redistribute ospf 1 metric 1 1 255 1 300

network 10.3.7.0 0.0.0.255

network 192.168.1.0

no auto-summary

!

router ospf 1

router-id 2.2.2.2

log-adjacency-changes

redistribute eigrp 5 subnets

network 10.2.7.0 0.0.0.255 area 0

!

ip http server

no ip http secure-server

!

ip classless

!

!

!

!

control-plane

!

alias exec blank copy flash:blank-config.txt start

alias exec frame copy flash:FrameSwitch.txt start

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

login

!

!

end

R2's routing table:

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets

C       10.3.7.0 is directly connected, Serial2/0

C       10.2.7.0 is directly connected, FastEthernet0/0

D EX 192.168.254.0/24 [170/2560512256] via 192.168.1.2, 00:10:20, Serial3/0

                      [170/2560512256] via 10.3.7.1, 00:10:20, Serial2/0

C    192.168.1.0/24 is directly connected, Serial3/0

D EX 192.168.253.0/24 [170/2560512256] via 192.168.1.2, 00:10:20, Serial3/0

                      [170/2560512256] via 10.3.7.1, 00:10:20, Serial2/0

D    192.168.2.0/24 [90/2681856] via 10.3.7.1, 00:14:54, Serial2/0

R3:

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname ro4

!

!

!

!

!

!

ip subnet-zero

no ip domain-lookup

!

!

!

!

interface Ethernet0

ip address 192.168.253.1 255.255.255.0

no keepalive

!

interface Ethernet1

ip address 192.168.254.1 255.255.255.0

no keepalive

!

interface Serial0

ip address 192.168.2.2 255.255.255.0

no fair-queue

clockrate 56000

!

interface Serial1

ip address 192.168.1.2 255.255.255.0

clockrate 56000

!

router eigrp 5

redistribute connected metric 1 1 255 1 300

network 192.168.1.0

network 192.168.2.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

ip http server

!

!

line con 0

exec-timeout 0 0

logging synchronous

line aux 0

line vty 0 4

!

end

R3's routing table:

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 2 subnets

D       10.3.7.0 [90/2681856] via 192.168.2.1, 00:15:37, Serial0

                 [90/2681856] via 192.168.1.1, 00:15:37, Serial1

D EX    10.2.7.0 [170/2560512256] via 192.168.2.1, 00:15:37, Serial0

                 [170/2560512256] via 192.168.1.1, 00:15:37, Serial1

C    192.168.254.0/24 is directly connected, Ethernet1

C    192.168.1.0/24 is directly connected, Serial1

C    192.168.253.0/24 is directly connected, Ethernet0

C    192.168.2.0/24 is directly connected, Serial0

Having trouble manufacturing a routing loop

One of the redistribution rules is that only routes from the routing table are considered for redistribution, i.e. only the best routes. In this way R1 learns the routes to 192.168.253 & 254 from R2. Because they are redistributed routes, they are flagged as External type 2 which is the default value.

When R1 subsequently considers the routes to redistribute, for 192.168.253 & 254 it only has the OSPF routes because those are currently in the routing table.

Another default behavior for OSPF is to only redistribute Internal routes.

Because the routes to 192.168.253 & 254 are of the type E2, they are not considered for redistribution.

The EIGRP routes are overruled by OSPF because of their lower AD so they cannot be used. (not in table)

You will get different results when you change the redistribute as follows:

redistribute ospf 1 metric 1 1 255 1 300 match external 2

http://www.cisco.com/en/US/partner/docs/ios/12_2t/ip_route/command/reference/p2ftind2.html#wp1041381

regards,

Leo

New Member

Re: Having trouble manufacturing a routing loop

Yes, thank you for reminding me of things I should know or remember if I'm going to be taking the exam next week.  This is absolutely correct, but my problem was that of metrics.  In the lab I was trying to recreate, I missed the part where the redistributed routes were seeded in such a way that the routing protocols were stepping on each other.  I tweaked my configs and now I've got a real nasty loop going on.  Now the fun starts!

Thanks for your time sir!

875
Views
0
Helpful
4
Replies
CreatePlease to create content