Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

having trouble setting up my 2950

Recently got a 2950 24 port to replace my "dumb hub". Figured it would be nice to practice my cisco on it.

I completely reset everything. atm, all I am doing is trying to set it up to be a dumb hub....

My network tri looks like   MODEM---->router---->Switch----computer

port 1 to router, port 2 is to laptop

I did this to it:

switch>enable

switch#config terminal

switch(config)#interface range fa0/1 - 24

switch(config-if-range)#switchport host

switch(config-if-range)#end

switch#write mem

My current running config:

Current configuration : 2275 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Switch

!

!

ip subnet-zero

!

ip ssh time-out 120

ip ssh authentication-retries 3

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/2

switchport mode access

spanning-tree portfast

=========

Switch#show vlan

VLAN Name                             Status    Ports

---- -------------------------------- --------- -------------------------------

1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4

                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8

                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12

                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16

                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20

                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24

1002 fddi-default                     act/unsup

1003 token-ring-default               act/unsup

1004 fddinet-default                  act/unsup

1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1    enet  100001     1500  -      -      -        -    -        0      0

1002 fddi  101002     1500  -      -      -        -    -        0      0

1003 tr    101003     1500  -      -      -        -    -        0      0

1004 fdnet 101004     1500  -      -      -        ieee -        0      0

1005 trnet 101005     1500  -      -      -        ibm  -        0      0

I have tried setting this thing up the last few days with no luck. I can only console. It never pings when tryin gto setup the vlan. open to any ideas or suggestions. Would like to get it working for http/telnet, but setting that i figured out how to do. Just my switch never talks to my router....

Everyone's tags (5)
1 ACCEPTED SOLUTION

Accepted Solutions
Gold

Re: having trouble setting up my 2950

the int Vlan 1 is shutdown, that might be why switch and router cant connect n ping.

int vlan 1

no shut

but as for the switching itself, this shouldnt be an issue!

what's the ip addresses of the PC and the router? do you have good physical connections?

Hope it Helps,

Soroush.

Hope it Helps!

Soroush.
10 REPLIES
Gold

having trouble setting up my 2950

hi brian,

you want to ping your switch from the router? if yes, did u set up an IP address for ur switch?

can you ping ur router from ur computer or thats disconnected too?

HTH,

plz Rate if it helped,

Soroush.

Hope it Helps!

Soroush.
New Member

having trouble setting up my 2950

i did not setup an Ip. I have tried to do that before witn no luck. I know how to set it, just it never seems to connect to my router.

at this point, All I want it to do is act like a hub.

Gold

Re: having trouble setting up my 2950

you have a Management vlan, by default its Vlan 1. you go to interface vlan 1, set an ip address in ur segment's ip range, and there you go. thats because you have Layer 2 switch. Only one ip address n its for management purposes!

interface vlan 1

ip address x.x.x.x

exit

Hope it Helps,

Soroush.

Hope it Helps!

Soroush.
Gold

Re: having trouble setting up my 2950

have u tried erasing to the factory default n see how it goes?

conf t

write erase

and power cycle.

HTH,

Soroush.

Hope it Helps!

Soroush.
New Member

Re: having trouble setting up my 2950

You need to setup a management ip on vlan 1

Config t

Int vlan 1

Ip address 192.168.0.2 255.255.255.0

Sent from Cisco Technical Support iPhone App

New Member

having trouble setting up my 2950

Why do I need to setup the Vlan if I only want to use it as a hub? Isn't the vlan for admin use only??

I did it anyways:

Switch>en

Switch#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#int vlan 1

Switch(config-if)#ip address 192.168.2.2 255.255.255.0

Switch(config-if)#exit

Switch(config)#exit

still have the same issue. computer connected to switch won't connect to the lan.

router does not see switch, switch won't ping the router....

interface Vlan1

ip address 192.168.2.2 255.255.255.0

no ip route-cache

shutdown

!

ip http server

!

line con 0

line vty 5 15

!

!

end

Brian

New Member

having trouble setting up my 2950

I have completely reset this switch a few times....

Gold

Re: having trouble setting up my 2950

the int Vlan 1 is shutdown, that might be why switch and router cant connect n ping.

int vlan 1

no shut

but as for the switching itself, this shouldnt be an issue!

what's the ip addresses of the PC and the router? do you have good physical connections?

Hope it Helps,

Soroush.

Hope it Helps!

Soroush.
New Member

having trouble setting up my 2950

ok, forgot to do a no shut, did that.

It does work now. To be honest, I think my issue was the switch was still plugged into my old hub, then to the router.

either way it is working now!

now to get the web interface working and I'll be a happy camper!

Gold

Re: having trouble setting up my 2950

the hub is a transparent device, so it shouldnt make a difference, unless its damaged.

btw glad its fixed

mark the question as answered, helps others with similar issues find an answer.

CheerZ!


Soroush.

Hope it Helps!

Soroush.
828
Views
0
Helpful
10
Replies
CreatePlease login to create content