Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Having trouble with configuring 2 vlans on the same switch

First, some background on what I am trying to do. We have a Steelhead riverbed device (used for bit caching) at a remote location. In order to make the passthrough work on the riverbed, I need to do one of two things. One is to plug the WAN connections and the connection into a dumb switch, which has the desired effect. The other option, which I prefer, is to set up a seperate vlan for three switchports that will essentially act as a seperate swich on the same physical switch (2950).

Even though traffic is flowing now with using the switch, I am having two issues. The first is that I keep getting the following error between the switchports that are on two different vlans:

000413: Nov 3 15:50:03.870 PST: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered

on FastEthernet0/22 (2), with SW-SPRINN-2950-1.redlion.com FastEthernet0/15 (1).

000414: Nov 3 15:50:03.874 PST: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered

on FastEthernet0/15 (1), with SW-SPRINN-2950-1.redlion.com FastEthernet0/22 (2).

Also, with my WAN connections on vlan 2 (the new, seperate vlan), I am unable to manage my switch remotely via telnet.

This is the configuration for the effected switchports and other information as well:

interface FastEthernet0/15

description Riverbed LAN interface

spanning-tree portfast

interface FastEthernet0/21

description Riverbed PRIMARY interface

spanning-tree portfast

interface FastEthernet0/22

description Riverbed WAN interface

switchport access vlan 2

switchport mode access

no cdp enable

!

interface FastEthernet0/23

description Aubeta DSL BACKUP circuit

switchport access vlan 2

!

interface FastEthernet0/24

description Aubeta T1 PRIMARY circuit

switchport access vlan 2

speed 100

duplex full

!

interface Vlan1

ip address 10.1.0.4 255.255.255.0

no ip route-cache

!

interface Vlan2

ip address 10.1.0.5 255.255.255.0

no ip route-cache

shutdown

The bottom line is that I need those three switchports to act as a standalone dumb switch, just like the soho switch we were using.

Any help would be GREATLY appreciated!

7 REPLIES
Hall of Fame Super Blue

Re: Having trouble with configuring 2 vlans on the same switch

Erik

Which vlan are fa0/15 and fa0/21 supposed to be in because you haven't allocated them to any vlan with the "switchport access .." command ?

Jon

Re: Having trouble with configuring 2 vlans on the same switch

Jon,

I noticed that the interface Vlan1 and vlan 2 overlapps and that's why vlan 2 is shutdown. He will need to assign another subnet to vlan 2 to get things working properly.

Francisco

Hall of Fame Super Blue

Re: Having trouble with configuring 2 vlans on the same switch

Francisco

Good spot, i was so busy thinking about the Native vlan mismatch i missed that. rated.

Jon

Cisco Employee

Re: Having trouble with configuring 2 vlans on the same switch

I believe your both ports Fa0/15 and Fa 0/21 are in vlan 1. Just run " no CDP enable " on both the interfaces and you will be fine with the errors, these are being wrongly reported as you dont need any native vlan thing in here.

For your second problem, you can only have 1 Vlan SVI up on a layer 2 switch such as 2950. Your Vlan1 is currently up and you can only manage is using the Vlan 1 IP. If you want to manage it via VLAN2 SVI, Please do a " shutdown" on Vlan 1 and do a noshut" on Vlan 2.

HTH,

-amit singh

Cisco Employee

Re: Having trouble with configuring 2 vlans on the same switch

Agree with Francisco on the subnet part, I missed it. You cannot have same subnet on two SVI's. Assign a different range of IP and do a " no shut " as well as per my last post.

-amit singh

Purple

Re: Having trouble with configuring 2 vlans on the same switch

You can only have 1 active SVI on a 2950 as it is a layer 2 device and that address is only used to manage the switch , you can't route with this switch. The addresses on the switch really have no bearin other than to decide which vlan you are going to use to manage the switch , then shut the other one down.

Blue

Re: Having trouble with configuring 2 vlans on the same switch

Hi:

From your question and the requirements you described, it seems that you want to use this switch to support connections in 3 separate subnets. No problem; place the switch ports in the desired vlan and be done with it.

The routed interface on the 2950 switch has nothing to do with forwarding traffic. Its used for management purposes only -- an interface to telnet to.

Lastly, it isnt a good idea to use vlan 1 to forward data because its used primarily for control plane traffic; CDP, VTP, etc. Create a different vlan for data.

HTH

Victor

391
Views
5
Helpful
7
Replies
CreatePlease to create content