Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

HELP 881w AP801 problems

So first I did a dumb thing and I know this. I was upgrading the images on the router to the latest and greatest and also wanted to upgrade the AP inside it. I wasn't paying attention to the fact that the new AP image was LWWAP rather than autonomous which is was before. well long story short the AP is now nonfunctional and I can't even seem to get into anymore.

at first I was able to get into the unit using the "service-module wlan-ap 0 reset bootloader" command then doing "service-module wlan-ap 0 session". I wanted to wipe the flash and start over from scratch so I erased the flash and set the environment variables to my network and was able to tftp the autonomous image ( ap801-k9w7-tar.124-10b.JDA3.tar ) back to the flash. After doing that though the ap will no longer let me connect to it.

router1#service-module wlan-ap 0 session

Trying 192.168.10.99, 2002 ...

% Connection refused by remote host

I tried issuing the "service-module wlan-ap 0 reset bootloader" command again with no luck I get the same connection refused.

At this point I am at a loss on how to restore service on this thing without having a true console to it.

If anybody has any suggestions on how to fix this I would be grateful.

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: HELP 881w AP801 problems

router#service-module wlan-ap 0 session

is equivalent to

router#telnet 2002

which in other words is just a reverse telnet to the 881's internal IP address, and out its (internal) line 2.


So if you get "% Connection refused by remote host" when you try it - then this almost surely just means that line 2 is left in some busy state.

So ...

router#clear line 2

Should fix the problem for now.

As to why you got into this state ... I assume that there was a previous session left lying around.

Hth,

Aaron

5 REPLIES
New Member

Re: HELP 881w AP801 problems

I did the same thing!!! Please tell me you found a solution!!

Thanks

Matt

Cisco Employee

Re: HELP 881w AP801 problems

router#service-module wlan-ap 0 session

is equivalent to

router#telnet 2002

which in other words is just a reverse telnet to the 881's internal IP address, and out its (internal) line 2.


So if you get "% Connection refused by remote host" when you try it - then this almost surely just means that line 2 is left in some busy state.

So ...

router#clear line 2

Should fix the problem for now.

As to why you got into this state ... I assume that there was a previous session left lying around.

Hth,

Aaron

New Member

Re: HELP 881w AP801 problems

Aaron where were you 5 months ago

that is the right answer after fighting with the AP for a couple hours after I posted this message I did the clear line 2 and after some syntax issues finally got the original ap image up there and everything has been working fine ever since. I used this link to help with the syntax since most don't play in the bootloader very often


New Member

Thank you! It worked. Raul

Thank you! It worked.

Raul

New Member

I just found myself in the

I just found myself in the same situation. The clear line 2 command didn't help in my case. There was another statement in the running config on the router that was blocking access to the embedded AP.

login block-for 300 attempts 5 within 300

Once I removed this entry (no login block-for 300 attempts 5 within 300), I was able to get the login prompt for the AP.

~Jason

6722
Views
20
Helpful
5
Replies
CreatePlease login to create content