Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help Configure Cisco 1941 Router

Help!!!

I just bought a cisco 1941 router, I understand it came with the Cisco CP, but I don't know how to get to that part where I can use it.

Also, how can I connect to the router directly without using the HyperTerminal console, all I want to be able to do is configure the ISP IP address and my IP address so I can use it for internet browsing.

Please help.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Help Configure Cisco 1941 Router

Hi,

Thanks for the screenshots and show output! You'll need some command lines for CCP to work:

configure terminal

username USERNAME privilege 15 secret PASSWORD

ip http server

ip authentication local

Sent from Cisco Technical Support iPad App

47 REPLIES

Help Configure Cisco 1941 Router

hi,

connect your PC or a laptop to the 1941's G0/0 port and enter 10.10.10.1 in IE. you'll also need java installed on your PC.

default login is cisco/cisco.

you can configure the 1941 for telnet or SSH remote admin access (using third party software) later on. good luck!

New Member

Help Configure Cisco 1941 Router

Hello John,

I wish I had gotten this information earlier, but the Cisco 1941 only allows the use of the cisco/cisco login details for the very first time, the username and password is now invalid. As I logged in, I changed the username and password to rabbit/rabbit (not real).

Is there a way I can restore the router to the out-of-the-box state, i.e the factory setting?

or I would appreciate any help I can get.

Thank you in anticipation

Re: Help Configure Cisco 1941 Router

Hi,

Did you save the running-config (i.e. write memory)? If you haven't yet, just reboot it and start all over.

Otherwise, you'll need to perform a password recovery procedure.

http://www.cisco.com/en/US/products/ps5855/products_password_recovery09186a0080b3911d.shtml

Good luck and please rate helpful posts!

Sent from Cisco Technical Support iPad App

New Member

Help Configure Cisco 1941 Router

Hi,

Thank you very much, you have really been helpful, I was able to retreive and create a new password by using the hyperterminal console to connect to the router.

my gigabitethernet0/0 interface is showing 10.10.10.1 255.255.255.0, so I make my PC static IP 10.10.10.2  and subnet mask 255.255.255.0, then I tried to connect to the router using Internet Explorer but didn't connect.

I don't know what I am doing wrong here.

Help Configure Cisco 1941 Router

hi,

what error did you get? could you post a screenshot?

kindly post show flash and show run output.

New Member

Help Configure Cisco 1941 Router

That is the IE error and the I had to put the Network Connection property in there, with this I should be able to connect to the router using the address in the IE but I cannot.

Important to note that, I am able to ping the router and also telnet to it, but I cannot open it via the ip address in the IE

New Member

Help Configure Cisco 1941 Router

This is the show flash command output

Re: Help Configure Cisco 1941 Router

Hi,

Thanks for the screenshots and show output! You'll need some command lines for CCP to work:

configure terminal

username USERNAME privilege 15 secret PASSWORD

ip http server

ip authentication local

Sent from Cisco Technical Support iPad App

New Member

Help Configure Cisco 1941 Router

Thank you for the last information, I can see some improvement, but as you can see, the last command was reported invalid.but the others went fine.

.

.

.

configure terminal

username USERNAME privilege 15 secret PASSWORD

ip http server

.

.

.

went fine, but the "ip authentication local" didn't at this point.

Re: Help Configure Cisco 1941 Router

Hi,

My apologies I've made a typo. It should be 'ip http authentication local.'

Kindly give a try.

Sent from Cisco Technical Support iPad App

New Member

Help Configure Cisco 1941 Router

Hello,

Yes it worked I can now connect to the CCP express installed on the router, I have cleared the TLS option on the java setting, and I can login to the CCP, it will open a new tab for the CCP but won't display anything except the new tab, I guess it had to do with my browser or some, but I appreciate your effort so far, you have been extremely help, wish I could pay you back some how.

Thank you

Re: Help Configure Cisco 1941 Router

Hi,

Thanks for your feedback! Your generous rating would be enough.

Just on a personal note, the CCP express is kinda limited and can only do basic stuff.

You'll need to download the full version (if you want VPN, firewall etc. setup) from Cisco's website given you have a CCO account.

Sent from Cisco Technical Support iPad App

New Member

Re: Help Configure Cisco 1941 Router

With the above shot, I guess the "gateway of Last resort" should be my router address (10.10.10.1) to the network which should be what exactly? I am absolutely lost here. please I need help.

Bronze

Help Configure Cisco 1941 Router

Sounds like you are almost there, the other interface that you connected to your ISP, will need to be configured as well, and you probably need some DNS server information configured on your PC. 

If your ISP is using DHCP, from your hyperterminal window type (this also applies if you have a cable modem):

enable

configure terminal

interface gig X/X  <------Fill in this area for the interface you connected to the ISP

ip address dhcp

If they are not giving you a DHCP address, do the following:

enable

configure terminal

interface gig X/X  <------Fill in this area for the interface you connected to the ISP

ip address a.a.a.a b.b.b.b    <------------- This will be the IP address and subnet mask your ISP has given you

Also, if you are not using DHCP from your ISP, you will need to create a default route:

enable

configure terminal

ip route 0.0.0.0 0.0.0.0 c.c.c.c      <--------- The c.c.c.c will be the ISP

Now, so you don't have to use static IP addresses anymore for your PC:

enable

confiure terminal

service dhcp

ip dhcp excluded-address 10.10.10.1

ip dhcp pool users

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 8.8.8.8      <------------------ This is a google public DNS server, if you know your ISP's DNS, use that

Sorry this is all CLI, I have never used the GUI.

Craig

New Member

Help Configure Cisco 1941 Router

Hi xcz504d1114,

Thank you, I stopped at the point you stopped, I guess I will have to save this to the startup-config by using the "copy running-config startup-config" command? yes? or no?

Purple

Help Configure Cisco 1941 Router

Hi,

yes you must save the run ning-config otherwise if the router reloads you will have lost all modifications you had made previously.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Help Configure Cisco 1941 Router

User Access Verification

Username:

Username: income

Password:

income#sh run

Building configuration...

Current configuration : 2916 bytes

!

! Last configuration change at 15:48:35 UTC Fri Oct 5 2012

! NVRAM config last updated at 15:51:07 UTC Fri Oct 5 2012

! NVRAM config last updated at 15:51:07 UTC Fri Oct 5 2012

version 15.1

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname income

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200

logging console critical

enable secret 5 $1$K/Wt$MOaWnBNOE9rLay.m8Sh4a.

enable password 7 151B050F0B272E76

!

no aaa new-model

!

no ipv6 cef

no ip source-route

ip cef

!

!

!

ip dhcp excluded-address 10.10.10.1 10.10.10.39

!

ip dhcp pool users

network 10.10.10.0 255.255.255.0

default-router 10.10.10.1

dns-server 217.117.0.38 10.10.10.244

!

!

no ip bootp server

ip name-server 217.117.0.38

ip name-server 10.10.10.244

multilink bundle-name authenticated

!

crypto pki token default removal timeout 0

!

!

license udi pid CISCO1941/K9 sn FCZ1633716L

!

!

username income privilege 15 secret 4 HSyp0yWKpXLGNBvuMAwswNaIjZOwIZdQsd4T3M2hSo

A

!

!

ip tcp synwait-time 10

!

!

!

!

interface Embedded-Service-Engine0/0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

shutdown

!

interface GigabitEthernet0/0

description $ES_LAN$

ip address 10.10.10.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat inside

ip virtual-reassembly in

duplex auto

speed auto

no mop enabled

!

interface GigabitEthernet0/1

description $ES_WAN$

ip address 41.75.205.190 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

no mop enabled

!

!

router eigrp 109

network 10.0.0.0

network 41.0.0.0

!

router rip

version 2

network 10.0.0.0

network 41.0.0.0

no auto-summary

!

ip default-gateway 41.75.205.189

ip forward-protocol nd

!

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip nat pool overld 41.75.205.190 41.75.205.190 prefix-length 24

ip nat inside source list 7 pool overld overload

ip route 0.0.0.0 0.0.0.0 41.75.205.189

!

logging trap debugging

access-list 7 permit 10.10.10.0 0.0.0.254

access-list 199 permit icmp any any

!

no cdp run

!

snmp-server community public RO

!

control-plane

!

!

!

line con 0

line aux 0

line 2

no activation-character

no exec

transport preferred none

transport input all

transport output pad telnet rlogin lapb-ta mop udptn v120 ssh

stopbits 1

line vty 0 4

privilege level 15

password 7 11001706181F0E5D

login local

transport input telnet ssh

transport output telnet ssh

line vty 5 15

privilege level 15

login local

transport input telnet ssh

transport output telnet ssh

!

scheduler allocate 20000 1000

end

income#

...............

What could be wrong with my configuration up there, my LAN network address on interface gigabitethernet0/0 is 10.10.10.0/24 with my router as 10.10.10.1, and the IP given to me by my ISP is 41.75.205.190/24 and their gateway is 41.75.205.189.

With above configuration, some systems can access the internet while some cannot.

Purple

Help Configure Cisco 1941 Router

Hi,

the wildcard mask you configured in your NAT ACL will only permit even addresses to be translated and odd ones won't be translated so won't have internet connectivity.

just do this:

ip access-list standard 7

no 10

10 permit 10.10.10.0 0.0.0.255

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Help Configure Cisco 1941 Router

Hi,

Thank you real good,

I know I said I was able to logon to the CCP after the help I got from all of you here, to my surprise, I restarted the router only to find that I have to do  everyting all over again, trust me, i did the "copy running-config startup-config" and  "copy system:running-config nvram:startup-config" command before I restarted but I guess it didn't save it, what else could be wrong?

Purple

Help Configure Cisco 1941 Router

Hi,

you surely have the config-register set to 0x2142, do a show version to confirm and if it is the case then issue following command into global configuration mode: config-register 0x2102

then do your configs again and save to startup.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Help Configure Cisco 1941 Router

Hi Cadet Alain,

Thank you, I can now save the configuration now, and retain it whenever i restarted the machine, having  configured the ISP given IP address for the WAN interface gig0/1 using the details on the old router, I am still unable to access the INTERNET using this router, but able to access using the old router, Is there something I'm missing on this CISCO router?

NOTE: my connection is Modem <===> Router<====>Switch ------- Wireless Access Points.

Anything I'm missing?

Purple

Help Configure Cisco 1941 Router

Hi,

post the latest config from this router and the config from the one working.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Help Configure Cisco 1941 Router

The Old router is a completely GUI input router, but I diiscovered, I did not at any point specify the SSID for the new router, and also there is no room for GATEWAY in the CISCO 1941 CCP, could any of these be the reason? especially the GATEWAY option.

Purple

Help Configure Cisco 1941 Router

Hi,

can you post output of following:

-sh ip route static

also do this:

conf t

access-list 199 permit icmp any any

do debug ip pack detail 199

do logging buffered debug 1000000

do clear log

do ping 8.8.8.8 rep 1

do sh log  ---> paste output

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Help Configure Cisco 1941 Router

Hi Alain,

The command: do logging buffered debug 1000000 did not work, it marked BUFFERED as wrong.

Output below:

the Last page coming in next post

New Member

Help Configure Cisco 1941 Router

...continued from last post

Purple

Help Configure Cisco 1941 Router

Hi,

didn't you ping 8.8.8.8 ?

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Help Configure Cisco 1941 Router

Hi Alain,

Please pardon me if I am disturbing or frustrating your effort,

Everyother output remain same:

The Ping 8.8.8.8 output is shown below

New Member

Help Configure Cisco 1941 Router

The Post for the ip route static command:

I believe I must set the gateway then, because on the old router, which is completely a GUI router, there is a provision for the gateway provided by my ISP.

44797
Views
67
Helpful
47
Replies
CreatePlease to create content