Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Help - DHCP to multiple vlans

I can not get dhcp to work... I am pulling my hair out of my head!!!!!! I can ping from the switch to both vlans...  HELP!!!!!!!

here is my config for the router.....

Router is a 1760

Current configuration : 1379 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname intra-vlan

!

boot-start-marker

boot-end-marker

!

enable password xxxxxxx

!

no aaa new-model

!

resource policy

!

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool voip

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   option 150 ip 192.168.1.103

!

!

!

interface FastEthernet0/0

no ip address

speed 100

full-duplex

!

interface FastEthernet0/0.1

description management VLAN

encapsulation dot1Q 1 native

ip address 192.168.1.252 255.255.255.0

ip nat inside

no snmp trap link-status

!

interface FastEthernet0/0.2

description voip VLAN

encapsulation dot1Q 2

ip address 192.168.2.1 255.255.255.0

no snmp trap link-status

!

interface FastEthernet0/0.3

description Data VLAN

encapsulation dot1Q 3

ip address 192.168.3.1 255.255.255.0

ip nat inside

no snmp trap link-status

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

ip default-gateway 192.168.1.254

ip route 0.0.0.0 0.0.0.0 192.168.1.254

!

no ip http server

no ip http secure-server

!

!

control-plane

!

!

!

!

!

!

!

!

banner motd ^CC ***************** you have reached intra-vlan router **************** ^C

!

Switch is a 2950

Here is my configuration for my switch

Current configuration : 3892 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname switch

!

!

ip subnet-zero

!

no ip domain-lookup

!

spanning-tree mode pvst

spanning-tree portfast default

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

interface FastEthernet0/1

description att gateway to internet ip 192.168.1.254

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/2

description VOIP PHONE

switchport access vlan 2

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/3

description voip phone 7941

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/4

description cisco 1760 router - intra-vlan ip 192.168.1.252

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/5

description linksys ata analog phone

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/6

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/7

description ibm laptop docking station

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/8

description cisco 1760 router - vpn gateway

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/9

description hp laserjet printer ip 192.168.1.250

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/10

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/11

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/12

description sony blu-ray dvd player

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/13

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/14

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/15

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/16

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/17

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/18

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/19

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/20

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/21

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/22

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/23

switchport mode access

no ip address

duplex full

speed 100

spanning-tree portfast

!

interface FastEthernet0/24

description trunk port for poe switch

switchport mode trunk

no ip address

!

interface GigabitEthernet0/1

description elastix server ip 192.168.1.103

no ip address

!

interface GigabitEthernet0/2

no ip address

!

interface Vlan1

description management vlan 1

ip address 192.168.1.249 255.255.255.0

no ip route-cache

!

ip http server

!

banner motd ^CC ************* you have reached the main switch ***************** ^C

!

Everyone's tags (3)
1 REPLY
VIP Super Bronze

Re: Help - DHCP to multiple vlans

You have configured 2 vlans on your switch (vlan 1 and vlan 2). In this case interface fa0/4 need to be a trunk port and not an access port.  You also need a default-gateway on the switch pointing to the manament interface on the router

(192.168.1.252)

From the DHCP can you ping

192.168.1.252

and

192.168.2.1

on the router since you already have a default router, than you don't need this command:

ip default-gateway 192.168.1.254

HTH

650
Views
0
Helpful
1
Replies