Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

Help in implementing PBR/Route-maps default route to 2nd ISP remote site

Hello,

I am trying to create a route-map to have a specific VLAN in our 6509-Rter to default route and use

outbound internet through MCI ISP. Internal routing is OSPF, the 6509Rter gateway of last resort is

out through ISPQwest, we have a 100 MB wan link between the 6509-Rter, on the 6506Rter I made its default

route to go out the ISPMCI. On the PIX I have created the nessesary access-list and PAT for outbound connections.

The reason I would want to route the especific VLAN on the 6509Rter is because our T1 to the internet from the

Qwest side has been bursting so internet is very slow, on the MCI side we have unlimited internet bandwidth

and until we upgrade the internet T1 I need to accomodate critical outbound traffic for some systems retreaving

time sensitive market data information from the internet.

Could someone give me some examples .

This is the tolopogy :

Internal Routing is OSPF and default route is out through Qwest.

On the 6506Rter its default route is statically given to go out the MCI ISP

Phisical

ISPQWEST<-->PIX515E<-FE->6509Rter<--100MB-WAN->6506router<-FE->2811Rter<-FE->PIX515e-->ISPMCI

Logical

6509Rter-10.10.0.2><10.10.0.1-6506Rter-192.168.12.1><192.168.12.2-2811Rter><192.168.2.1><To-PIX515e

On the 6509Rter I have created the route map for a test subnet but it did not work, what did I missed?

6509Rter

interface vlan22

ip address 10.168.100.2

ip policy route-map cadlab-traffic

access-list 100 permit ip host 10.168.100.2

route-map cadlab-traffic permit 10

match ip address 1

set ip default next-hop 10.10.0.1

Thanks

Jorge

4 REPLIES
Bronze

Re: Help in implementing PBR/Route-maps default route to 2nd ISP

Hi,

As far as I can see you should have :

match ip add 100, not 1 ?

Regards

Bjornarsb

Bronze

Re: Help in implementing PBR/Route-maps default route to 2nd ISP

Have a look on this basci exa.

Regards

Bjornarsb

Re: Help in implementing PBR/Route-maps default route to 2nd ISP

Hey bjornarsb, thanks for your imput.. I did corrected your observations but still I was having issues yesterday not being able to re-route www traffic out to the other ISP, until this morning when I try adding a host on the the access list. I ended up creating a whole new script and it worked.

I have placed the basic topology diagram so that I can share with others the solution.

The new script I created was the following:

On the BOSTON Core-6509:

interface Vlan23

description TEST_Segment_10.169.100.0/2

ip address 10.169.100.2 255.255.255.0

no ip redirects

no ip proxy-arp

ip policy route-map cadlab-traffic

standby 23 ip 10.169.100.1

standby 23 priority 20

standby 23 preempt

standby 23 authentication msfc_v23

standby 23 name TEST_Segment

access-list 1 permit 10.169.100.1

access-list 1 permit 10.169.100.2

access-list 1 permit 10.169.100.10 ( Added )

route-map cadlab-traffic permit 10

match ip address 1

set ip next-hop 10.10.0.1

====================

So basically I added the 10.169.100.10 PCs-IP in acl 1 and all wwww traffic redirected to COLO-site ISP-2

Thanks

Jorge

Bronze

Re: Help in implementing PBR/Route-maps default route to 2nd ISP

Hi again,

That was good news!

Please rate if the exa. I posted helped you

identifing you problem.

Regards,

Bjornarsb

126
Views
4
Helpful
4
Replies