Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help*Problem Trunking between Catalyst 2950 switches.

Hi All,

I am new to Cisco and have setup a small lab as per CBTNuggets. Everything was going well until I introduced a second switch to create a trunk. Now I cannot ping between my two switches. Both show operational mode as down:

SWITCH1#show interfaces f0/12 switchport

Name: Fa0/12

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: 1

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Appliance trust: none

And There doesn't seem to be any vlans enabled to trunk. See Below

SWITCH1#show interface f0/12 trunk

Port        Mode         Encapsulation  Status        Native vlan

Fa0/12      on           802.1q         not-trunking  1

Port      Vlans allowed on trunk

Fa0/12      none

Port        Vlans allowed and active in management domain

Fa0/12      none

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/12      none

I have tried to allow all vlans or vlan 1 specifically and the output of the above doesn't seem to change.

I am wondering if there is something in the config-register that is preventing trunking, but I don't really know enough yet!

The output of my second switch is identical to this one, the only difference is that I have it configured as a vtp client.

Hope someone can help.

Thanks.

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Help*Problem Trunking between Catalyst 2950 switches.

Hey craig,

I'm going to guess that you are using a straight through cable instead of a cross-over cable.
Switch to a cross-over cable and everything should come up

4 REPLIES
New Member

Help*Problem Trunking between Catalyst 2950 switches.

Hey craig,

I'm going to guess that you are using a straight through cable instead of a cross-over cable.
Switch to a cross-over cable and everything should come up

New Member

Help*Problem Trunking between Catalyst 2950 switches.

I thought it was a cross-over, but looking at it now it doesn't look like it. I will get a hold of a cross-over, and try that.

Let you know how it goes.

New Member

Help*Problem Trunking between Catalyst 2950 switches.

ps Thanks.

New Member

Help*Problem Trunking between Catalyst 2950 switches.

Spot on rettuc_ccnp, found a crossover at work today and is now working! I did get a couple of cables with my lab and presumed they were crossover, never really checked.

Thanks.

1631
Views
0
Helpful
4
Replies