Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Help to configure cisco

Hello everyone, 

I need your help here I try to configure a Cisco 881 router when infact I have a connection that reaches the Wan port on the router I configure 88.XXX (public ip) I put the default gateway etc.. his short works because when I ping the IP on the outside it works 
my problem i want to  have internet on my port FastEthernet 0 , I configured a dhcp pool top 192.168.0.X it works but I do not have internet despite having set nat inside outside putting the road so I added a static route but it's not work copy of my config thank you.

 

1#show running-config
Building configuration...

Current configuration : 5424 bytes
!
! Last configuration change at 15:56:09 UTC Thu Mar 13 2014 by admin
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
memory-size iomem 10
!
crypto pki trustpoint TP-self-signed-2132292671
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2132292671
revocation-check none
rsakeypair TP-self-signed-2132292671
!
!
crypto pki certificate chain TP-self-signed-2132292671
certificate self-signed 01
3082022B XXXXXXXXXXXXXXXXXXXXXXXXXXXX
!
!
!
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 192.168.0.254
!
ip dhcp pool ccp-pool
import all
network 10.10.10.0 255.255.255.248
default-router 10.10.10.1
lease 0 2
!
ip dhcp pool vlan5
network 192.168.0.0 255.255.255.0
default-router 192.168.0.254
dns-server 8.8.8.8
!
!
!
no ip domain lookup
ip domain name yourdomain.com
ip cef
no ipv6 cef
!
!
license udi pid CISCO881-K9 sn FCZ18047124
!
!
!
!
!
!
!
ip ssh version 2
!
!
!
!
!
!
!
!
!
interface FastEthernet0
switchport access vlan 5
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
ip address 84.14.XXX.X 255.255.255.248
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Vlan1
description $ETH_LAN$
ip address 10.10.10.1 255.255.255.248
ip tcp adjust-mss 1452
!
interface Vlan5
ip address 192.168.0.254 255.255.255.0
!
ip default-gateway 84.14.209.185
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 2 interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 84.14.209.185
!
access-list 2 permit 192.168.0.0 0.0.0.255
no cdp run
!
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------

Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.

It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.

username <myuser> privilege 15 secret 0 <mypassword>

Replace <myuser> and <mypassword> with the username and password you
want to use.

-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.

YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE
PUBLICLY-KNOWN CREDENTIALS

Here are the Cisco IOS commands.

username <myuser> privilege 15 secret 0 <mypassword>
no username cisco

Replace <myuser> and <mypassword> with the username and password you want
to use.

IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL
NOT BE ABLE TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.

For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to http://www.cisco.com/go/ciscocp
-----------------------------------------------------------------------
^C
!
line con 0
login local
no modem enable
line aux 0
line vty 0 4
access-class 23 in
privilege level 15
password
login
transport input ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
!
end

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Add the below interface

Add the below

 

interface Vlan5

ip nat inside

2 REPLIES
New Member

Add the below interface

Add the below

 

interface Vlan5

ip nat inside

New Member

This is all it was missing ?

It works thank's !!

94
Views
0
Helpful
2
Replies