Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Help with configuring routing on 3750 switches

Hi

Currently I have the following configured on my router, what I'd like to do is put this on my 3750 switch, my question is what changes do I need to make to enable this to occur:

interface FastEthernet0/0

ip address 10.11.8.2 255.255.248.0

no ip redirects

ip route-cache same-interface

ip route-cache flow

no ip mroute-cache

speed 100

full-duplex

standby 1 timers 5 15

standby 1 preempt

standby 1 authentication xxxxxxx

standby 1 ip 10.11.8.1

!

interface FastEthernet0/1

ip address 10.29.2.2 255.255.255.0

no ip redirects

ip route-cache flow

speed 100

full-duplex

!

router ospf 1

router-id 10.11.8.1

log-adjacency-changes

redistribute connected subnets route-map PRIVONLY

redistribute static subnets

redistribute rip metric 120

network 10.11.8.0 0.0.7.255 area 0

network 10.17.2.0 0.0.0.255 area 0

network 10.28.2.0 0.0.0.255 area 0

default-information originate

!

router rip

version 2

redistribute ospf 1

network 0.0.0.0

default-metric 30

!

ip flow-export source FastEthernet0/0

ip flow-export version 5

ip flow-export destination 10.11.9.11 9996

ip classless

ip route 0.0.0.0 0.0.0.0 10.11.8.5 150

ip route 10.0.0.0 255.0.0.0 Null0 220

ip route 10.1.0.0 255.255.0.0 10.11.8.21

access-list 2 remark ***** Routes that will be propagated *****

access-list 2 permit 10.0.0.0 0.255.255.255

access-list 2 permit 192.168.0.0 0.0.255.255

access-list 119 permit ip host 10.2.4.5 192.168.16.0 0.0.0.255

access-list 120 permit icmp host 10.2.4.5 192.168.16.0 0.0.0.255

route-map PRIVONLY permit 10

match ip address 2

!

Thanks in advance

Dan

4 REPLIES
Silver

Re: Help with configuring routing on 3750 switches

Hi,

Considering that the 3750 runs IOS this config will work most probably. However check whether the IOS in 3750 is able to run ospf for instance because as far as I know the routing protocols require enhanced image.

Anyway the port numbering will be different and if you want to configure the port for L3 then you have to issue the no switchport command and ip routing in global config mode to enable the routing itself.

Hope it helps,

Krisztian

Cisco Employee

Re: Help with configuring routing on 3750 switches

Dan,

Please paste the show version from your switch.

-amit singh

New Member

Re: Help with configuring routing on 3750 switches

Couple of things.

Netflow is not supported on the 3750 platform so you can go ahead and remove that config.

Turn on routing using the "ip routing" global config command.

Configure ports as Layer three interfaces by using the "no switchport" interface command.

New Member

Re: Help with configuring routing on 3750 switches

Couple of things.

Netflow is not supported on the 3750 platform so you can go ahead and remove that config.

Turn on routing using the "ip routing" global config command.

Configure ports as Layer three interfaces by using the "no switchport" interface command.

272
Views
0
Helpful
4
Replies
CreatePlease to create content