Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Help with dhcp forwarder

Hello all,

I want to set up a dhcp-relay.

There are 2 routers one is the dhcp server the other one is the forwarder.

Please see the attached file (from Cisco packet tracer).

The pc on the right side only give my a message with a failure of retrieving a ip address.

What am I doing wrong??

Thanks in advanced!

1 ACCEPTED SOLUTION

Accepted Solutions
Purple

Help with dhcp forwarder

Hi,

on R2:

enable

conf t

ip route 10.1.11.0 255.255.255.0 10.1.10.1

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
8 REPLIES

Help with dhcp forwarder

A lot of us don't use packet tracer. Can you post the configs instead?

Basically, without seeing the config, you will have R1 as dhcp server and R2 as a forwarder. The helper address will be configured on the lan side toward the pc, and you'll have to have routes between R1 and R2:

R1 --- R2 --- PC

R1:

ip dhcp pool Test

network 192.168.12.0

default-router 192.168.12.1

R1 connection to R2 - 10.10.10.1

R2 connection to R1 - 10.10.10.2

R2 Lan address - 192.168.12.1

R2 fa0/1

ip addre 192.168.12.1

ip helper-addre 10.10.10.1

There are a few bugs in packet tracer too, so posting the configs will allow us to see if there's a problem. When the pc broadcasts for a dhcp server, the lan interface on R2 will see it and package it up as a unicast and send it to R1. R1 will see the requesting subnet and assign an address from the 192.168.12.0 pool.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Purple

Help with dhcp forwarder

Hi,

You must have a route for the gia address( which is the ip address where your helper-address is set) on the DHCP server(which is router2). This is because the DHCP replies are unicasted to this IP and then relayed as unicast or broadcast to the DHCP client.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Help with dhcp forwarder

Ok here we go,

Pc is dhcp not static

Forwarder (I removed some of the "!" there were a lot of them ):

Building configuration...

Current configuration : 473 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

!

interface FastEthernet0/0

ip address 10.1.10.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.1.11.1 255.255.255.0

ip helper-address 10.1.10.2

duplex auto

speed auto

!

ip classless

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

end

DHCP router:

Building configuration...

Current configuration : 566 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Router

!

ip dhcp excluded-address 10.1.11.1

!

ip dhcp pool hallo

network 10.1.11.0 255.255.255.0

default-router 10.1.11.1

dns-server 4.4.4.4

!

interface FastEthernet0/0

ip address 10.1.10.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

ip classless

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

end

So makes this it a little bit more clear??

Purple

Help with dhcp forwarder

Hi,

look at my reply, without this routing info R2 will never reply to DHCP requests from the client as it doesn't know how to send them.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Help with dhcp forwarder

i read it, but don't get it.

How do I make that route?

Purple

Help with dhcp forwarder

Hi,

on R2:

enable

conf t

ip route 10.1.11.0 255.255.255.0 10.1.10.1

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

Help with dhcp forwarder

Thanks man that was the answer I was looking for!!

New Member

Help with dhcp forwarder

Pop in the route to the subnet so that it knows what to send them down

137
Views
5
Helpful
8
Replies