Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Help with RIP version 2 lab

Hi,

I'm just starting to learn my IP protocols. I have just started on RIP version 2 with just 2 routers. Once I can get these 2 router ping each other I will add a 3rd router.

Attached are my 2 routers configs, I just want to ping the both LAN's which are the loopback interfaces to prove the routing is all working. It all worked with static routing.

Also any useful debug commands would be great, as I'm not sure if the RIP updates are being sent to either router.

Thanks

4 REPLIES

Re: Help with RIP version 2 lab

try to make ur config as following

router1:

router rip

version 2

network 10.0.0.0

network 172.30.30.0

no auto-summary

router 2

interface Loopback0

ip address 192.168.4.99 255.255.255.0

interface FastEthernet0/0

ip address 192.168.3.99 255.255.255.0

router rip

version 2

network 10.0.0.0

network 192.168.3.0

network 192.168.4.0

no auto-summary

good luck

if helpful Rate

New Member

Re: Help with RIP version 2 lab

Hi,

1.) I have noticed you added the fa0/0 on router 2 to the network list eventhough it is shutdown, do I need to do the same for Router 1's fa0/0 - "network 192.168.2.0"?

2.) 0n router 1 I try to add "network 172.30.30.0" but it defaults to "network 172.30.0.0"

3.) the clock rate only has to be set on the DCE router? (Router 2)

Thanks

Hall of Fame Super Bronze

Re: Help with RIP version 2 lab

1.) I have noticed you added the fa0/0 on router 2 to the network list eventhough it is shutdown, do I need to do the same for Router 1's fa0/0 - "network 192.168.2.0"?

No, I believe he was illustrating that you have duplicate IP addresses in the loopback interface and the LAN interface. Your initial message indicated you wanted to test connectivity between LANs, on this case, it seems you want to test connectivity between loopbacks - which is fine but it differs from the initial message. As long as you keep the LAN interface is shutdown mode, you should be able to ping between loopbacks with your provided config.

2.) 0n router 1 I try to add "network 172.30.30.0" but it defaults to "network 172.30.0.0"

Expected behavior under router rip process. It defaults to its classful network.

3.) the clock rate only has to be set on the DCE router? (Router 2)

On back-to-back connections, YES.

HTH,

__

Edison.

Please rate helpful posts

New Member

Re: Help with RIP version 2 lab

ok Hi first of all,

Router A

connected to 10.x.x.x & 175.x.x.x

RIP command should be

router rip

ver 2

net 10.x.x.x

net 175.x.x.x not sure of the subnet

router rip

version 2

network 10.x.x.x

network 192.168.2.0

dont forget to config your bandwidth on the router with the clock speed

378
Views
0
Helpful
4
Replies
CreatePlease to create content