Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help with simple etherchannel

Hello,

For a simple etherchannel to work between 2 switches I have configured ports 1 and 2 on both cisco 2960 switches with the channel-group option like this:

interface FastEthernet0/1

channel-group 1 mode on

!

interface FastEthernet0/2

channel-group 1 mode on

                  

I thought the port-channel 1 would get automatically created but it didn't, should it?  And under the port-channel interface should I set this as a trunk or do I do this on the 2 fa interfaces on each switch?

Thanks

Everyone's tags (2)
3 REPLIES
Silver

Help with simple etherchannel

Andy White wrote:

Hello,

For a simple etherchannel to work between 2 switches I have configured ports 1 and 2 on both cisco 2960 switches with the channel-group option like this:

interface FastEthernet0/1

channel-group 1 mode on

!

interface FastEthernet0/2

channel-group 1 mode on

I thought the port-channel 1 would get automatically created but it didn't, should it?  And under the port-channel interface should I set this as a trunk or do I do this on the 2 fa interfaces on each switch?

Thanks

You need to create the port channel interface on each switch as well. And you need to set both the port-channel interface and the individual ports exactly the same - so if you set one as a trunk, you need to set ALL of them as a trunk

So you need something like this

interface port-channel 1

description switch link

switchport trunk encapsulation dot1q

switchport mode trunk

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchpore mode trunk

channel-group 1 mode on

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode on

Put that into each switch (etherchannel numbers are only lcoally significant, so you can use the same number on each switch), and then issue the command

show int port-channel 1 etherchannel

to verify that the link comes up with both ports active.

Cheers.

New Member

Re: Help with simple etherchannel

I do not believe that you have to create the "Port-channel1" interface yourself as the previous comment indicates - I did the same thing as the original poster on a pair of 2960's (albeit running in Packet Tracer) and as soon as I did the configs on Fa0/1 and Fa0/2 on both sides, I could see that IOS had created the "Port-channel1" interface (pic attached.) Now, I would do further config using "int Po1" and any config entered against this interface will flow down to the physical int's (f0/1 and f0/2 in this case.)

Best,

Will

Sent from Cisco Technical Support iPhone App

Re: Help with simple etherchannel

Hi Dennis,

Once create a channel group in physical interface automatically port channel is getting created. But in port channel you need to define the vlan and its informations as well. like stated in the below.

interface Port-channel1

description SWa-SWb

switchport trunk encapsulation dot1q

switchport trunk native vlan [v]

switchport trunk allowed vlan [v],[v2]....

switchport mode trunk

switchport nonegotiate

no shutdown

!

So that it will work. If you mention access in one end and other end if you have trunk... then it will not take. If you are etherchanneling 2 ports then both the ports should be with same configuration on both the ends.

Hope this makes clear.

By

Karthik

355
Views
0
Helpful
3
Replies
CreatePlease login to create content