Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help with vlan routing on 3750 to ASA 5520

Hello,

I need to setup a new network and need some advice on static route from Cisco 3750 to ASA5520

Here is my proposed setup:

Cisco3750:

VLAN Name                      IP

---- -------------------------------- ---------------------------------------

1    default                           

2    data                          10.253.1.1 255.255.255.0

4    guest                        192.168.10.1 255.255.255.0   

5    voice                         172.10.0.1 255.255.0.0

Switch(config)#ip routing                         

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#switchport trunk encapsulation dot1q

Switch(config-if)#switchport mode trunk

Switch(config)#ip route 0.0.0.0 0.0.0.0 10.253.1.254

* port fa0/1 trunk to ASA 5510 eth0/0

ASA 5520:

interface GigabitEthernet0

nameif outside

security-level 0

ip address x.x.x.x 255.255.255.x

!

interface GigabitEthernet1

shutdown

no nameif

no security-level

no ip address

!

interface GigabitEthernet1.1

vlan 2

nameif inside

security-level 100

ip address 10.253.1.254 255.255.255.0

!

interface GigabitEthernet1.2

vlan 5

nameif voice

security-level 100

ip address 172.10.0.254 255.255.0.0

!

interface GigabitEthernet1.3

vlan 4

nameif guest

security-level 10

ip address 192.168.10.254 255.255.255.0

!

All the hosts will use the switch vlan ip as default gateway and the switch will do the inter vlan routing. ASA will server DHCP to all vlans (without ip on subinterface dhcp will not work)

The main thing I am confused about is : ip route 0.0.0.0 0.0.0.0 10.253.1.254

Is the ip route correct? and will all the vlan have access to internet providing dynamic nat is configured for each subif?

thanks

Everyone's tags (2)
1 REPLY
New Member

Help with vlan routing on 3750 to ASA 5520

oops,

* port fa0/1 trunk to ASA 5510 eth0/1

* ASA 5510 eth0/0 to internet router

390
Views
0
Helpful
1
Replies
CreatePlease to create content