Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Help with VLAN

Hey guys i need yr help.
I have a router and a switch which i want to connect. Before that i want to make three vlans. I have this ip adress to use 172.26.0.0 and subnet mask 255.255.0.0. After this i will have to connect my small network to another small network of the same infrastructure. you can use any subnet and it does no matter how many host on each subnet. Thanks
Thanks

Sent from Cisco Technical Support iPhone App

11 REPLIES

Help with VLAN

Can you may be try to draw it up what you are trying to accomplish first part kinda makes sense that you want to connect a router and a switch and you want 3 VLAN's, not sure what do you mean by the second part, are you connecting two small networks to the same switch?

Are you may be trying to connect 3 networks to the same switch and the router and want to keep them completely separate?

New Member

Re: Help with VLAN

Im trying to connect one router to one switch! all i need is the configuration and forming those three vlans plus subnetting of course! thats all i need so far! later i will have to do the same on other one router and one switch then i will connect those two network using point to point connection but first i want to configure the router and the switch and form a small network before i connect to anything else!
thanks

Sent from Cisco Technical Support iPhone App

Help with VLAN

we can help you in configure in one Router and one switch.

we need some information to go further.

1 )Model number of the rotuer and Switch.

if your switch is not an L3 device then we need to do different configuration (ROS).

2 )you have mentioned you need 3 Vlans please provide us the range of the subnet that you need for each vlan

in the above you have mentioned 172.26.0.0/16 which means you can

your start ip is 172.26.0.1 to 172.26.255.255 the total number of host would be around 65534.

New Member

Re: Help with VLAN

Don't worry about my switch or router model because its in PT!
The range also should not matter as long as you have three vlans. Maybe have 100 hosts or less in each vlan will help.
Thanks

Sent from Cisco Technical Support iPhone App

New Member

Re: Help with VLAN

Let say i want 5 subnets and 60 hosts on each subnet!

Sent from Cisco Technical Support iPhone App

Re:Help with VLAN

The router and switch model matter because people need to know how to help you. Different hardware are configured differently...

For a start please provide thebinfo being requested...


Sent from Cisco Technical Support Android App

New Member

Re: Help with VLAN

i want 3 subnet, the first will have 60 hosts the second 100 and the third 120 hosts.
the router model is 1800 series and the switch is 3350 series.
thanks

Sent from Cisco Technical Support iPhone App

Re: Help with VLAN

for the router you can try these config these config are just basic configs

Router configuration

1)interface for facing the internet

2)interface for facing to the Lan side

Interface Gigabitethernet 0/1

ip address (INternet IP )

Interface Gigabitethernet 0/2

description LAN

ip address 172.26.100.9 255.255.255.248

access-list 11 permit 172.26.0.0 0.0.255.255

access-list 110 permit 172.26.0.0 0.0.255.255 any

access-list 10 deny any

ip route 0.0.0.0 0.0.0.0 internet gate ip

ip route 172.26.6.0 255.255.255.0 172.26.100.10

ip route 172.26.7.0 255.255.255.0 172.26.100.10

ip route 172.26.8.0 255.255.255.0 172.26.100.10

on switch you can use the below config

configuration on the switch

use all the subnet has /24 subnet is easy purpose.

fine tunning has to be done... but for basic these config should be working.

configuration on the switch 3550 l3 device so intervlan communcation will be happeing

interface Vlan6

ip address 172.26.6.1 255.255.255.0

!

interface Vlan7

ip address 172.26.7.1 255.255.255.0

!

interface Vlan8

ip address 172.26.8.1 255.255.255.0

Interface Gigabitethernet 1/0/1

Description Uplink to switch 3550

no switch port

ip address 172.23.100.10 255.255.255.245

ip route 0.0.0.0 0.0.0.0 172.23.100.9

if you have any doubts then please let me know. As i said these are just basic configuration.

New Member

Re: Help with VLAN

Hi Arsene Muhigirwa,

           My advice you go for the following IP addressing schemes


1.  Vlan  10  -  172.26.10.0 /24   valid ip - 172.26.10.1  to 172.26.10.254 , default ip - 172.26.10.1

2.  Vlan  11 -   172.26.11.0 /24   valid ip -  172.26.11.1 to 172.26.11.254  ,default ip - 172.26.11.1

3.  Vlan  12 -   172.26.12.0 /24   valid ip -  172.26.12.1 to 172.26.12.254 , default ip - 172.26.12.1

Steps to configure :

1. Create 3 vlans ( for e.g  vlan 10, vlan 11, vlan 12 ) in the switch and assign the ports as a access port on which host systems are connected

2.  Connect the router to the switch and configure that port as a trunk port  to carry all VLAN traffic.

3.  Then go to router and create 3 sub interface,one sub interface for each vlan . set the default ip address of all the vlans as a sub interface ip address.

Then try to communicate from host machine in one vlan to other system in anothe vlan.


Re: Help with VLAN

This Url gives you a clear undestanding of how to configure L3 on switch 3550.

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008019e74e.shtml

New Member

Re: Help with VLAN

Thank you guys this will work!

Sent from Cisco Technical Support iPhone App

266
Views
0
Helpful
11
Replies
CreatePlease login to create content