Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

hi. route summarization with rip doesn't work for my handons network practi

this network diagram is 2 router(A and B), 2 switches and 2 pc.

router A:

int s0 161.20.4.1/30 DCE

int loopback0 161.20.3.1/30

int E0 161.20.2.1/24

router B:

int s1 161.20.4.2/30 DTE

int loopback0 161.20.5.1/30

int E0 161.20.1.1/24

According to the lab manual, route summarization cut the network off at 161.20.0.0/16 and did not advertise the /24 route.

the lab manual said workstation in can ping loopback address in its side, but can't ping each other for these 2 workstation.

let me write how the lab manual look like

routerA:sh ip route

161.20.0.0/16 is variably subnetted, 40 subnets, 2 mask

R 161.20.5.0/30 via 161.20.4.2, serial0

C . . ...(text cut off)...

C ........

C .......

161.20.1.0 network is not listed because it was summaried.

the above text are from lab manual.

then let me post my router sim result:

routerB#sh ip route

R 161.20.2.0/24 via serial 1

R 161.20.3.0/30 via serial 1

i was able to ping to ping each other on these workstations.

the lab they should not be able to ping each other. my lab practice failed =.="""

is the router simulator really can't work like a real router in these simple hands on lab?

can someone explain to me? although rip is very simple protocols, but for some reason, it's not that simple.

it's only simple at configuration

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Gold

Re: hi. route summarization with rip doesn't work for my handons

I have looked at the additional information that you posted and it is helpful. I do not have the book that you are talking about and can not comment in detail about it.

But in general the book is correct and your router sim is incorrect. Your configuration does specify version 1 (which was one of the questions in my first post). In RIP version 1 it will advertise over an interface only subnets with the same subnet mask and will not advertise subnets with differing subnet masks. So since the serial interface has a /30 mask RIP would advertise the loopback which has a /30 mask and would not advertise the fastethernet which has a /24 mask. If your router sim is showing the fastethernet as being advertised then that is a flaw in the router sim.

HTH

Rick

5 REPLIES
Hall of Fame Super Gold

Re: hi. route summarization with rip doesn't work for my handons

I am guessing that the lab manual was assuming running RIP version 1 and that you configured your router with RIP version 2. In RIP v1 the behavior would be as the lab manual describes and subnets with different masks would not be advertised over the serial link. In RIP v2 subnets of different sizes can be advertised.

If that does not seem to be the right explanation then perhaps you can provide a bit more detail including the configuration of the routers.

HTH

Rick

Community Member

Re: hi. route summarization with rip doesn't work for my handons

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname routerA

routerA(config)#int serial 0

routerA(config-if)#ip address 161.x.x.1 255.255.255.252

routerA(config-if)#clock rate 56000

routerA(config-if)#no shut

%LINK-3-UPDOWN: Interface Serial0, changed state to up

%LINK-3-UPDOWN: Interface Serial0, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down

routerA(config-if)#int loopback 0

routerA(config-if)#ip address 161.20.3.1 255.255.255.252

routerA(config-if)#no shut

routerA(config-if)#int fa0/0

routerA(config-if)#ip address 161.20.2.1 255.255.255.0

routerA(config-if)#router rip

routerA(config-router)#version 1

routerA(config-router)#^Z

%SYS-5-CONFIG_I: Configured from console by console

routerA#config t

Enter configuration commands, one per line. End with CNTL/Z.

routerA(config)#int fa0/0

routerA(config-if)#no shut

%LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

routerA(config-if)#router rip

routerA(config-router)#version 1

routerA(config-router)#network 161.20.0.0

routerA(config-router)#^Z

%SYS-5-CONFIG_I: Configured from console by console

routerA#copy run start

Destination filename [startup-config]?

Building configuration...

[OK]

routerA#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route

Gateway of last resort is not set

161.20.0.0/16 is variably subnetted, 5 subnets

C 161.20.3.0/30 is directly connected, Loopback0

C 161.20.2.0/24 is directly connected, FastEthernet0/0

C 161.20.4.0/30 is directly connected, Serial0

R 161.20.5.0/30 [120/1] via 161.20.4.2, 00:03:30, Serial0

R 161.20.1.0/24 [120/1] via 161.20.4.2, 00:01:28, Serial0

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname routerB

routerB(config)#int serial 1

routerB(config-if)#ip address 161.20.4.2 255.255.255.252

routerB(config-if)#no shut

%LINK-3-UPDOWN: Interface Serial1, changed state to up

routerB(config-if)#int loopback 0

routerB(config-if)#ip address 161.20.5.1 255.255.255.252

routerB(config-if)#no shut

routerB(config-if)#int fa0/0

routerB(config-if)#ip address 161.20.1.1 255.255.255.0

routerB(config-if)#no shut

%LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up

routerB(config-if)#router rip

routerB(config-router)#version 1

routerB(config-router)#network 161.20.0.0

routerB(config-router)#^Z

%SYS-5-CONFIG_I: Configured from console by console

routerB#copy run start

Destination filename [startup-config]?

Building configuration...

[OK]

routerB#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route

Gateway of last resort is not set

161.20.0.0/16 is variably subnetted, 5 subnets

C 161.20.4.0/30 is directly connected, Serial1

C 161.20.5.0/30 is directly connected, Loopback0

C 161.20.1.0/24 is directly connected, FastEthernet0/0

R 161.20.3.0/30 [120/1] via 161.20.4.1, 00:06:17, Serial1

R 161.20.2.0/24 [120/1] via 161.20.4.1, 00:04:42, Serial1

Community Member

Re: hi. route summarization with rip doesn't work for my handons

i think the lab manual has problem.

the book shows that 161.20.50.0/30 is learned in routerA's routing table. 161.20.50.0/30 is a loopback address on routerB. it also said fa0/0 interface of routerB is not listed in routerA's routing table.

i am questionning. If the routerA can learn the loopback interface, i think it can learn the fa0/0(161.20.1.0) on routerB.

i am practice the lab from this book. "Learning by Doing-CCNA- Lab Manual version 4 volume 2 eBook"

it's free ebook.

Hall of Fame Super Gold

Re: hi. route summarization with rip doesn't work for my handons

I have looked at the additional information that you posted and it is helpful. I do not have the book that you are talking about and can not comment in detail about it.

But in general the book is correct and your router sim is incorrect. Your configuration does specify version 1 (which was one of the questions in my first post). In RIP version 1 it will advertise over an interface only subnets with the same subnet mask and will not advertise subnets with differing subnet masks. So since the serial interface has a /30 mask RIP would advertise the loopback which has a /30 mask and would not advertise the fastethernet which has a /24 mask. If your router sim is showing the fastethernet as being advertised then that is a flaw in the router sim.

HTH

Rick

Community Member

Re: hi. route summarization with rip doesn't work for my handons

thank you . rick.

after your explaination, now i understand how RIP works.

201
Views
0
Helpful
5
Replies
CreatePlease to create content