Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

hi Wrongprotocol on CATOS on LACP

I have problem in CATOs switch that is -

(enable) show port channel 1

Wrong protocol type. Module 1 is set to LACP

Sup1A we are using

4 REPLIES
Silver

hi Wrongprotocol on CATOS on LACP

Hello Cssam,

I suppose you have « set channelprotocol lacp [1] » configured on the CatOS. It indicates the unique bundling protocol used for the whole module.

Indeed in CatOS all ports in an EtherChannel must use the same protocol; you cannot run two protocols on one module http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/catos/8.x/configuration/guide/channel.html#wp1039836

This is the reason why you cannot issue the command to validate the the pagp information.

In order to check the Channel-protocol information issue the ‘show port lacp-channel’ instead as LACP is used here.

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/catos/8.x/command/reference/sh_p_sn.html#wp1428547

If you want (depending of your current etherchannl config) to configure a PagP etherchannel, you will have to redifine the channel protocol (global or on a module basis) => set channelprotocol pagp  [1]

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/catos/7.x/command/reference/ses_sete.html#wp1084706

Thus you would be able to see the show port channel 1 output (of course, be careful of what etherchannel already configured)

Hope that helps.

Kind regards.

Karim

New Member

hi Wrongprotocol on CATOS on LACP

hi karim,

we have configuration as below -

#channelprotocol

set channelprotocol lacp 1

set channelprotocol lacp 2

!

#port channel

set port lacp-channel 1/1,2/1 11

but there is no multiple channel protocol running

Silver

hi Wrongprotocol on CATOS on LACP

Hi,

Thank you for the config.

So you have configured LACP for modules 1 & 2.

So, in order to see the details of your Etherchannel you can use show port lacp-channel

About your comment "but there is no multiple channel protocol running" => That is normal as you cannot run two protocols (PagP and LACP at the same time) on one module.

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/catos/8.x/configuration/guide/channel.html#wp1039836

Hope that helps.

Kind regards.

Karim


Silver

hi Wrongprotocol on CATOS on LACP

Hi,

Your command defaults to PAgP. You can either use the command "show port channel all" which should give you the information about both PAgP and LACP channels or you have the option to use the command "show lacp-channel" instead.

Best regards,

Antonin

885
Views
0
Helpful
4
Replies