Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

High Availability

Hi.

I have a network with a 3750 as Core of the LAN. The 3750 has a default route to Router Cisco 2800. I would like add a new Cisco 2800 for high availability. How I can configure the high availability without dynamic protocol (the Cisco 3750 has a default route to the 2800 Route)? And when the external interface of the Router 2800 A is down the traffic from the LAN, be redirected to the new Cisco Router 2800 B?

I attached a picture for better understanding

Thanks

6 REPLIES
Silver

Re: High Availability

There are a few options, one of them is to use HSRP between the LAN interfaces of the 2800 routers so that only one of them is active at the time and you can control that 2800-1 for instance would be the active router (therefor routing for Internet traffic) but only when its WAN interface is up. Here is an example:

Primary 2800 Router

interface Ethernet0

ip address 10.1.5.1 255.255.255.0

standby 1 ip 10.1.5.3

standby 1 priority 105 preempt

standby 1 track Serial0

!

Secondary 2800 Router

interface Ethernet0

ip address 10.1.5.2 255.255.255.0

standby 1 ip 10.1.5.3

standby 1 priority 100 preempt

standby 1 track Serial0

In this example both Ethernet interfaces will be connected to the 3750 core and 10.1.5.3 is going to be the default-gateway of the 3750.

The primary 2800 will be the active as long as its Serial0 (assuming here it's the WAN port) is up.

Some other options include floating static routes using IP SLA for tracking but please analyse the option I explain to see if it works for you

New Member

Re: High Availability

Thanks jbrenesj.

I read about HSRP, and this works.

But in the scenario that the new Router is in another IP segment.

For example:

RouterA Lan: 10.1.5.X

RouterB Lan: 172.16.31.X

The only option is implement IP SLA?

thanks

Silver

Re: High Availability

HSRP won't work if both routers are in different subnet/vlans.

Using IP SLA for object tracking with static routes is cool but checking further is not supported on the 3750 switches, just on the routers, 6500 and 3750-Metro

Configuring Reliable Static Routing Backup Using Object Tracking: Static Routing Examples

http://www.cisco.com/en/US/docs/ios/12_3/12_3x/12_3xe/feature/guide/dbackupx.html#wp1071672

Super Bronze

Re: High Availability

"The only option is implement IP SLA?"

Possibly not. A Rube Goldberg combination of VLANs and floating statics might do the trick, but Reliable Static Routing Backup Using Object Tracking on your 3750 (available starting with 12.2[46]SE, non-base image?) or using a dynamic routing protocol would probably be better solutions.

The issue is, either the 3750 will need to know the status of the WAN link on the backside of the WAN routers or the WAN routers will need to redirect traffic to the other WAN router if they don't have a good path to the Internet.

Silver

Re: High Availability

Way to go Cisco... it was about time that the 3750/3560 support object tracking. Good to know Joseph thanks.

Configuring Enhanced Object Tracking

Catalyst 3750 Switch Software Configuration Guide, 12.2(46)SE

http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/release/12.2_46_se/configuration/guide/sweot.html#wp1086461

Super Bronze

Re: High Availability

A variation of what Jorge has suggested, the 2800s should support mHSRP. This allows you to define a virtual gateway unique for each router but "backed up" by the other router. Then you can have two default route statements on the 3750 to each of the unique virtual gateways and load balance on both links, outbound. (BTW, I'm assuming both Internet WAN links are available. If not, there would also be the issue of how inbound traffic is redirected to the secondary link.)

e.g.

Primary 2800 Router

interface Ethernet0

ip address 10.1.5.1 255.255.255.0

standby 1 ip 10.1.5.3

standby 1 priority 105 preempt

standby 1 track Serial0

standby 2 ip 10.1.5.4

standby 2 priority 100 preempt

standby 2 track Serial0

!

Secondary 2800 Router

interface Ethernet0

ip address 10.1.5.2 255.255.255.0

standby 1 ip 10.1.5.3

standby 1 priority 100 preempt

standby 1 track Serial0

standby 2 ip 10.1.5.4

standby 2 priority 105 preempt

standby 2 track Serial0

486
Views
14
Helpful
6
Replies
CreatePlease to create content