Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

(High Ip input) on My router , I need to troubleshoot why CPU is high !!!!

(High Ip input) on My router  , I need to troubleshoot why CPU is high !!!!
=================
i have a cisco router 7200 NPEG2 processor , worked as LNS for PPPOVPDN circuits (Router for ADSL clients)
i  have "high ip input on my processor" and there is alot of differnce on my router between operations done by cef and operations done by router cpu
as an example , lets make show cpu process sorted
CPU utilization for five seconds: 67%/54%; one minute: 67%; five minutes: 68%
 PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process 
  87    10837056    46891299        231  6.31%  6.04%  6.32%   0 IP Input         
 122     4081972    38214106        106  2.47%  2.36%  2.46%   0 L2X Data Daemon  
 270      467844     2089101        223  0.79%  0.78%  0.79%   0 PPP Events       
 275     1862224     2102444        885  0.71%  0.73%  0.71%   0 SNMP ENGINE      
 112      627104       93588       6700  0.39%  0.36%  0.37%   0 CEF: IPv4 proces 
 273      854004     4207368        202  0.31%  0.26%  0.24%   0 IP SNMP          
  52      453256       12321      36787  0.31%  0.31%  0.31%   0 Compute load avg 
 258      295540      701580        421  0.23%  0.17%  0.15%   0 RADIUS           
 142       45792    14107303          3  0.23%  0.21%  0.21%   0 HQF Shaper Backg 
  78       86532      166975        518  0.23%  0.17%  0.13%   0 ACCT Periodic Pr 
 260      483164      248673       1942  0.23%  0.19%  0.24%   0 L2TP mgmt daemon 
 272       63980     1073491         59  0.15%  0.16%  0.15%   0 IPHC Admin       
  77      111560      184597        604  0.15%  0.08%  0.06%   0 AAA ACCT Proc    
 261      330572      217566       1519  0.15%  0.12%  0.15%   0 L2TUN Applicatio 
 274      450584     2102164        214  0.15%  0.15%  0.15%   0 PDU DISPATCHER   
  16      152352     1081873        140  0.07%  0.08%  0.19%   0 EnvMon           
 279      229040       27298       8390  0.07%  0.10%  0.11%   0 VTEMPLATE Backgr 
  40       23704       53593        442  0.07%  0.03%  0.02%   0 Net Background   
  95        4512       55604         81  0.07%  0.00%  0.00%   0 PPP Hooks        
 109        6844       62029        110  0.07%  0.00%  0.00%   0 IP Background    
 269       21384     1931910         11  0.07%  0.06%  0.07%   0 PPP manager      
 271         116       60672          1  0.07%  0.00%  0.00%   0 Multilink PPP    
  23       98400         321     306542  0.00%  0.07%  0.03%   0 AAA high-capacit 
=====================

as we see above , we have high "IP Input" about differnece in cpu =67-54=13 % , which is high value process in software .

i follwed the article here :
http://www.cisco.com/c/en/us/support/docs/routers/7500-series-routers/41160-highcpu-ip-input.html

i check and found that my router is fine , 
no arp calls.
no routing loops.
no flapping links.
i checked that my router has cef enabled and no enormous routing protocol updates

i found that i have big differnce between hardware & software process on the router which is 13 %
but when the traffic is more and more , the cpu reach reach 93 % and begin to have drops.

i just want to ask , how can i debug the operations that are done on the cpu processor of the router ???
i mean that if i know that traffic , i can estimate and know the problem  that increasing my cpu !!!

another question :

how to debug the packest that has a ttl exceeded 50 or ttl exceeded 100 ?????

i dont wan tto make debug ip packed , because i have a huge traffic and it will let my router hanged due to large debug !!
===============
righ now i will post my router config and some verification:
###############################################################################
drvirus#sh running-config 
Building configuration...

Current configuration : 12291 bytes
!
upgrade fpd auto
version 12.4
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service dhcp
!
hostname drvirus
!
boot-start-marker
boot system flash disk2:c7200p-adventerprisek9-mz.124-24.T7.bin
boot system flash disk2:c7200p-adventerprisek9-mz.124-24.T8.bin
boot-end-marker
!
logging message-counter syslog
!
aaa new-model
!
!
aaa group server radius radiusservers
 server-private 10..f.f.f auth-port 1812 acct-port 1813 key 7 weifuhjkefkjdbhfjkasbfjka
!
aaa authentication login adminstaff local
aaa authentication login sdm_vpn_xauth_ml_1 group radius
aaa authentication login ahmad local
aaa authentication ppp vpdn group radiusservers local
aaa authentication ppp drvirus local
aaa authentication ppp vpdn1 local group radiusservers
aaa authentication ppp ddd none
aaa authentication ppp dddd none
aaa authentication ppp anyok none
aaa authorization network default group radius local 
aaa authorization network vpdn group radiusservers local 
aaa authorization network sdm_vpn_group_ml_1 local 
aaa authorization network drvirus local 
aaa authorization network vpdn1 local group radiusservers 
aaa authorization network ddd none 
aaa authorization network anyok none 
aaa accounting delay-start 
aaa accounting update newinfo periodic 10
aaa accounting network vpdn
 action-type start-stop
 broadcast
 group radiusservers
!
!
aaa server radius dynamic-author
 client xxxxxxxx
 client 10.xxxxxx
 client 10.xxxxxxxxx
 server-key 7 dihcbsdjkbvcsdhmbvhsdbvsdhmbvsd
 auth-type any
!
aaa session-id common
clock timezone GMT+3 3
no ip subnet-zero
no ip source-route
no ip gratuitous-arps
ip cef
!
!
!
!
no ip bootp server
ip domain name drvirus
ip name-server x.x.x.x.x
ip name-server 8.8.8.8
login block-for 180 attempts 3 within 60
login quiet-mode access-class telnet
login on-failure log
login on-success log
no ipv6 cef
ipv6 dhcp pool vvv
 prefix-delegation pool version6
 address prefix 3333::/64
 dns-server 4444::1
!
!
multilink bundle-name authenticated
vpdn enable
vpdn logging
vpdn logging local
vpdn history failure table-size 50
!
vpdn-group eeeeeeeeeeee
 accept-dialin
  protocol l2tp
  virtual-template 1
 terminate-from hostname qqqqqq
 local name rrrrrrr
 lcp renegotiation on-mismatch
 l2tp tunnel password 7ekfhjjeklfnlenfl
 l2tp tunnel timeout no-session 60
 ip mtu adjust
!
!
!
username drvirus@!34`!512&$8#$232!^@^FGsdGD privilege 0 password 7 000sdkjhvsdkjvnah94313085g2355091407458E32425D

!

!
!
!
!
!
interface Loopback1
 ip address ttttttt 255.255.255.255
!
!
interface GigabitEthernet0/1
 description ttttttt
 ip address 10.60.60.2 255.255.255.0 secondary
 ip address 10.200.200.200 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!
interface GigabitEthernet0/1.4
 encapsulation dot1Q 4
 ip address ttttttttt 255.255.255.224
!
interface GigabitEthernet0/1.14
 encapsulation dot1Q 14
 ip address 192.168.50.3 255.255.255.0
!
interface FastEthernet0/2
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 ip address 10.160.150.2 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
 negotiation auto
!         
interface GigabitEthernet0/3
 description rrrrrrr
 ip address xxxxxxx 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 load-interval 30
 duplex full
 speed 1000
 media-type sfp
 negotiation auto
!
interface Virtual-Template1
 ip unnumbered Loopback1
 ip tcp adjust-mss 1412
 no logging event link-status
 peer default ip address pool xxxxx xxxxxx
 ppp mtu adaptive
 ppp authentication pap vpdn1
 ppp authorization vpdn1
 ppp accounting vpdn
!
!
router eigrp 2
 redistribute connected metric 1 2 1 2 1
 passive-interface default
 no passive-interface GigabitEthernet0/1
 network 10.200.200.200 0.0.0.0
 no auto-summary
 eigrp router-id 2.2.2.2

ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.200.200.2
ip route dddddddddd 255.255.255.0 fffffff
ip route ddddddddd 255.255.255.0 ffffff
no ip http server
no ip http secure-server
!
!
!


!
ip radius source-interface GigabitEthernet0/2 

radius-server attribute nas-port format d
radius-server configure-nas
radius-server host ddddddddddd auth-port 1812 acct-port 1813 key 7 dddddddddd
radius-server retransmit 0
radius-server key 7 dddddddddddddddddd
radius-server vsa send cisco-nas-port
radius-server vsa send accounting
radius-server vsa send authentication
!
control-plane
!
!
!
###################################################################

drvirus#sh ip traffic
IP statistics:
  Rcvd:  92454889 total, 5908020 local destination
         0 format errors, 94 checksum errors, 3789577 bad hop count
         0 unknown protocol, 23360 not a gateway
         0 security failures, 0 bad options, 3730347 with options
  Opts:  0 end, 0 nop, 0 basic security, 0 loose source route
         0 timestamp, 0 extended security, 0 record route
         0 stream ID, 0 strict source route, 3730347 alert, 0 cipso, 0 ump
         0 other
  Frags: 1409002 reassembled, 485 timeouts, 0 couldn't reassemble
         4542214 fragmented, 9089659 fragments, 2659413 couldn't fragment
  Bcast: 6024 received, 0 sent
  Mcast: 56503 received, 31033 sent
  Sent:  15839581 generated, 2407203241 forwarded
  Drop:  23 encapsulation failed, 0 unresolved, 0 no adjacency
         0 no route, 0 unicast RPF, 0 forced drop
         0 options denied
  Drop:  0 packets with source IP address zero
  Drop:  0 packets with internal loop back IP address
         0 physical broadcast

ICMP statistics:
  Rcvd: 0 format errors, 0 checksum errors, 0 redirects, 4 unreachable
        140579 echo, 33742 echo reply, 0 mask requests, 0 mask replies, 0 quench
        0 parameter, 0 timestamp, 0 timestamp replies, 0 info request, 0 other
        0 irdp solicitations, 0 irdp advertisements
        0 time exceeded, 0 info replies
  Sent: 0 redirects, 3530 unreachable, 33744 echo, 140579 echo reply
        0 mask requests, 0 mask replies, 0 quench, 0 timestamp, 0 timestamp replies
        0 info reply, 46795 time exceeded, 0 parameter problem
        0 irdp solicitations, 0 irdp advertisements

TCP statistics:
  Rcvd: 19285 total, 0 checksum errors, 7 no port
  Sent: 39402 total

BGP statistics:
  Rcvd: 0 total, 0 opens, 0 notifications, 0 updates
        0 keepalives, 0 route-refresh, 0 unrecognized
  Sent: 0 total, 0 opens, 0 notifications, 0 updates
        0 keepalives, 0 route-refresh

IP-EIGRP statistics:
  Rcvd: 39154 total
  Sent: 39275 total

PIMv2 statistics: Sent/Received
  Total: 0/0, 0 checksum errors, 0 format errors
  Registers: 0/0 (0 non-rp, 0 non-sm-group), Register Stops: 0/0,  Hellos: 0/0
  Join/Prunes: 0/0, Asserts: 0/0, grafts: 0/0
  Bootstraps: 0/0, Candidate_RP_Advertisements: 0/0
  Queue drops: 0
  State-Refresh: 0/0

IGMP statistics: Sent/Received
  Total: 0/0, Format errors: 0/0, Checksum errors: 0/0
  Host Queries: 0/0, Host Reports: 0/0, Host Leaves: 0/0 
  DVMRP: 0/0, PIM: 0/0
  Queue drops: 0

UDP statistics:
  Rcvd: 5632168 total, 0 checksum errors, 9605 no port
  Sent: 15536481 total, 0 forwarded broadcasts

OSPF statistics:
  Rcvd: 0 total, 0 checksum errors
        0 hello, 0 database desc, 0 link state req
        0 link state updates, 0 link state acks

  Sent: 0 total
        0 hello, 0 database desc, 0 link state req
        0 link state updates, 0 link state acks

ARP statistics:
  Rcvd: 36012 requests, 25 replies, 0 reverse, 0 other
  Sent: 3590 requests, 1883 replies (41 proxy), 0 reverse
  Drop due to input queue full: 0
#######################################################
drvirus#sh interfaces switching 
GigabitEthernet0/1 ffff
          Throttle count          0
                   Drops         RP      29334         SP          0
             SPD Flushes       Fast     183378        SSE          0
             SPD Aggress       Fast          0
            SPD Priority     Inputs     196591      Drops          0

    Protocol  IP                  
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process   50222652 1410586379   38933488 2377282438
            Cache misses          0          -          -          -
                    Fast 2501299905  502401799 1732463443 1178236678
               Auton/SSE          0          0          0          0

    Protocol  DEC MOP             
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process          0          0        104       8008
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    Protocol  ARP                 
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process      36178    2170680       3643     233084
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    Protocol  CDP                 
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process       1039     385469       2067     772027
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    Protocol  Other               
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process       2266     138297       6179     370740
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    NOTE: all counts are cumulative and reset only after a reload.

Interface FastEthernet0/2 is disabled

GigabitEthernet0/2 
          Throttle count          0
                   Drops         RP          0         SP          0
             SPD Flushes       Fast        785        SSE          0
             SPD Aggress       Fast          0
            SPD Priority     Inputs       1900      Drops          0

    Protocol  IP                  
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process     382927   34296776     382540  106683985
            Cache misses          0          -          -          -
                    Fast        198      31569          0          0
               Auton/SSE          0          0          0          0

    Protocol  DEC MOP             
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process          0          0        104       8008
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    Protocol  ARP                 
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process       1900     114000       1813     108780
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    Protocol  CDP                 
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process       1030     378010       1031     378377
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    Protocol  Other               
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process          0          0       6180     370800
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    NOTE: all counts are cumulative and reset only after a reload.
GigabitEthernet0/3 drvirus

          Throttle count          0
                   Drops         RP         15         SP          0
             SPD Flushes       Fast      22435        SSE          0
             SPD Aggress       Fast          0
            SPD Priority     Inputs     194236      Drops          0

    Protocol  IP                  
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process   40507058 2970006619   56462488 1872816742
            Cache misses          0          -          -          -
                    Fast 1758170357  386468928 2449949282 3706868609
               Auton/SSE          0          0          0          0

    Protocol  DEC MOP             
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process          0          0        105       8085
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    Protocol  ARP                 
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process          5        300          7        420
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    Protocol  CDP                 
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process          0          0       1034     379478
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    Protocol  Other               
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
                 Process          0          0       6180     370800
            Cache misses          0          -          -          -
                    Fast          0          0          0          0
               Auton/SSE          0          0          0          0

    NOTE: all counts are cumulative and reset only after a reload.


############################################################

drvirus#sh ip route summary 
IP routing table name is Default-IP-Routing-Table(0)
IP routing table maximum-paths is 32
Route Source    Networks    Subnets     Overhead    Memory (bytes)
connected       1           1644        105280      250040
static          3           0           192         456
eigrp 2         0           0           0           0
internal        5                                   5860
Total           9           1644        105472      256356
Removing Queue Size 0
drvirus#sh ip route summary 
IP routing table name is Default-IP-Routing-Table(0)
IP routing table maximum-paths is 32
Route Source    Networks    Subnets     Overhead    Memory (bytes)
connected       1           1645        105344      250192
static          3           0           192         456
eigrp 2         0           0           0           0
internal        5                                   5860
Total           9           1645        105536      256508
Removing Queue Size 0
drvirus#sh ip route summary 
IP routing table name is Default-IP-Routing-Table(0)
IP routing table maximum-paths is 32
Route Source    Networks    Subnets     Overhead    Memory (bytes)
connected       1           1645        105344      250192
static          3           0           192         456
eigrp 2         0           0           0           0
internal        5                                   5860
Total           9           1645        105536      256508
Removing Queue Size 0
drvirus#sh ip route summary 
IP routing table name is Default-IP-Routing-Table(0)
IP routing table maximum-paths is 32
Route Source    Networks    Subnets     Overhead    Memory (bytes)
connected       1           1645        105344      250192
static          3           0           192         456
eigrp 2         0           0           0           0
internal        5                                   5860
Total           9           1645        105536      256508
Removing Queue Size 0
drvirus#
###############################################################


ANy help ??????!!!!!

10 REPLIES
Super Bronze

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

For starters "we have high "IP Input" about differnece in cpu =67-54=13 % " is incorrect.  The 13% is non-"interrupt" processing.  Your IP Input usage is shown as:

 PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process 
  87    10837056    46891299        231  6.31%  6.04%  6.32%   0 IP Input        

Which is higher percentage than we would like, but a higher percentage might be "normal" for your "LNS for PPPOVPDN".

Just how much aggregate traffic is your router passing when it reaches about 93% and you start to experience drops?

BTW, a NPE-G2, in theory, is good for up to about 1.3 Gbps of minimum size wire-speed Ethernet, and that's without allowance for services and other CPU needs of the router.  I.e. A NPE-G2 doesn't guarantee wire-speed for even a single gig duplex link.  So, even if you cut your non-"interrupt' CPU utilization, you might need a "faster" router.

New Member

Hi,thank you very much for

Hi,

thank you very much for your reply ,

 

i confess that it was a typo due to quick when i was typing the post  ,===> i mean that i have 13 % done in software which is in my  opinion a bad issue !!!!!

.... in the rush hours (when most of users are online , say 2000 ppovpn online  , with about 400-450 Mbps traffc) the  cpu is fire .....

it may reach 88 - 90 -93 the max ... @ that cpu some drops we have in the packets !!!!

 

the issue  of (high non interrupt traffic )  which some times reach 20 % is done due to changes in topology , but again i cant get back ... dont ask me to go back ...smiley

 

how can i debug the  traffic that done in my CPU software ( non interrrupt) , or how to debug if there is a lot of ttl expeired packets there ??

 

i googled alot with no benefit , agian ...  i believe that this 7200 npeg2 can handle more and more users..

my  problem is , i need to fix the (non interrupt ) traffic that is hitting my router ??!!!!

can  u guide me ?? do u have a powerfull tools ??

any help ??

Super Bronze

DisclaimerThe Author of this

Disclaimer

The Author of this posting offers the information contained within this posting without consideration and with the reader's understanding that there's no implied or expressed suitability or fitness for any purpose. Information provided is for informational purposes only and should not be construed as rendering professional advice of any kind. Usage of this posting's information is solely at reader's own risk.

Liability Disclaimer

In no event shall Author be liable for any damages whatsoever (including, without limitation, damages for loss of use, data or profit) arising out of the use or inability to use the posting's information even if Author has been advised of the possibility of such damage.

Posting

Cisco does have some whitepapers on troubleshooting CPU performance issues, but I suspect your performance isn't so much caused by some misconfiguration or problem, but, again, it's just caused by the nature of your traffic.  For example, I notice you have mss-adjust 1412 on your virtual-template and that implies a whole bunch of possible CPU issues (not the command itself, but dealing with packets larger than possible MTU).

BTW, "mean that i have 13 % done in software which is in my  opinion a bad issue !!!!!", yes any non-fast-path process may be an issue, but pretty much all processing on a NPE is done in software; it's just a question of how efficiently.

Also BTW, although a NPE-G2 in theory has 2x the performance of a NPE-G1, if you search these forums, it seems some have otherwise experience.  (NB: the NPE-G2 is a different architecture from the other NPEs.)

We'll see if anyone else can other help, but I also suspect you may need to consider you need a more "powerful" router for your traffic load.  In the 7200 family, there is a more "powerful" "engine" than the NPE-G2, the NSE-1 (I mention this to possibly preserve as much of your existing hardware).  However, it's not faster in all areas, and it's long been end-of-sale.

New Member

thank you both for your

thank you both for your replies ... agian ... the cpu is not natural , im sure that it was better with same traffic and same users.

can i start anything that can decrease my cpu ??

should i change mtu to 1500 ???

upgrade ios ?

any other suggestion ??

 

could the high "ip input" value can be due to routing loop issue ??

 

 

New Member

any help ?

any help ?

Hall of Fame Super Gold

Why, oh why, are you running

Why, oh why, are you running an IOS with the "T" train?   

 

Can you try upgrading your IOS using the "M" train?

New Member

with "T" train it was working

with "T" train it was working like a charm ... but  recently it has a higher cpu due to topology changes !!!

 

can u help me investigating the "non interrupt " traffic ?

New Member

can some one determin if :

can some one determin if :

 122     9166144   120227216         76  3.30%  2.81%  2.42%   0 L2X Data Daemon

 

has a relation to my high cpu 

?????????

 

her  is agian my cpu process :

drvirus#sh processes cpu sorted 
CPU utilization for five seconds: 69%/51%; one minute: 62%; five minutes: 59%
 PID Runtime(ms)     Invoked      uSecs   5Sec   1Min   5Min TTY Process 
  87    22165548   147317354        150  7.60%  6.54%  5.74%   0 IP Input         
  16      682988     2637213        258  3.61%  0.70%  0.37%   0 EnvMon           
 122     9166144   120227216         76  3.30%  2.81%  2.42%   0 L2X Data
Daemon  
 270      484700     4987094         97  0.76%  0.84%  0.86%   0 PPP Events       
 260      746640      483367       1544  0.30%  0.51%  0.51%   0 L2TP mgmt daemon 
 112     1082540      228491       4737  0.30%  0.31%  0.31%   0 CEF: IPv4 proces 
 190         596         755        789  0.30%  0.02%  0.00%   2 SSH Process      
 279      461184       78909       5844  0.30%  0.39%  0.45%   0 VTEMPLATE Backgr 
  52      954592       29823      32008  0.30%  0.31%  0.31%   0 Compute load avg 
 272       53744     2782461         19  0.23%  0.17%  0.16%   0 IPHC Admin       
 261      513524      428266       1199  0.23%  0.38%  0.37%   0 L2TUN Applicatio 
 142       31888    35627222          0  0.23%  0.19%  0.20%   0 HQF Shaper Backg 
 258      570384     1602872        355  0.15%  0.18%  0.17%   0 RADIUS           
  78       43280      392561        110  0.15%  0.10%  0.08%   0 ACCT Periodic Pr 
 281       52340      385568        135  0.07%  0.08%  0.09%   0 IP-EIGRP: PDM    
  40       37300      138153        269  0.07%  0.09%  0.10%   0 Net Background   
  77      145860      443602        328  0.07%  0.06%  0.07%   0 AAA ACCT Proc    
 110       31060       53876        576  0.07%  0.03%  0.02%   0 IP RIB Update    
  45       11868       52400        226  0.07%  0.01%  0.00%   0 IF-MGR control p 
 115       20164      103667        194  0.07%  0.02%  0.00%   0 PPP IPCP         
 102      181600      489310        371  0.07%  0.14%  0.15%   0 SSM connection m 
 143        3148     1461382          2  0.07%  0.01%  0.00%   0 RBSCP Background 
  80       19488       22128        880  0.07%  0.02%  0.00%   0 CDP Protocol     
  23      189412       10771      17585  0.00%  0.15%  0.04%   0 AAA high-capacit 
  22           0           1          0  0.00%  0.00%  0.00%   0 CEF MIB API      
  21           0           2          0  0.00%  0.00%  0.00%   0 ATM Idle Timer   
  20         376      153594          2  0.00%  0.00%  0.00%   0 ARP Background   
  24           0           2          0  0.00%  0.00%  0.00%   0 AAA_SERVER_DEADT 
  25           0           1          0  0.00%  0.00%  0.00%   0 Policy Manager   
  26        1376       26590         51  0.00%  0.00%  0.00%   0 DDR Timers       
  31           4          30        133  0.00%  0.00%  0.00%   0 EEM ED Syslog    
  27           0           5          0  0.00%  0.00%  0.00%   0 Entity MIB API   
  33         324      147392          2  0.00%  0.00%  0.00%   0 GraphIt          
  34           0           2          0  0.00%  0.00%  0.00%   0 Dialer event     
  28           0           2          0  0.00%  0.00%  0.00%   0 Serial Backgroun 
  36           0           2          0  0.00%  0.00%  0.00%   0 XML Proxy Client 

New Member

hiii all , well i just want

hiii all ,

 

well i just want to share info that i got collected.

 

it seems that 7200 LNS with about 400 M traffic and with about 2000 users  cant handle all operations in hardware===> this mean that  that some cef punts must occurs.

 

 

i think this is my answeto my question , my question was why about 20 % differ between hardware and software handling.

 

 

no problem in my topology  no errors i have.

 

 

we are migrating to add more LNS routers .

 

 

thanks alot for all replies

 

with my best regards

Cisco Employee

Hello  CPU utilization for

Hello 

 

CPU utilization for five seconds: 67%/54%; one minute: 67%; five minutes: 68%

 

This means that the overall CPU is 67% .... and 54% is due to interrupt 

 

usually interrupt are traffic related issue and the most common cause is hardware limitation ....according to router performance document provided by cisco this router capable up to 1024 mbps in the idle cases i.e router with no features .... so the most common cause is hardware limitation and you should consider hardware upgrade or offload the traffic to another router 

 

 

http://www.cisco.com/web/partners/downloads/765/tools/quickreference/routerperformance.pdf

902
Views
15
Helpful
10
Replies
CreatePlease to create content