Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

High Utilization on one port of an Etherchannel

Hi to all,

I have an etherchannel using 4 gigabit interfaces and i'm having high utilization just in one of it. It's the interface G6/32 on the SW-CENTRAL1 and SW-CENTRAL2 the ones that are having this situation (one in output and the other in input), the etherchannel is configured as desirable between two WS-C4507R with the IOS version 12.2(20)EWA4.

The configurations for the etherchannel are exactly the same for the two devices:

interface Port-channel2

description PortChannel-Central

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

interface GigabitEthernet6/29

description EtherChannel-2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode desirable

!

interface GigabitEthernet6/30

description EtherChannel-2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode desirable

!

interface GigabitEthernet6/31

description EtherChannel-2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode desirable

!

interface GigabitEthernet6/32

description EtherChannel-2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode desirable

SW-CENTRAL1#sh int port-channel 2

Port-channel2 is up, line protocol is up (connected)

Hardware is EtherChannel, address is 000e.84cd.306e (bia 000e.84cd.306e)

Description: PortChannel-Central

MTU 1500 bytes, BW 4000000 Kbit, DLY 10 usec,

reliability 255/255, txload 7/255, rxload 6/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 1000Mb/s, media type is N/A

input flow-control is off, output flow-control is unsupported

Members in this channel: Gi6/29 Gi6/30 Gi6/31 Gi6/32

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output never, output hang never

5 minute input rate 99376000 bits/sec, 20421 packets/sec

5 minute output rate 112217000 bits/sec, 20172 packets/sec

SW-CENTRAL2#sh int port-channel 2

Port-channel2 is up, line protocol is up (connected)

Hardware is EtherChannel, address is 000e.84cd.2cde (bia 000e.84cd.2cde)

Description: PortChannel-Central

MTU 1500 bytes, BW 4000000 Kbit, DLY 10 usec,

reliability 255/255, txload 6/255, rxload 6/255

Full-duplex, 1000Mb/s, media type is N/A

input flow-control is off, output flow-control is unsupported

Members in this channel: Gi6/29 Gi6/30 Gi6/31 Gi6/32

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output never, output hang never

Last clearing of "show interface" counters 11w0d

Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 108971000 bits/sec, 19845 packets/sec

5 minute output rate 102179000 bits/sec, 20525 packets/sec

Do you know what could be causing this??

Thanks in advance for your help.

9 REPLIES
Hall of Fame Super Blue

Re: High Utilization on one port of an Etherchannel

Alfonso

Any one individual conversation will always use the same link. How the individual conversations are defined is down to the load-balancing algorithm in use on the switch.

So it may just be that 2 machines on either side of the link are doing all the talking at the moment or it may be that your load-balancing algorithm could be changed to get a better distribution across the links. Have a look at this doc for more details on etherchannel load-balancing -

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_tech_note09186a0080094714.shtml

Jon

Re: High Utilization on one port of an Etherchannel

What EtherChannel load-balancing algorithm are you using? Depending on the traffic characteristics it is possible this behaviour is normal.

Have a read of the EtherChannel chapter here:

http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/50sg/configuration/guide/channel.html

HTH

Andy

Re: High Utilization on one port of an Etherchannel

From the output you've showed, how are you verifying that it's only using one link?

New Member

Re: High Utilization on one port of an Etherchannel

Hi,

My LMS is sending me this message:

EVENT ID = 0008HOB

ALERT ID = 00001L8

TIME = Thu 08-Jan-2009 04:54:10 CST

STATUS = Active

SEVERITY = Critical

MANAGED OBJECT = 128.127.254.1

MANAGED OBJECT TYPE = Switches and Hubs

EVENT DESCRIPTION = HighUtilization::Component=PORT-128.127.254.1/95 [Gi6/32] [EtherChannel-2];OutputPacketRate=67309.25 PPS;Type=ETHERNETCSMACD;CurrentUtilization=75.16374 %;InputPacketRate=16970.86 PPS;TrafficRate=9.395468E7 BYPS;UtilizationThreshold=75;DuplexMode=FULLDUPLEX;MaxSpeed=1000000000;

CUSTOMER IDENTIFICATION = Switches

And i also graph the traffic on all the etherchannel interfaces and is just the g6/32 the one that is having this high utilization

Purple

Re: High Utilization on one port of an Etherchannel

Because of the channel distribution method that is configured looks like most is riding that single link , you need to figure out why. Are all the links up in the channel group ? Post a "show ether summary " command.

New Member

Re: High Utilization on one port of an Etherchannel

Hi Glen,

Here is the output from the 2 sw:

SW-CENTRAL1#sh etherchannel summary

Number of channel-groups in use: 2

Number of aggregators: 2

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

2 Po2(SU) PAgP Gi6/29(P) Gi6/30(P) Gi6/31(P)

Gi6/32(P)

4 Po4(SU) - Gi7/3(P) Gi7/4(P)

SW-CENTRAL2#sh etherchannel summary

Number of channel-groups in use: 2

Number of aggregators: 2

Group Port-channel Protocol Ports

------+-------------+-----------+-----------------------------------------------

2 Po2(SU) PAgP Gi6/29(P) Gi6/30(P) Gi6/31(P)

Gi6/32(P)

3 Po3(SU) - Gi7/1(P) Gi7/2(P)

I don't know why most of the traffic is going only throught this single port, one thing important is that this happens on a random period of time, i mean the g6/32 is not all the time with high utilization.

Thanks

Hall of Fame Super Silver

Re: High Utilization on one port of an Etherchannel

Hello Alfonso,

use

sh etherchannel load-balance

to see what algorythm is in use

example:

sh etherchannel load-balance

EtherChannel Load-Balancing Configuration:

src-dst-ip

mpls label-ip

EtherChannel Load-Balancing Addresses Used Per-Protocol:

Non-IP: Source XOR Destination MAC address

IPv4: Source XOR Destination IP address

IPv6: Source XOR Destination IP address

MPLS: Label or IP

Hope to help

Giuseppe

Re: High Utilization on one port of an Etherchannel

I agree.

Use the option that provides the balance criteria with the greatest variety in your configuration. For example, if the traffic on an EtherChannel is going only to a single MAC address and you use the destination MAC address as the basis of EtherChannel load balancing, the EtherChannel always chooses the same link in the EtherChannel; using source addresses or IP addresses might result in better load balancing.

For more details on configuring channel laod-balancing:

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/configuration/guide/channel.html#wp1020414

New Member

Re: High Utilization on one port of an Etherchannel

Hi,

I'll try that.

Thanks to all for your help.

1358
Views
0
Helpful
9
Replies
CreatePlease to create content