Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

hola, router to switch connection

                   ok, so i have my router and made subinterfaces

int e0/0

no ip address

no shutdown

int e0/0.1

encapsulation dot1q 1

ip address 10.10.10.17 255.255.255.240

               and i set my switch up with this

config t

int vlan 1

ip address 10.10.10.18 255.255.255.240

no shut

               made the 1st port a trunk

int fa0/1

switchport mode trunk

               then made my 2nd port like the access

int fa0/2

switchport mode access

switchport access vlan 1

switchport port-security mac-address sticky

switchport port-security maximum 1

switchport port-security violation shutdown

ready for the question? i can ping my computer of 10.10.10.19, but why cant i ping my default gateway of 10.10.10.17.

im not sure but is it because the router is ethernet and switch is fast. does the router not support vlan(sub-int).

it let me set-up the sub-interfaces for vlan 1, but maybe the port does not support it, 2600 router and 2950 switch.

thanks,

chris

  • LAN Switching and Routing
1 ACCEPTED SOLUTION

Accepted Solutions

Re: hola, router to switch connection

Hi,

Could you try:

- shut/no shut the ports on both devices
- issue clear ip arp
- use another VLAN
- check PC TCP/IP setting and personal FW



Sent from Cisco Technical Support iPhone App

9 REPLIES
Purple

hola, router to switch connection

Hi,

just add the keyword native at the end of your encapsulation command on the router subinterface and let us know if it works.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
New Member

hola, router to switch connection

no that did not seem to help

any other ideas, did i miss anything while setting up?

Re: hola, router to switch connection

Hi,

Could you try:

- shut/no shut the ports on both devices
- issue clear ip arp
- use another VLAN
- check PC TCP/IP setting and personal FW



Sent from Cisco Technical Support iPhone App

New Member

hola, router to switch connection

eureka, ima genious.........

i wish, lol

thanks floyd, i made a vlan 2 and it let me ping and telnet to the router. it would not let me in the administrative vlan 1 for some reason. if you know why ill wait for an explianation.

ill mark you as the best answer, thanks

hola, router to switch connection

hi chris,

i'm glad your issue is resovled. your setup should work flawlessly but i suspect it might be due to the fact your running "legacy" equipment (i.e ethernet on 2600) and doesn't support native VLAN (VLAN 1).

best practice is that VLAN 1 should not be used for anything.

New Member

hola, router to switch connection

thanks im studying for my ccna, legacy is all i have for now. thaks for your reply

Cisco Employee

hola, router to switch connection

Chris, John,

You may be interested to know that the 2610 and 2611 series routers with Ethernet (i.e. 10Mbps) interfaces do not support configuring a subinterface for the native VLAN. This appears to be a limitation of the Ethernet controller in these routers. If you want to use the native VLAN, you must configure the physical interface directly. Subinterfaces for all other VLANs work just fine but instead of configuring a subinterface for the native VLAN, configure the Ethernet0/0 interface directly instead.

FastEthernet-based routers like 2620, 2621, the 2600XM series etc. do not have this limitation anymore.

Best regards,

Peter

hola, router to switch connection

hi peter,

this is a cool fact! thanks for educating us. +5 sir!

Cisco Employee

hola, router to switch connection

Hi John,

It is a pleasure and an honor. Thank you!

Best regards,

Peter

301
Views
5
Helpful
9
Replies
This widget could not be displayed.