Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Home Agent Redundancy Issue

I am trying to configure a pair of 2911 routers with home agent redundancy and have run into what I think is a routing issue. 
 

When Router 1 is the active HSRP router, the mobile IP bindings are received on the 10.10.40.1 interface and shared to Router 2. I can ping the mobile IP subnet from both routers. Each router has a switch connected to gi 0/0, from the switch connected to Router 1 I can ping the mobile IP subnet, from the switch connected to Router 2 I cannot.

If I make Router 2 the active HSRP by giving it a higher priority the situation is reversed. In that case the switch connected to Router 2 can ping the mobile IP subnet, and the switch connected to Router 1 cannot ping the Mobile IP subnet.

 

Here is an example of a binding with Router 1 Active.

Router 1

192.168.1.10:
    Care-of Addr 10.10.70.100, Src Addr 172.30.98.102
    Lifetime granted 00:12:30 (750), remaining 00:12:26
    Flags sbdmg-T-, Identification D7AB51B4.530047A3
    Tunnel1 src 10.10.40.1 dest 10.10.70.100 reverse-allowed
    Routing Options - (T)Reverse-tunnel

 

Router 2

192.168.1.10:
    Care-of Addr 10.10.70.100, Src Addr 10.10.40.2
    Lifetime granted 00:12:30 (750), remaining 00:12:26
    Flags sbdmg-T-, Identification D7AB51B4.530047A3
    Tunnel1 src 10.10.40.1 dest 10.10.70.100 reverse-allowed
    Routing Options - (T)Reverse-tunnel

 

 

Router 1

Router 2

IOS

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(4)M4, RELEASE SOFTWARE (fc1)

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(4)M4, RELEASE SOFTWARE (fc1)

Routing

router eigrp 10

redistribute mobile metric 2 1 255 1 1500

router mobile

router eigrp 10

redistribute mobile metric 2 1 255 1 1500

router mobile

Interface

interface GigabitEthernet0/2

description HSRP connected interface

ip address 10.10.40.2 255.255.255.0

standby 0 ip 10.10.40.1

standby 0 preempt

standby 0 priority 150

standby 0 name mobileStandby

 

interface GigabitEthernet0/0

description local access subnet

ip address 10.10.50.1 255.255.255.0

 

 

interface GigabitEthernet0/2

description HSRP connected interface

ip address 10.10.40.3 255.255.255.0

standby 0 ip 10.10.40.1

standby 0 preempt

standby 0 name mobileStandby

 

 

interface GigabitEthernet0/0

description local access subnet

ip address 10.10.60.1 255.255.255.0

 

Mobile IP

ip mobile home-agent address 10.10.40.1
ip mobile home-agent redundancy mobileStandby virtual-network address 10.10.40.1 mode active-standby
ip mobile virtual-network 192.168.1.0 255.255.255.0 address 10.10.40.1
ip mobile host 192.168.1.0 192.168.1.254 virtual-network 192.168.1.0 255.255.255.0
ip mobile secure host 192.168.1.0 255.255.255.0 spi D1EA15FC key hex 4d051cd2d14cd658342ed0cb9ef4ab6b algorithm hmac-md5
ip mobile secure home-agent 10.10.40.3 spi 100 key hex 00112233445566778899001122334455 algorithm md5 mode prefix-suffix

 

ip mobile home-agent address 10.10.40.1
ip mobile home-agent redundancy mobileStandby virtual-network address 10.10.40.1 mode active-standby
ip mobile virtual-network 192.168.1.0 255.255.255.0 address 10.10.40.1
ip mobile host 192.168.1.0 192.168.1.254 virtual-network 192.168.1.0 255.255.255.0
ip mobile secure host 192.168.1.0 255.255.255.0 spi D1EA15FC key hex 4d051cd2d14cd658342ed0cb9ef4ab6b algorithm hmac-md5
ip mobile secure home-agent 10.10.40.2 spi 100 key hex 00112233445566778899001122334455 algorithm md5 mode prefix-suffix

 

 

 

 

 

 

Everyone's tags (1)
24
Views
0
Helpful
0
Replies
CreatePlease to create content