Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Host LACP on a 6500 w/vlans

Howdy,

I would like to use LACP wih 2 NIC's on a server connecting to a 6509 blade. Problem seems to be that you can't put a port-channel interface in a vlan. Am I reading the docs correctly? Is there a workaround for this other than haveing a bunch of /30 subnets everywhere?

Thanks,

Mike

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Host LACP on a 6500 w/vlans

You'll need to configure the port-channel, it will just be layer2.

Heres an example of a switchport-

interface GigabitEthernet9/3

description BladeCenter

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,501,541-543

switchport mode trunk

switchport nonegotiate

no ip address

speed 1000

duplex full

channel-group 10 mode active

Example of the Port-Channel-

interface Port-channel10

description BladeCenter

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,501,541-543

switchport mode trunk

switchport nonegotiate

no ip address

10 REPLIES
Hall of Fame Super Blue

Re: Host LACP on a 6500 w/vlans

Hi Mike

Could you point to the docs as to where it says that you can't do this. As lomg as all the ports are in the same vlan there is no reason why an etherchannel cannot be an access link rather than a trunk link.

Hope i've not misunderstood

Jon

New Member

Re: Host LACP on a 6500 w/vlans

Can't remember the exact reference, but anyway, here is what happens if you try it

interface Port-channel2

description Wintel Server

no ip address

shutdown

S3EDC03B#conf t

Enter configuration commands, one per line. End with CNTL/Z.

S3EDC03B(config)#interface port-channel 2

S3EDC03B(config-if)#switchport access vlan 248

Command rejected: Po2 not a switching port.

S3EDC03B(config-if)#

Hall of Fame Super Blue

Re: Host LACP on a 6500 w/vlans

Mike

I will check this tomorrow but i don't think you tell the port-channel what vlan it is in. You just make sure that the individual ports that make up the port-channel are all in the smae vlan.

HTH

Jon

New Member

Re: Host LACP on a 6500 w/vlans

Here is what happens when I try to add vlan access to port-channeled ports:

Command rejected (Port-channel2, Gi7/1): Either port is L2 and port-channel is L3, or vice-versa

S3EDC03B(config-if-range)#

This looks like I need more L3 in the mix to me.

Re: Host LACP on a 6500 w/vlans

We trunk the ports instead of trying to use them as access ports. Can you do that?

New Member

Re: Host LACP on a 6500 w/vlans

Can you expand on your answer? Trunking is normally switch to switch, not host to switch.

Mike

Re: Host LACP on a 6500 w/vlans

You can trunk to a host, you just need a NIC that supports it. We do it with our ESX Servers. By trunking it you will still have VLAN access.

New Member

Re: Host LACP on a 6500 w/vlans

Sounds like the old joke, you can tune a piano, but you can't tune a fish (couldn't resist!)

So, just 802.1q trunks and no port-channel?

Re: Host LACP on a 6500 w/vlans

You'll need to configure the port-channel, it will just be layer2.

Heres an example of a switchport-

interface GigabitEthernet9/3

description BladeCenter

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,501,541-543

switchport mode trunk

switchport nonegotiate

no ip address

speed 1000

duplex full

channel-group 10 mode active

Example of the Port-Channel-

interface Port-channel10

description BladeCenter

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,501,541-543

switchport mode trunk

switchport nonegotiate

no ip address

New Member

Re: Host LACP on a 6500 w/vlans

That did the trick! Thanks!

6120
Views
0
Helpful
10
Replies