Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

How can I add IP address to 2950 Catalyst?

I have a 2950 cataylst that I need to access via it's IP address, I then want to use SNMP to monitor ports.

I added an IP address to VLAN1 but can't ping it. I have 6 other VLAN in it and have tried ping from the 2950 in hyper terminal but I get nothing. With so many VLANS etc what is it's gateway into the LAN?

9 REPLIES

Re: How can I add IP address to 2950 Catalyst?

Hi,

You need to access the switch from a port that belongs to the management VLAN (VLAN 1 in your case, since you have entered the IP address under interface VLAN1).

[edit] You should be using a separate IP subnet for each VLAN as a best practice, and the default-gateway for this layer 2 switch in this case is the default-gateway for VLAN 1 as VLAN 1 is your management VLAN, and further more this default-gateway will make you able to access the switch remotely and from other VLANs.

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

Cisco Employee

Re: How can I add IP address to 2950 Catalyst?

Hi Friend,

2950 being a layer 2 siwtch is only capable of having one layer 3 logical interface for management purpose. Now as you added ip address in interface vlan 1 first thing make sure you have atleast one physical interface attached to vlan 1 or a trunk port allowing that vlan.

Then make sure you add a gateway ip address on your 2950 switch pointing to layer 3 device which will route between all your vlans.

Something like this

ip default-gateway

This ip address should be the ip which is configured on your layer 3 switch/router for vlan 1.

HTH

Ankur

*Pls rate all helpfull post

Community Member

Re: How can I add IP address to 2950 Catalyst?

Hi, when you say I need a physical link into our LAN switch, port 2 which is on VLAN2 (has port 1,2 & 3) has a network cable in to LAN switch.

Should it use this?

Re: How can I add IP address to 2950 Catalyst?

Hi,

You need to access the switch from a device connected to a port that belongs to the management VLAN (VLAN1 in your case).

HTH, please do rate all helpful replies,

Mohammed Mahmoud.

Community Member

Re: How can I add IP address to 2950 Catalyst?

Sorry for these basic questions, how can i tell what is in VLAN 1? A show config shows no VLAN created, just VLAN 1 and it's IP address.

Re: How can I add IP address to 2950 Catalyst?

Hi,

By default all ports are on VLAN 1, unless "switchport access vlan x" command is configured under the interface.

HTH,

Mohammed Mahmoud.

Cisco Employee

Re: How can I add IP address to 2950 Catalyst?

Hi,

Just do a " show vlan " and it should tell you that which port belongs to to which vlan. Then if you have any port in the vlan1, you connect your PC to the same port and you should be able to ping the switch and access it.

Please paste the output of " show vlan " and " show config" here and we will be able to help further on this.

HTH,Please rate if it does.

-amit singh

Community Member

Re: How can I add IP address to 2950 Catalyst?

Hi, here it is in 2 parts:

core1#sh vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/21, Fa0/22, Fa0/24, Gi0/2

2 fwinside active Fa0/1, Fa0/2, Fa0/3

3 fwoutside active Fa0/4, Fa0/5, Fa0/6

4 dmz1 active Fa0/7, Fa0/8, Fa0/9, Fa0/10

Fa0/11, Fa0/12, Fa0/13, Fa0/14

Fa0/15, Fa0/16, Fa0/20, Fa0/23

5 dmz2 active

6 VLAN0006 active Gi0/1

7 VLAN0007 active Fa0/17, Fa0/18, Fa0/19

8 VLAN0008 active

1002 fddi-default act/unsup

1003 token-ring-default act/unsup

1004 fddinet-default act/unsup

1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 0 0

2 enet 100002 1500 - - - - - 0 0

3 enet 100003 1500 - - - - - 0 0

4 enet 100004 1500 - - - - - 0 0

5 enet 100005 1500 - - - - - 0 0

6 enet 100006 1500 - - - - - 0 0

7 enet 100007 1500 - - - - - 0 0

8 enet 100008 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 tr 101003 1500 - - - - - 0 0

1004 fdnet 101004 1500 - - - ieee - 0 0

1005 trnet 101005 1500 - - - ibm - 0 0

Remote SPAN VLANs

------------------------------------------------------------------------------

Primary Secondary Type Ports

------- --------- ----------------- ------------------------------------------

Community Member

Re: How can I add IP address to 2950 Catalyst?

core1#sh conft

!

version 12.1

service timestamps debug uptime

service timestamps log datetime

service sequence-numbers

!

hostname core1

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

--More-- interface FastEthernet0/1

--More-- description Management interface

--More-- switchport access vlan 2

switchport mode access

duplex full

speed 100

!

interface FastEthernet0/2

description Link to *******

switchport access vlan 2

switchport mode access

duplex full

speed 100

!

interface FastEthernet0/3

description Link to LAN inside

switchport access vlan 2

switchport mode access

duplex full

speed 100

!

interface FastEthernet0/4

description Link to *******

switchport access vlan 3

switchport mode access

--More-- duplex full

speed 100

!

interface FastEthernet0/5

description Link ********

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/6

description link to ******

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/7

description Link to ****

switchport access vlan 4

switchport mode access

duplex full

speed 100

!

interface FastEthernet0/8

description Link to *****

switchport access vlan 4

--More-- switchport mode access

duplex full

speed 100

!

interface FastEthernet0/9

description Link *****

switchport access vlan 4

switchport mode access

!

interface FastEthernet0/10

description Link ******

switchport access vlan 4

switchport mode access

duplex full

speed 100

!

interface FastEthernet0/11

description link to ********

switchport access vlan 4

switchport mode access

duplex full

speed 100

!

--More-- interface FastEthernet0/12

description Link to ********

switchport access vlan 4

switchport mode access

duplex full

speed 100

!

interface FastEthernet0/13

description *******

switchport access vlan 4

switchport mode access

duplex full

speed 100

!

interface FastEthernet0/14

description ******

switchport access vlan 4

switchport mode access

duplex full

speed 100

!

interface FastEthernet0/15

description ****

--More-- switchport access vlan 4

switchport mode access

duplex full

speed 100

!

interface FastEthernet0/16

description *****

switchport access vlan 4

switchport mode access

speed 100

!

interface FastEthernet0/17

description *****

switchport access vlan 7

switchport mode access

!

interface FastEthernet0/18

description ******

switchport access vlan 7

switchport mode access

!

interface FastEthernet0/19

description ********

--More-- switchport access vlan 7

switchport mode access

!

interface FastEthernet0/20

description Lin to VLAN4 spare

switchport access vlan 4

switchport mode access

!

interface FastEthernet0/21

description VLAN 8 for LAN IP connection

!

interface FastEthernet0/22

description Link to *****

!

interface FastEthernet0/23

switchport access vlan 4

switchport mode access

duplex full

speed 100

!

interface FastEthernet0/24

description Link to *******

!

--More-- interface GigabitEthernet0/1

description To Ground Floor

switchport access vlan 6

switchport mode access

!

interface GigabitEthernet0/2

!

interface Vlan1

ip address 192.168.200.52 255.255.0.0

ip access-group 1 in

no ip route-cache

!

interface Vlan2

no ip address

no ip route-cache

shutdown

!

interface Vlan8

no ip address

no ip route-cache

shutdown

!

ip http server

--More-- !

logging trap warnings

logging facility local4

logging

snmp-server community

!

line con 0

line vty 0 4

password ****

login

line vty 5 15

password *****

login

!

!

monitor session 1 source interface Fa0/1 , Fa0/11

monitor session 1 destination interface Fa0/24

end

core1#

396
Views
0
Helpful
9
Replies
CreatePlease to create content