Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How can you setup VLAN between Cisco 3845 Router and the Integrated service module?

Dear Cisco Community,

I have a Cisco 3845 Integrated Service Router and I have installed a Service Module.

I want to use the integrated Gigabit ports as switch ports and put ports in the Service Module and Gigabit port in a VLAN.

Is this possible? can it be done by setting internal Gigabit link as trunk and how?

can anyone please guide me?

Below is the somewhat the setup i am looking for

Service module

fa0/1 |

fa0/2 | Vlan X

fa0/3 |                       

fa0/4 |

fa0/5 | Vlan Y

fa0/6 |

Router 3845

Ga0/0 Vlan X

Ga0/1 Vlan Y

Any support is much appreciated.

Thank you

7 REPLIES
Purple

How can you setup VLAN between Cisco 3845 Router and the Integra

Someone else can chime in too  but I don't believe you can do that .  The service module is basically a standalone switch in a slot .  Don't think you can put a vlan on an internal gig port  and have the same vlan on the switch module.

Silver

How can you setup VLAN between Cisco 3845 Router and the Integra

Marwan Khoury wrote:

Dear Cisco Community,

I have a Cisco 3845 Integrated Service Router and I have installed a Service Module.

I want to use the integrated Gigabit ports as switch ports and put ports in the Service Module and Gigabit port in a VLAN.

Is this possible? can it be done by setting internal Gigabit link as trunk and how?

can anyone please guide me?

Below is the somewhat the setup i am looking for

Service module

fa0/1 |

fa0/2 | Vlan X

fa0/3 |                       

fa0/4 |

fa0/5 | Vlan Y

fa0/6 |

Router 3845

Ga0/0 Vlan X

Ga0/1 Vlan Y

Any support is much appreciated.

Thank you

You can't. The fixed ports are not switch ports, so you can't add them to a VLAN

You can create a trunk between the fixed ports and the SM - but you have to create sub-interfaces in the internal 1 gig interface.

This is how I've done it (albeit on a 2900 series, but the concept is the same, just writ small)

interface GigabitEthernet1/0

description Backplane link to interface g0/26 on switch module

ip address 1.1.1.1 255.255.255.0

!

interface GigabitEthernet1/0.3

encapsulation dot1Q 3

ip address 10.50.12.253 255.255.255.0

ip helper-address 10.50.12.2

ip virtual-reassembly in

vrrp 2 description  LAN

vrrp 2 ip 10.50.12.254

vrrp 2 preempt delay minimum 5

vrrp 2 priority 110

And on the switch module (SM-ES3-24-P)

interface GigabitEthernet0/26

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Vlan3

ip address 10.50.12.251 255.255.255.0

ip helper-address 10.50.12.2

That links the two internal gigabit ports together - but it's only useful in that I don't really need a router IP on the switch module (although there is one for management purposes), and I can use the fixed ports in the 2900 router side for actual routing/NAT etc, which the switch module doesn't support.

I'm sure someone will correct me if I'm wrong. And, if they do, I'll eagerly thank them for the answer to a problem I've eben trying to sort out for months. :-)

New Member

How can you setup VLAN between Cisco 3845 Router and the Integra

first thank you for your reply.

so the only way i can achieve what i am looking for is by defining subint.

Currently i am using static route to route traffic from service module to the router.

By defining subint on the SM and allowing the vlans I want, will i still be needing the static route to reach the routers?

and one more thing that has been bothering me, who will remove the tag ID?

Will it be removed on the router or on the SM switch or never?

regards,

Silver

How can you setup VLAN between Cisco 3845 Router and the Integra

Marwan Khoury wrote:

first thank you for your reply.

so the only way i can achieve what i am looking for is by defining subint.

Currently i am using static route to route traffic from service module to the router.

By defining subint on the SM and allowing the vlans I want, will i still be needing the static route to reach the routers?

and one more thing that has been bothering me, who will remove the tag ID?

Will it be removed on the router or on the SM switch or never?

regards,

No, you won't need a static route on your SM to get to the router - because the IP address on the router sub interface will effectively be on the same VLAN as the ports in your SM, so they'll "see" it.

I assume you could do multiple VLAN's by defining multiple sub interfaces in your internal gig-E port if you have different VLAN's on the SM which need routing.

The tag will be removed by the router - because the fixed port(s) on the router are *not* a switch port, and doesn't recognise the tags (AFAIK, I could be wrong), so any packet which egresses the fixed port will be untagged, and any packet which ingresses via the fixed port to the SM will have a tag added when it hits the switch module.

Cheers.

New Member

How can you setup VLAN between Cisco 3845 Router and the Integra

Hi Darren,

Thank you for your response.

I remember I tried doing subinterfaces on the internal gigabit link on the router side, but I failed to do so.

Are you sure i can create subint on the Router side?

Regards,

Silver

How can you setup VLAN between Cisco 3845 Router and the Integra

Marwan Khoury wrote:

Hi Darren,

Thank you for your response.

I remember I tried doing subinterfaces on the internal gigabit link on the router side, but I failed to do so.

Are you sure i can create subint on the Router side?

Regards,

You should be able to. What IOS version/Feature set are you running on the router?

Cheers

New Member

How can you setup VLAN between Cisco 3845 Router and the Integra

I will try the subint again and I will reply as soon as I can, whether it worked or it failed.

Thanks again

1659
Views
0
Helpful
7
Replies
CreatePlease login to create content