Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

How do I get my VLAN 40 to communicated to my DHCP Server to get an Address

My DHCP Server is on 192.43.100.100

I have VLAN Set up on my SG500 switch.

I want to have the VLAN 40 on my switch to communicate to the DHCP server so that anything on the VLAN40 can pick up an IP Address automatically.

I have created a Scope called VLAN 40 - 192.43.104.0 on the DHCP Server.

What do I need to do to get this to work? What command to I need to type to get this working? Do I need to use IPHelper?

Everyone's tags (2)
10 REPLIES
VIP Purple

Re: How do I get my VLAN 40 to communicated to my DHCP Server to

Hi Tanoop ,

just provide the ip helper address under interface vlan40.

just like this:

interface Vlan40

ip address 192.43.104.254 255.255.255.0----check this according to u

ip helper-address 192.43.x.x--------------Where DHCP server address

and teh interface where ur DHCP server conneted put this config:

interface FastEthernet0/17

description *** xyz ***

.

.

.

ip dhcp snooping trust

Regards

Please rate if it help

New Member

How do I get my VLAN 40 to communicated to my DHCP Server to get

Hello, you can confirm me if it is possible configure as DHCP Server to the SG500?

How do I get my VLAN 40 to communicated to my DHCP Server to get

hi,

use ip helper-address command below the vlan 40 interface config.

Alessio

New Member

Re: How do I get my VLAN 40 to communicated to my DHCP Server to

Hi,

This is what I get.. what am I missing for the mandatory parameter?

Switch1#config

Switch1(config)#interface Vlan40

Switch1(config-if)#ip address 192.43.104.254 255.255.255.0

Duplicated IP interface on the same subnet.

Switch1(config-if)#ip address 192.43.104.1 255.255.255.0

Switch1(config-if)#ip helper-address 192.43.100.100

% missing mandatory parameter

Switch1(config-if)#

VIP Purple

Re: How do I get my VLAN 40 to communicated to my DHCP Server to

HI Tanoop,

Can you paste ur config?

so that we can find the error:

     

I just attached the test config .....see this and tray again.

Regards

Please rate if it helps.

New Member

Re: How do I get my VLAN 40 to communicated to my DHCP Server to

Switch1#show running-config

vlan database

vlan 20,30,40,50,60,70

exit

voice vlan state disabled

voice vlan oui-table add 0001e3 Siemens_AG_phone________

voice vlan oui-table add 00036b Cisco_phone_____________

voice vlan oui-table add 00096e Avaya___________________

voice vlan oui-table add 000fe2 H3C_Aolynk______________

voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone

voice vlan oui-table add 00d01e Pingtel_phone___________

voice vlan oui-table add 00e075 Polycom/Veritel_phone___

voice vlan oui-table add 00e0bb 3Com_phone______________

ip dhcp snooping

ip dhcp snooping information option allowed-untrusted

ip dhcp relay address 192.9.100.100

ip dhcp relay enable

ip dhcp information option

bonjour interface range vlan 1

hostname Switch1

line console

exec-timeout 30

exit

line ssh

exec-timeout 30

exit

line telnet

exec-timeout 30

exit

username cisco password encrypted 490c76f46beb5a5fcbf85cc9b29adedd49f35180 privi

lege 15

no snmp-server server

ip http timeout-policy 1800

ip http secure-server

ip domain name mdha.local

ip name-server  192.9.100.100

ip telnet server

!

interface vlan 1

ip address 192.9.100.82 255.255.254.0

no ip address dhcp

!

interface vlan 20

name Voice

!

interface vlan 30

name Servers

!

interface vlan 40

name Computers

ip address 192.9.104.254 255.255.255.0

ip dhcp relay enable

!

interface vlan 50

name Printers

!

interface vlan 60

name Wireless

!

interface vlan 70

name Network

!

interface gigabitethernet1/1/1

ip dhcp snooping trust

!

interface gigabitethernet1/1/7

switchport trunk native vlan 40

switchport default-vlan tagged

!

banner login ^C

CH COMMS ROOM

^C

macro auto processing type host enabled

macro auto processing type router enabled

ip helper-address all 192.0.100.100 37 42 49 53 137 138

ip helper-address all 192.9.100.100 37 42 49 53 137 138

ip route 192.9.102.0 255.255.255.0 192.9.100.100

Switch1#

New Member

How do I get my VLAN 40 to communicated to my DHCP Server to get

Hola, me podrías indicar si es posible que el Switch SG500 actúe como DHCP Server??

New Member

How do I get my VLAN 40 to communicated to my DHCP Server to get

Hi Tanoop,

U need to enable intervlan routing for the Server to communicate with that.

Refer Below Docs as well...

http://networkcity.blogspot.in/2010/01/configuring-inter-vlan-routing-and-dhcp.html?spref=fb

http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008019e74e.shtml

Regards

Pradeep Poojari

Please rate if it Serves you

New Member

How do I get my VLAN 40 to communicated to my DHCP Server to get

Hola, me podrías indicar si es posible que el Switch SG500 actúe como DHCP Server??

New Member

Re: How do I get my VLAN 40 to communicated to my DHCP Server to

Any ideas on what I am doing wrong from the Logs??

3542
Views
0
Helpful
10
Replies
CreatePlease to create content