Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How Do I reset a Cisco 800 back to factory defults?

I have a cisco 800 that needs to be reset back to factory defaults. I tried typing in "config factory-default 10.10.10.1 255.255.255.0" at the conf t prompt, but I got an error Invaild input detected at ^ (the ^ is just under the word factory). So after a bit of reserch I came across this command "write erase"

that seemed to do something but now I can't get any ip addreses. Here is the running config:

Using 1104 out of 131072 bytes

!

version 12.4

service config

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname *Host Name*

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$7sCe$otJJdbrbqgn/WkFF8Aqzt.

enable password *Password*

!

no aaa new-model

!

!

dot11 syslog

no ip routing

!

!

no ip cef

!

!

!

!

!

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0

shutdown

no cdp enable

!

interface FastEthernet1

no cdp enable

!

interface FastEthernet2

shutdown

no cdp enable

!

interface FastEthernet3

shutdown

no cdp enable

!

interface FastEthernet4

no ip address

ip broadcast-address 0.0.0.0

no ip route-cache

shutdown

duplex auto

speed auto

no cdp enable

!

interface Vlan1

no ip address

ip broadcast-address 0.0.0.0

no ip route-cache

shutdown

!

ip forward-protocol nd

!

no ip http server

no ip http secure-server

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

no modem enable

line aux 0

line vty 0 4

password *Password*

login

!

scheduler max-task-time 5000

no process cpu extended

no process cpu autoprofile hog

end

I would like to get the router to a state where I can get to the web page and configure it. Thanks.

1 ACCEPTED SOLUTION

Accepted Solutions

How Do I reset a Cisco 800 back to factory defults?

Hi,

Q. How do you set the router back to its factory default settings?

A. To set the router back to its factory defaults, you can either use Cisco SDM or you can go into the Cisco IOS Software CLI and do a "write erase" on the router itself, or grab the factory default configuration from Cisco Configuration Express. In addition, when the reset button is pressed within 5 seconds of the boot up and there is a valid xxx.cfg file in the flash, the router boots up with the xxx.cfg file and avoids the startup-config file in NVRAM.

See the below link will help you in step by step instructions to follow...

http://www.cisco.com/en/US/products/sw/iosswrel/ps5187/products_tech_note09186a00802017a1.shtml

Please rate all the helpfull posts.

Regards,

Naidu.

13 REPLIES
Silver

How Do I reset a Cisco 800 back to factory defults?

jsandau@mpe.ca wrote:

I have a cisco 800 that needs to be reset back to factory defaults. I tried typing in "config factory-default 10.10.10.1 255.255.255.0" at the conf t prompt, but I got an error Invaild input detected at ^ (the ^ is just under the word factory). So after a bit of reserch I came across this command "write erase"

that seemed to do something but now I can't get any ip addreses. Here is the running config:

Enter the following commands

router# configure terminal

router(config)#interface vlan1

router(config-in)#ip address 10.10.10.1 255.255.255.0

router(config-if)#no shut

router(config-if)#exit

router(config)#interface f0

router(config-if)#switchport access vlan 1

router(config-if)#no shut

router(config-if)#exit

router(config)#ip http server

router(config-if)end

router#copy run start

Plug your PC into interface F0, assign it an IP address in the 10.10.10.0/24 address (not 10.10.10.1, which is your router), and you should be able to access the routers web interface and configure it.

Cheers.

New Member

Re: How Do I reset a Cisco 800 back to factory defults?

I get an invalid input detected at ^ marker when i put in the switchport access vlan 1 command. the ^ marker is under the w in the switchport command.

I also got the following error when I was typing in the commands, or if i let it idle for a few seconds:

%Error opening tftp://255.255.255.255/network-confg (Socket error)

%Error opening tftp://255.255.255.255/cisconet.cfg (Socket error)

%Error opening tftp://255.255.255.255/host-confg (Socket error)

%Error opening tftp://255.255.255.255/host.cfg (Socket error)

*Sep 28 03:24:45.335: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (t

ftp://255.255.255.255/network-confg) failed

*Sep 28 03:24:45.335: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (t

ftp://255.255.255.255/cisconet.cfg) failed

*Sep 28 03:24:45.339: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (t

ftp://255.255.255.255/host-confg) failed

*Sep 28 03:24:45.339: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (t

ftp://255.255.255.255/host.cfg) failed

Silver

How Do I reset a Cisco 800 back to factory defults?

jsandau@mpe.ca wrote:

I get an invalid input detected at ^ marker when i put in the switchport access vlan 1 command. the ^ marker is under the w in the switchport command.

That's OK - the switchport on F0 should default to VLAN1 anyway, so you should be OK.

Can you post the output of "show running-config" after you've made the changes? Also "show ip int brief" as well.

I also got the following error when I was typing in the commands, or if i let it idle for a few seconds:

%Error opening tftp://255.255.255.255/network-confg (Socket error)

%Error opening tftp://255.255.255.255/cisconet.cfg (Socket error)

%Error opening tftp://255.255.255.255/host-confg (Socket error)

%Error opening tftp://255.255.255.255/host.cfg (Socket error)

*Sep 28 03:24:45.335: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (t

ftp://255.255.255.255/network-confg) failed

*Sep 28 03:24:45.335: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (t

ftp://255.255.255.255/cisconet.cfg) failed

*Sep 28 03:24:45.339: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (t

ftp://255.255.255.255/host-confg) failed

*Sep 28 03:24:45.339: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (t

ftp://255.255.255.255/host.cfg) failed

OK, that's weird - it's trying to load a config from a network boot server - I can't see where in your original posted config it would be doing this - post the current config, please.

Cheers

Cheers

New Member

Re: How Do I reset a Cisco 800 back to factory defults?

Here is the running config:

Building configuration...

Current configuration : 1101 bytes

!

version 12.4

service config

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname *host*

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$7sCe$otJJdbrbqgn/WkFF8Aqzt.

enable password *Password*

!

no aaa new-model

!

!

dot11 syslog

no ip routing

!

!

no ip cef

!

!

!

!

!

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0

no cdp enable

!

interface FastEthernet1

no cdp enable

!

interface FastEthernet2

shutdown

no cdp enable

!

interface FastEthernet3

shutdown

no cdp enable

!

interface FastEthernet4

no ip address

ip broadcast-address 0.0.0.0

no ip route-cache

shutdown

duplex auto

speed auto

no cdp enable

!

interface Vlan1

ip address 10.10.10.1 255.255.0.0

ip broadcast-address 0.0.0.0

no ip route-cache

!

ip forward-protocol nd

!

ip http server

no ip http secure-server

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

no modem enable

line aux 0

line vty 0 4

password *Password*

login

!

scheduler max-task-time 5000

no process cpu extended

no process cpu autoprofile hog

end

Shouldn't there be a way to reset to factory defaults and have it work right out of the box (so I can at least get DCHP and internet)?

Edit: I can get to the web interface if I change the ip on my computer to something in the 10.10.10.x range, but I can't do anything in the web interface. I can't click on any of the categories or anything.

Silver

How Do I reset a Cisco 800 back to factory defults?

jsandau@mpe.ca wrote:

Here is the running config:

That looks OK - you should be able to plug into F0, assign your PC an IP address in the right range (not via DHCP, as there's no DHCP configured) and access the web configuration.


Shouldn't there be a way to reset to factory defaults and have it work right out of the box (so I can at least get DCHP and internet)?

It really depends on the router model. Most Cisco kit assumes you have a basic knowledge and can use the console cable to set up the minimal config - you don't mention the exact model number, so I can't be sure of the defaults (and I have to admit to never pulling an 800 series out of a box and starting from scratch), but based on the bigger boxes I'm used to no, there's not - you at least need to put in basic information to get it working.

Cheers.

Please rate helpful posts.

New Member

Re: How Do I reset a Cisco 800 back to factory defults?

I can get to the web interface if I change the ip on my computer to something in the 10.10.10.x range, but I can't do anything in the web interface. I can't click on any of the categories or anything.

Silver

Re: How Do I reset a Cisco 800 back to factory defults?

jsandau@mpe.ca wrote:

I can get to the web interface if I change the ip on my computer to something in the 10.10.10.x range, but I can't do anything in the web interface. I can't click on any of the categories or anything.

What version of IOS is the router running?? Does it have all the web support files installed?

Can you post the output of the following command

sh flash:

listing all the files?

Oh, and what password are you using to authenticate when you access the web page? The enable secret one?

Cheers.

New Member

Re: How Do I reset a Cisco 800 back to factory defults?

darren.g wrote:

What version of IOS is the router running?? Does it have all the web support files installed?


Here are the results of the sh flash:

0480K bytes of processor board System flash (Intel Strataflash)

Directory of flash:/

    2  -rwx    12701008   --- -- ---- --:--:-- -----  c850-advsecurityk9-mz.124-15.T7.bin
    3  -rwx        3179   Mar 1 2002 00:04:03 +00:00  sdmconfig-8xx.cfg
    4  -rwx      931840   Mar 1 2002 00:04:22 +00:00  es.tar
    5  -rwx     1505280   Mar 1 2002 00:04:47 +00:00  common.tar
    6  -rwx        1038   Mar 1 2002 00:04:58 +00:00  home.shtml
    7  -rwx      112640   Mar 1 2002 00:05:11 +00:00  home.tar

19353600 bytes total (4091904 bytes free)

and the password I an using is the enable password

Re: How Do I reset a Cisco 800 back to factory defults?

Hi,

There's a reset button behind. Press it for 5 seconds upon booting up to restore the device to default settings.

http://www.cisco.com/en/US/prod/collateral/routers/ps380/ps6200/prod_qas0900aecd8028a982_ps380_Products_Q_and_A_Item.html

Here's a useful link for the minimum config required to make the web GUI work.

http://www.cisco.com/en/US/docs/net_mgmt/cisco_configuration_professional_express/version1_0/rlsnotes/CiscoCPEr10.html

Sent from Cisco Technical Support iPhone App

How Do I reset a Cisco 800 back to factory defults?

Hi,

Q. How do you set the router back to its factory default settings?

A. To set the router back to its factory defaults, you can either use Cisco SDM or you can go into the Cisco IOS Software CLI and do a "write erase" on the router itself, or grab the factory default configuration from Cisco Configuration Express. In addition, when the reset button is pressed within 5 seconds of the boot up and there is a valid xxx.cfg file in the flash, the router boots up with the xxx.cfg file and avoids the startup-config file in NVRAM.

See the below link will help you in step by step instructions to follow...

http://www.cisco.com/en/US/products/sw/iosswrel/ps5187/products_tech_note09186a00802017a1.shtml

Please rate all the helpfull posts.

Regards,

Naidu.

New Member

Re: How Do I reset a Cisco 800 back to factory defults?

The Model is Cisco 850 and the IOS version is 12.4(15)T7 if that helps.

New Member

Re: How Do I reset a Cisco 800 back to factory defults?

I was able to get into CCP and configure some settings. I have DHCP working, but I still can't get on the Internet. I have FE4 (The WAN port) set to get an ip address via DHCP, but when I do a test connection from CCP I get this error:

Checking interface IP address…failed

No Ip Address for the interface has been obtained. The interface is configured to obtain an ip address through dhcp. The remote end may not be configured with a dhcp server or the dhcp pool may be empty.

Recommended actions

Please contact your ISP or WAN administrator and check if the server has been configured to lease ip addresses to the client’s connection through DHCP. Retest connection

I know that the modem is providing an ip address via dchp, because I can plug my computer directly into  the modem and get an ip address, so I think I may have missed a setting on the router. Here is he running config:

Building configuration...

Current configuration : 1833 bytes

!

version 12.4

service config

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname *host*

!

boot-start-marker

boot-end-marker

!

no logging buffered

enable secret 5 $1$7sCe$otJJdbrbqgn/WkFF8Aqzt.

enable password *password*

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

!

aaa session-id common

!

!

dot11 syslog

no ip routing

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.0.1 10.10.10.99

ip dhcp excluded-address 10.10.10.201 10.10.255.254

!

ip dhcp pool Vlan1

   network 10.10.0.0 255.255.0.0

   default-router 10.10.10.1

!

!

no ip cef

ip name-server 64.59.135.133

ip name-server 64.59.135.135

!

!

!

username admin privilege 15 secret 5 $1$almq$LzL55/3z.g3Sq9fpSvv8e0

!

!

archive

log config

hidekeys

!

!

!

!

!

interface FastEthernet0

no cdp enable

!

interface FastEthernet1

no cdp enable

!

interface FastEthernet2

no cdp enable

!

interface FastEthernet3

no cdp enable

!

interface FastEthernet4

description $ETH-WAN$

ip address dhcp client-id FastEthernet4

ip broadcast-address 0.0.0.0

ip nat outside

ip virtual-reassembly

no ip route-cache

duplex auto

speed auto

no cdp enable

!

interface Vlan1

ip address 10.10.10.1 255.255.0.0

ip broadcast-address 0.0.0.0

ip nat inside

ip virtual-reassembly

no ip route-cache

!

ip forward-protocol nd

!

ip http server

no ip http secure-server

ip nat inside source list 1 interface FastEthernet4 overload

!

access-list 1 remark INSIDE_IF=Vlan1

access-list 1 remark CCP_ACL Category=2

access-list 1 permit 10.10.0.0 0.0.255.255

!

control-plane

!

!

line con 0

exec-timeout 0 0

no modem enable

line aux 0

line vty 0 4

password *password*

!

scheduler max-task-time 5000

no process cpu extended

no process cpu autoprofile hog

end

How Do I reset a Cisco 800 back to factory defults?

Hi,

FE4 interface config needs to be change it seems.

You may need to add the command "ip address negotiated" because this interface need to negotiate with the DSL modem for an IP.

See the below examples may helps you....

Now we configure one Ethernet interface for use as our WAN interface.


router(config)#interface Ethernet1

router(config-if)#description ADSL WAN Interface

router(config-if)#no ip address

router(config-if)#no ip redirects

router(config-if)#no ip unreachables

router(config-if)#no ip proxy-arp

router(config-if)#no ip mroute-cache

router(config-if)#pppoe enable

router(config-if)#no cdp enable

router(config-if)#exit


Now to add your Dialer interface:


router(config)#interface Dialer1

router(config-if)#description ADSL WAN Dialer

router(config-if)#ip address negotiated

router(config-if)#no ip unreachables

router(config-if)#ip nat outside

router(config-if)#encapsulation ppp

router(config-if)#no ip mroute-cache

router(config-if)#dialer pool 1

router(config-if)#dialer-group 1

router(config-if)#no cdp enable

Please rate all the helpfull posts.

Regards,

Naidu.

12176
Views
8
Helpful
13
Replies