Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

How does HSRP works

Hello there!

Please S.O.S.

We have on our campus two 6509 connected together with a Gig link running hsrp.

Master 10.1.16.4 Standby client 10.1.16.5 and vertual and default gateway for hosts 10.1.16.1

I have a filling hsrp is no longer working.

Problem 1. When i create a vlan on the master it does not get copied to the standby as was before.

Problem 2. Now i can configure vlans on any switch on the network standby or any other client switch which was not posible before. Initially i could add vlans from the master switch only and they get sychronized to standby and others.

There seems to be no sych between master and stanby switches or HSRP is not functining completely.

see data below.

Master

IOS ver.

IOS (tm) c6sup2_rp Software (c6sup2_rp-PK2SV-M), Version 12.1(19)E1, EARLY DEPLO

YMENT RELEASE SOFTWARE (fc2)

interface Vlan1

ip address 10.1.28.4 255.255.240.0 secondary

ip address 168.167.60.1 255.255.252.0 secondary

ip address 10.1.16.4 255.255.240.0

ip helper-address 10.6.1.21

no ip redirects

no logging event link-status

standby ip 10.1.28.1

standby priority 110

standby preempt

standby 1 ip 10.1.16.1

standby 1 priority 110

standby 1 preempt

standby 2 ip 168.167.60.4

standby 2 priority 110

standby 2 preempt

GAB-ML-IT-1-RS-01-6509# sh vtp status

VTP Version : 2

Configuration Revision : 104

Maximum VLANs supported locally : 1005

Number of existing VLANs : 34

VTP Operating Mode : Server

VTP Domain Name : BTC-HO

VTP Pruning Mode : Disabled

VTP V2 Mode : Enabled

VTP Traps Generation : Enabled

MD5 digest : 0x18 0x72 0x26 0xFD 0x97 0x1C 0x84 0x02

Configuration last modified by 10.1.16.4 at 6-2-08 07:13:44

Local updater ID is 10.1.16.4 on interface Vl1 (lowest numbered VLAN interface f

ound)

GAB-ML-IT-1-RS-01-6509#

STANDBY

IOS ver.

IOS (tm) c6sup2_rp Software (c6sup2_rp-PK2SV-M), Version 12.1(19)E1, EARLY DEPLO

YMENT RELEASE SOFTWARE (fc2)

interface Vlan1

ip address 10.1.28.5 255.255.240.0 secondary

ip address 168.167.60.5 255.255.252.0 secondary

ip address 168.167.60.2 255.255.252.0 secondary

ip address 10.1.16.5 255.255.240.0

no ip redirects

no logging event link-status

standby ip 10.1.28.1

standby 1 ip 10.1.16.1

standby 2 ip 168.167.60.4

GAB-ES-CR-G-RS-01-6509# sh vtp status

VTP Version : 2

Configuration Revision : 104

Maximum VLANs supported locally : 1005

Number of existing VLANs : 34

VTP Operating Mode : Client

VTP Domain Name : BTC-HO

VTP Pruning Mode : Disabled

VTP V2 Mode : Enabled

VTP Traps Generation : Enabled

MD5 digest : 0x18 0x72 0x26 0xFD 0x97 0x1C 0x84 0x02

Configuration last modified by 10.1.16.4 at 6-2-08 07:13:44

GAB-ES-CR-G-RS-01-6509#

What might be the problem here, plz help???

1 ACCEPTED SOLUTION

Accepted Solutions
Community Member

Re: How does HSRP works

At a glance, your VTP domains are synchronized - looking good from the output you displayed. The "master" (VTP server mode) is at revision 104. The "standby" (VTP client mode) is also at revision 104. Both switches have 34 VLANs.

VLAN creation and propagation to other switches has nothing to do with HSRP. VTP handles that duty using trunk links. A place to start looking is to verify that your trunks are up and working with "show interface trunk".

3 REPLIES

Re: How does HSRP works

HSRP does not carry VTP information and is not responsible for vlan propagation.

Have you enabled VTP password in your server switch by any chnace and not on others?

Also from your output i see that you have VTP version 2 enabled. so Make sure all your switches are running VTP version 2

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/configuration/guide/vtp.html#wp1029449

HTH

Narayan

Community Member

Re: How does HSRP works

At a glance, your VTP domains are synchronized - looking good from the output you displayed. The "master" (VTP server mode) is at revision 104. The "standby" (VTP client mode) is also at revision 104. Both switches have 34 VLANs.

VLAN creation and propagation to other switches has nothing to do with HSRP. VTP handles that duty using trunk links. A place to start looking is to verify that your trunks are up and working with "show interface trunk".

Community Member

Re: How does HSRP works

Hi,

Try the following thing,it will sure work for ur environment--

1-First thing both the master and standby core switch should be in vtp mode-server.All other client switch will be in client mode.

2- Configure the same vtp domain and password for all the core and client swicthes using following command--

vtp domain

vtp password

above two steps will solve ur vlan replication problem.

3-Better will be if u create different vlan for what u have assigned secondary ip in interface vlan 1.

Revert back the status .

regards,

Raj Kumar

695
Views
4
Helpful
3
Replies
CreatePlease to create content