Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How does switch detect "channel-misconfig" and err-disable the port?

Hi experts,

I had an incident yesterday that some guy mistakenly removed a port from the etherchannel. However the err-disable didn't catch it and had both ports running which caused a loop and broadcast storm... I want to know how exactly switch detects the channel-misconfig. I assume that it utilizes SPT? Here is my config:

Core switch:

interface range GigabitEthernet2/0/2,GigabitEthernet1/0/26

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 12 mode on

interface Port-channel12

switchport trunk encapsulation dot1q

switchport mode trunk

Access switch:

interface GigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

no channel-group 12 mode on (deliberately removed)

interface GigabitEthernet1/0/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 12 mode on

interface Port-channel12

switchport trunk encapsulation dot1q

switchport mode trunk


This is actually my test enviroment. I have err-disable enabled on both switches but no auto-recovery. Once I removed the G1/0/1 from the channel-group the errdisable did work and have all the ports blocked. However I just don't know why it didn't work at our client site...

BTW is it recommended to use PAGP/LACP for the L2 etherchannels between the switches or set them to statically "on"?

Thanks!

Difan

3 REPLIES
Cisco Employee

How does switch detect "channel-misconfig" and err-disable the p

Hi,

Yeap STP should take place in this case. This is how it works in short:

http://www.cisco.com/en/US/tech/tk389/tk213/technologies_configuration_example09186a0080094647.shtml#tshoot

Not also sure what happened in your client's scenario - possibility that STP loop was very fust and strong and e.g. affected CPU thus err-disable mechanism did not trigger. But it is just a guess.

Nik

New Member

How does switch detect "channel-misconfig" and err-disable the p

Thank you Nik! Your explaination makes sense. I think it is good enough to explain to the customer.

So do you always recommend using pagp or lacp and avoid hard coded on at all times?

thanks!

difan

Cisco Employee

How does switch detect "channel-misconfig" and err-disable the p

Hi

I would say PAGP or LACP give you more features to control the etherchanel negotiation and operation. SO those can be more reliable. However all should be considered based on the support for those feature on the switches yourun etherchannel between.

In this case LACP or PAGP can be more effective though anyway should be tested first on that environment.

Nik

697
Views
4
Helpful
3
Replies