Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

How to access multiple VLANs from one pc?

Good day,

I have a quick question, this is the situation:

- 1x layer2 switch that has these VLANs specified:

VLAN11: Manufacturing 192.168.1.x 255.255.255.0

VLAN12: Management 192.168.2.x 255.255.255.0

-1x desktop pc with 1 ehternet card

Is it in any way possible to have the desktop pc connected to the switch and have it communicate with both VLANs?

I thought it wasn't possible but I may be wrong because I am not that experienced yet.

Thanks in advance,

Best Regards,

Joris

Everyone's tags (2)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Purple

How to access multiple VLANs from one pc?

Yes You are absolutely right.

Router or layer3 switch or 2 NICs will solve tthis problem.

Regards

Please rate if it helps.

Please mark this question as answered, if your satisfied with solution.

3 REPLIES
VIP Purple

How to access multiple VLANs from one pc?

HI Joris,

May be I understand your question correctly.

You can access any vlan...from 1 pc.

All these routing done by layer 3 switchor a router.

If you are using layer 3 switch then you can use this config :

InterVLAN_Switch_Layer3.jpg

Switch configuration

ip routing
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access

interface Vlan10
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0

And on hosts just assign IP addresses and default gateways (to the corresponding interface VLANs) -> hosts in different VLANs can communicate.

Regards

Please rate if it helps.

New Member

How to access multiple VLANs from one pc?

Thank you,

The point is, there is no router or no layer3 switch.

Only a layer2 switch. So I assume this is impossible this way?

Could only be solved by:

- Using a layer3 switch

or

- Using a router

or

- Using a 2nd ethernet card in the desktop pc

Is that correct?

Best Regards,

Joris

VIP Purple

How to access multiple VLANs from one pc?

Yes You are absolutely right.

Router or layer3 switch or 2 NICs will solve tthis problem.

Regards

Please rate if it helps.

Please mark this question as answered, if your satisfied with solution.

9935
Views
0
Helpful
3
Replies