Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

How to conf Sticky in ACE

Hi All,

I have configured sticky in ACE but show status sticky but it is showing zero connection and show database sticky showing empty..

4 REPLIES

Hi,

Hi,

 

What is the ACE model, which you are using now and how did you configured sticky now on your device?

 

Example of IP Address Sticky Configuration

The following example illustrates a running configuration that defines IP address stickiness.The IP address stickiness configuration appears in bold in the example.

In this configuration, the ACE uses IP address stickiness to stick a client to the same server for multiple subsequent connections as needed to complete a transaction using the client source IP address, the destination IP address, or both.

access-list ACL1 line 10 extended permit ip any any

probe icmp ICMP

  interval 2

  faildetect 2

  passdetect interval 2

rserver host SERVER1

  ip address 192.168.252.240

  inservice

rserver host SERVER2

  ip address 192.168.252.241

  inservice

rserver host SERVER3

  ip address 192.168.252.242

  inservice

serverfarm host SFARM1

  probe ICMP

  rserver SERVER1

    inservice

  rserver SERVER2

    inservice

  rserver SERVER3

    inservice

sticky ip-netmask 255.255.255.255 address both SGROUP1

  timeout 20

  replicate sticky

  serverfarm SFARM1

class-map match-all L4STICKY-IP_115:ANY_CLASS

  2 match virtual-address 192.168.120.115 any

policy-map type loadbalance first-match L7PLBSF_STICKY-NETMASK_POLICY

  class class-default

    sticky-serverfarm SGROUP1

policy-map multi-match L4SH-Gold-VIPs_POLICY

  class L4STICKY-IP_115:ANY_CLASS

    loadbalance vip inservice

    loadbalance policy L7PLBSF_STICKY-NETMASK_POLICY

    loadbalance vip icmp-reply

    nat dynamic 1 VLAN 120

interface vlan 120

  description Upstream VLAN_120 - Clients and VIPs

  ip address 192.168.120.1 255.255.255.0

  fragment chain 20

  fragment min-mtu 68

  access-group input ACL1

  nat-pool 1 192.168.120.70 192.168.120.70 netmask 255.255.255.0 pat

  service-policy input L4SH-Gold-VIPs_POLICY

  no shutdown

ip route 10.1.0.0 255.255.255.0 192.168.120.2

It Depends on your scenario as well. But this type of sticky is the basic method get the sticky table created and worked out. you can restrict it only with source not with destination something like that you can do with this.

 

 

Regards

Karthik

New Member

PFA... Please check the

PFA... Please check the attached conf but it is not showing the sticky connection..kindly suggested me any changes required from side conf...
 

New Member

c4710

c4710

New Member

This conf is good .. my

This conf is good .. my sticky conf is working fine...thanks for your help...

34
Views
5
Helpful
4
Replies
CreatePlease to create content