Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

How to configre point to point connection

Hi Experts,

We have two Sites:

Site A has CISCO 2960

192.168.5.0/24

Site B has CISCO 2960

192.168.51.0/24

For Both the sites we got point to point line 10Base T with capacity of 10 Mega bits per second (As this is a 10Mbit/s Point to Point circuit, there are no IP addresses associated. At both ends, the ports will be configured to 10BaseT, Full Duplex. The circuit routed over MSP from the Site A to Site B, and then picks up a leased line to the ‘B’ end.).

I think we will have to trunk ports on both of these switches in order to get this working. As both ends have different private networks please suggest how to get it working.

Please guide how to get it working

Everyone's tags (2)
10 REPLIES
New Member

How to configre point to point connection

Hi Experts,

Please reply on my query, i need to impliment this point to point line.

What is the best way to configure this line.

Thanks

Pankaj

How to configre point to point connection

Hi, ok, here s a shot although not sure what you want exactly

Define a new vlan on both switches and call it "transport"

Define interfaces on both switches in that same vlan with a smail subnet

Lets say something like

switch A:

vlan 10

name tranport

interface Vlan10

desc transport

ip address 10.1.1.1 255.255.255.248

ip route 192.168.5.0 255.255.255.0 10.1.1.2

switch B:

vlan 10

name tranport

interface Vlan10

desc transport

ip address 10.1.1.2 255.255.255.248

ip route 192.168.51.0 255.255.255.0 10.1.1.1

Connect the switches and place the ports in vlan 10.

if this is what you look for anyway.

New Member

Re: How to configre point to point connection

Hi Engelen,

Please see if you suggested this to me:

cisco1 at SITE A:

configure terminal

(config)#vlan 20

(config-vlan)#name VLAN0020Transport

(config-vlan)#

ip address 10.1.1.1 255.255.255.248

(config-vlan)#

ip route 192.168.5.0 255.255.255.0 10.1.1.2

(config-vlan)#exit

(config)#interface Gigabitethernet 0/20

(config-if)#switchport mode access

(config-if)#switchport access vlan 20

(config-if)#exit

CISCO at SITE B:

configure terminal

(config)#vlan 20

(config-vlan)#name VLAN0020Transport

(config-vlan)#

ip address 10.1.1.2 255.255.255.248

(config-vlan)#

ip route 192.168.51.0 255.255.255.0 10.1.1.1

(config-vlan)#exit

(config)#interface Gigabitethernet 0/20

(config-if)#switchport mode access

(config-if)#switchport access vlan 20

(config-if)#exit

Once this is configured i will put lan cable from ISP to port 20 in CISCO2960 at both ends.

And resorces from 192.168.5.x must be able to access 192.168.51.x

Thanks

Pankaj

Re: How to configre point to point connection

Yes.

i forgot to mention the "no shut" but if the ios you have loaded can do this, this should work.

New Member

How to configre point to point connection

Hi pankaj

as both the sites are connected point to point . so u  can communicate between two subnets

1.by trunking the ports, connected at each end and allow the vlans  that u want to pass through from the trunk port

2. to communicate between the two vlans /subnets u need a router or an L3 switch which does the routing part at each end.

3. and again from L2 switch to router/L3 switch connected interface should be trunked

                                                or

1. create a single vlan at both end i.e use only one subnet either 192.168.5.0 or 192.168.51.0/24, if u dont have the router /switch at both ends

if u have L3 switch/router: here is the sample 

so first of create vlans at 2960 where it supports some part of Layer 3 functions but not routing part.

site A:

interface vlan 30

ip address 192.168.5.2 255.255.255.0

no shut

site B:

interface vlan 40

192.168.51.2 255.255.255.0

no shut

L3 switch:at site B      in the same way configure at site a with Ip change enable routing at both ends

create a vlan

interface vlan 30

ip address 192.168.51.1 255.255.255.0

no shut

enable routing

please rate helpful posts

regards

srikanth

How to configre point to point connection

Hi Pankaj,

Configure vlan at each site and the specific interface link below on which you are going to terminate the p2p link.


interface Vlan1143
description Vlan 1143 towards siteA 10 Mb line
ip address 192.168.89.1 255.255.255.0


interface GigabitEthernet3/10
description P2P link to siteB
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1143
switchport mode trunk

Please rate the helpfull posts.
Regards,
Naidu.

New Member

How to configre point to point connection

Hi Latchum,

Please suggest if you meant the below:

CISCO at SITE A:

interface Vlan20
description Vlan 20 towards site  B10 Mb line
ip address 192.168.89.1 255.255.255.0
interface GigabitEthernet0/20
description P2P link to siteB
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20
switchport mode trunk

CISCO at SITE B:

interface Vlan20
description Vlan 20 towards site A 10 Mb line
ip address 192.168.89.2 255.255.255.0
interface GigabitEthernet0/20
description P2P link to siteA
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 20
switchport mode trunk

So no need to add routes to 192.168.5.x and 192.168.51.x as at botht the ends subnets are different.

Thanks for your help

Pankaj

New Member

How to configre point to point connection

Hi Srikanth and Engelen,

Thank you so much for your reply, We have cisco 2960 at both ends and no router.

On Site A subnet is 192.168.5.0/24 and ON Site B subnet is 192.168.51.0/24

Please suggest if this is possible to connect this line with cisco2960 and communicate two diffrent subnets.

Waiting for your suggestion please.

Thanks

Pankaj

How to configre point to point connection

You should be able to do that with the 2960 depending on what IOS you are using. If you're using LAN Base I don't think that's possible. I think there is a IOS version with the 2960 that can handle static routing, but don't quote me on that.

New Member

How to configre point to point connection

Hi pankaj

as mentioned above by john .. i have tested this If u have a lan base no u cant communicate between two subnets. and if u have a higher version . i dont think u can achieve this. as 2960 is L2 switch cant do routing part or Layer 3 functions.

2960 cannot do IP routing

but

" I see some information on the Cisco website that 2948G switches can do Layer 3 functions."

Correct, in that the switch "understands" IP packets for some features.  E.g. "Advanced QoS".

For more information on the 2948G, please check its documentation:

http://www.cisco.com/en/US/docs/switches/lan/catalyst2948gand4908g/12.0_18_w5_22a/configuration/guide/co

please rate helpful posts

best regards

srikanth

3952
Views
0
Helpful
10
Replies
CreatePlease to create content