Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

how to configure 2 DHCP servers for 2 user vlans on a C3750

                   Hi,

I can't seem to find any info on how to configure 2 DHCP server pools on a C3750, to use with 2 user vlans.

The purpose is that users in vlan 1 should get an IP address from DHCP server1, and users in vlan 2 should get an IP address from DHCP server2.

Both DHCP servers are configured in a stack of C3750 switches, which acts a a L2 switch.

Anyone any idea, or better; experiences ?

Thx!

BR,

Lieven

Everyone's tags (7)
2 REPLIES

how to configure 2 DHCP servers for 2 user vlans on a C3750

interface Vlan1

ip address 192.2.1.1 255.255.255.0

ip helper-address 10.1.1.2

!

interface Vlan2

ip address 192.2.2.1 255.255.255.0

ip helper-address 10.1.2.3

how to configure 2 DHCP servers for 2 user vlans on a C3750

Here is one example to created below for one DHCP Server and change the DHCP pool name "D_MKT" something else for second vlan and so on.

Also make sure, you have created SVI interface as your default-router for the given vlan.

ip dhcp excluded-address 192.168.2.1

ip dhcp excluded-address 192.168.2.1 192.168.2.20

ip dhcp pool D_MKT

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 192.168.1.17

   domain-name mydomain.com

   lease 8

Hope that answers your question.

Thanks

Rizwan Rafeek

1302
Views
0
Helpful
2
Replies
CreatePlease to create content