Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

How to configure a new interface on a router

Hi

I hope someone can help me. I've got a 3640 router that has the following config

interface FastEthernet0/0

ip address 10.11.8.2 255.255.248.0

no ip redirects

ip route-cache same-interface

ip route-cache flow

no ip mroute-cache

speed 100

full-duplex

standby 1 timers 5 15

standby 1 preempt

standby 1 authentication xxxxx

standby 1 ip 10.11.8.1

!

interface FastEthernet0/1

ip address 10.29.2.2 255.255.255.0

no ip redirects

ip route-cache flow

speed 100

full-duplex

!

router ospf 1

router-id 10.11.8.1

log-adjacency-changes

redistribute connected subnets route-map PRIVONLY

redistribute static subnets

redistribute rip metric 120

network 10.11.8.0 0.0.7.255 area 0

network 10.17.2.0 0.0.0.255 area 0

network 10.29.2.0 0.0.0.255 area 0

default-information originate

!

router rip

version 2

redistribute ospf 1

network 0.0.0.0

default-metric 30

!

What I'd like to do is create a new VLAN on the same connection that is coming off of fa 0/0 so instead of just 10.11.8.0/21 I want to have a 10.32.0.0/16.

My question is how can I change the above config to accomodate a new vlan? I think I need to create subinterfaces, but I was worried about what it might affect given the above config. Also on the switch port do I need to convert the port to a trunk link?

Thanks in advance

Dan

1 REPLY
Hall of Fame Super Blue

Re: How to configure a new interface on a router

Hi Dan

Yes you will need to use subinterfaces and the switchport will need to be a trunk port.

For arguments sake let say

10.11.8.0/21 is vlan 10

10.32.0.0/16 is vlan 20

int fa0/0.10

encapsulation dot1q 10

ip address 10.11.8.2 255.255.248.0

+ other config you have

int fa0/0.20

encapsulation dot1q 20

ip address 10.32.x.x 255.255.0.0

+ additonal config you need

As alreay said you need to convert your switchport to a trunk port.

HTH

Jon

116
Views
5
Helpful
1
Replies
CreatePlease to create content