Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

How to configure Ether-channel between 6513 switches

Hello ,

I am trying to configure layer 2 ether channel between two of my core switches which were connected using fiber.

CS1 ( 10.1.1.1)     -----------------------------  CS2 ( 10.1.1.3) CS2 is the standby hsrp switch. we are using eigrp and pvst method.

Gi 13/14                                      Gi 3/1

Gi 13/15                                      Gi 3/2

Gi 13/16                                      Gi 3/3

Gi 13/17                                      Gi 3/4

Cs1: on all ports

switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address

channel-group 1 mode on
end

and created  port-channel 1

interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
end

Cs2: on all ports

switchport
  switchport trunk encapsulation dot1q
  switchport mode trunk
  no ip address

channel-group 1 mode on

end

nd created  port-channel 1

interface Port-channel1
  switchport
  switchport trunk encapsulation dot1q
  switchport mode trunk
  no ip address
end

After i did this i lost remote connectivity to both the switches and had to remove the configuration.

Error logs on CS1 core switch:-

Jun  3 14:30:36.293 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Gi13/14, putting Gi13/14 in err-disable state
Jun  3 14:30:36.345 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Gi13/15, putting Gi13/15 in err-disable state
Jun  3 14:30:36.517 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Gi13/16, putting Gi13/16 in err-disable state
Jun  3 14:30:36.733 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/14 in err-disable state
Jun  3 14:30:36.733 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/15 in err-disable state
Jun  3 14:30:36.208 UAE: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/14 in err-disable state
Jun  3 14:30:36.292 UAE: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/15 in err-disable state
Jun  3 14:30:36.348 UAE: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/16 in err-disable state
Jun  3 14:30:36.733 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Po1, putting Gi13/16 in err-disable state
Jun  3 14:30:36.913 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Gi13/15, putting Gi13/15 in err-disable state
Jun  3 14:30:37.029 UAE: %PM-SP-STDBY-4-ERR_DISABLE: channel-misconfig error detected on Gi13/16, putting Gi13/16 in err-disable state

I am confused in the following things -

1) Is it the right way for creating Layer 2 ether channel  ( Does layer2 eth channel requires manual port-channel to be created?)

2) Since i am not assgning ip to these gig interface can i used pagp/lacp  method and which is the best in this scenario?

3) Wouold like to know the full configuration for the above scenario  using auto /lacp /pagp method?

Highly appreciate all your efforts.

Regards,

KA.

6 REPLIES
VIP Super Bronze

Re: How to configure Ether-channel between 6513 switches

Hi Karim,

Try changing you channel group mode to desirable mode and test again

here is link to follow:

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SXF/native/configuration/guide/channel.html#wp1020436

HTH

Reza

New Member

Re: How to configure Ether-channel between 6513 switches

Hello Raza,

Thanks for your reply!

I just want to know why the Error -disbale message have come on the core switches.

in layer 2 etherchannel do i need to create a port channel oor it gets created automatically.

Regards,

KA.

VIP Super Bronze

Re: How to configure Ether-channel between 6513 switches

Hi Karim,

Yes, you still need to create the portchannel.

but this time use PAGP or LACP and test again

HTH

Reza

New Member

Re: How to configure Ether-channel between 6513 switches

Hi Karim,

This will be very easy for you. Before getting started make sure you shutdown the physical interfaces that will be used in the etherchannel on at least one of the 6513's before getting started since sometimes the order of operation on configuring the EC may cause ports on the EC to err-disable.

Basically all we have to do is make sure everything on both switches for the EC matches! This means physical ports as well as the port channel interfaces. That's it.

on 6513 #1 and 6513#2

int range g13/14 - 17

switchport

switchport trunk encap dot1q

switchport mode trunk

channel-group 1 mode on    (please not the port-channel interface 1 is automatically created.

interface port-chanel 1

switchport

switchport trunk encap dot1q

switchport moe trunk

channel-group 1 mode on

Repeat the same for interfaces g3/1 to g3/4 for 6513#2

Please rate if this post helps.

Kind Regards,

Brandon

New Member

Re: How to configure Ether-channel between 6513 switches

Karim,

Brandon is correct...Just make sure when you are placing the interfaces in PO1, you dont already have a PO1 created.  You could either place the interfaces in the wrong port channel, or an err-disable may occur if you place them in an existing PO where the interfaces are mismatched configurations.

Also, dont forget to trunk your VLANs if that is your intent 

Bruce.

New Member

Re: How to configure Ether-channel between 6513 switches

KA

The errs come this way.  When you configure an etherchannel between two switches, you do it one at a time, right.  As long as they are connected, at one moment one switch will have the config and the other will not - that is where the "misconfig" is coming in.  As soon as this is detected, the involved ports will be placed into err-disabled state.  This has caused a lot of misery for network engineers who end up cutting off sections of their networks (pray to God that is not where the exchange server is).  The best way to configure an etherchannel if you do not want to disable the ports first (as one good engineer suggested somewhere) is to use the following command:

"no spanning-tree etherchannel guard misconfig" on both switches. This is a global config command and is applied across the entire switch.

This way comms continues to happen - and no switch will see any misconfigs as you carry out your configurations. The etherhcannel guard feature is on by default and it is the one that reports on this and err-disabled the ports as soon as it notices a misconfiguration on the etherchannel.

It is a useful feature so after you finish configuring and your port-channel is happy - turn it back on as follows:

"spanning-tree etherchannel guard misconfig"

Cheers

Sydney

1748
Views
0
Helpful
6
Replies
CreatePlease to create content